DVBSky S960CI has suddenly started to oops with kernel NULL pointer dereference

  • Hi everyone,

    this has me a bit stumped. I've been running LibreELEC 9.2 on a Raspberry Pi 4 for a couple of months now, with Tvheadend happily using a DVBSky S960CI USB tuner.


    That worked just fine, until about a week ago when I suddenly started seeing these oopses (which appear right when I plug the tuner's USB cable into the rPi):

    What's weird is that when this occurred a week ago, I unplugged the tuner to come back to it a day later to troubleshoot, and when I tried to do that and rebooted my rPi and plugged the tuner back in, the problem was gone and the tuner was functioning normally.


    Then it worked for another few days, and now the problem is back and appears to be permanent. Reboots don't help, simultaneously power cycling both the rPi and the tuner's power supply doesn't either. As soon as I plug the tuner back in, I get this oops.


    I must confess, I don't even know where to start looking for a potential root cause. Can someone enlighten me where this oops could be coming from, and what I can do to avoid it? I would be most grateful for that. Thanks in advance for any ideas!

  • Could be a hardware issue with the DVBSky. I had S960 tuner which gone bad after about 3 years.

  • Thanks — hmmm, that would be saddening considering that tuner sat around in a box for some time and I just started using it like a couple of months ago. If you have ideas for differential diagnosis to ascertain that it is indeed a hardware issue, or even for things to try to fix it, I'd be happy to try those out!