Raspberry Pi 4: No bluetooth adapter found

  • Hello,


    I already asked on kodinerds.net but got no answer. Now I'd like to dig a little bit deeper in my problem. Since two days I have the problem, that Kodi doesn't pair with my Harmony Hub anymore. The Hub shows a red led and when I enter Kodi in the LibreElec section, the "bluetooth" menu item tells me "bluetooth is deactivated", which is not correct, when I look at "connections" menu item.

    Then I deactivate bluetooth and activate it again. Now I see "No bluetooth adapter found" in the "bluetooth" menu item. I also tried to press the pairing button on the Hub, after I re-activated bluetooth, but that doesn't change anything.


    Now I wanted to check, if bluetooth is found in LibreElec at all. But what a pitty I couldn't find a command to list bluetooth adapter or something like that. Commands from other Linux didn't work as well.


    Could you please help me to get my Hub working again with Raspberry Pi?


    Thanks and kind regards,


    Dirk

  • Thanks a lot, Irusak, I'm just running a scan with bluetoothctl scan on. Following the documentation I found it may take a little bit longer. It should at least find my smartphone, because the hub still shows a red led.


    Kind regards,


    Dirk

  • Hmm, running "bluetoothctl scan on" didn't bring any results and was running for over an hour, until I skipped it. Also my smartphone's bluetooth was activated, so I expected it to find at least this.


    Btw.: I use Raspberry Pi 4 Bluetooth, no external bluetooth adapter.


    Any ideas, what I can try? E.g. activating bluetooth from shell? Or are there any logs that could contain information,...?


    Thanks and kind regards,


    Dirk