Turning the TV on after libreelec

  • I have a Libreelec install on an old Nvidia/Acer HTPC.

    # less /etc/release

    A Kodi 18.2 Leia build.

    I have shares available over SMB, and DLNA.

    If I boot up the machine without the HDMI lead plugged into the TV. When SSHing into the box usually after a period of time, I can sometimes see eventlircd eating up pretty much all of the CPU.

    Anyway I thought it might be Kodi waiting on a signal. Something like hanging on an infrared remote press. But SSHing in and checking the processes - Kodi doesn't appear to be booted.

    If I plug the HDMI lead into the TV and turn it on at this point sometimes I get nothing.

    I just tried this after about a five minute wait. And I saw a message about Xorg not starting and then it sprang into action and Kodi started. So it's a little intermittant and hard to reproduce.

    Anyway, it's useful to know that if Kodi is not booted/running, DLNA doesn't appear available. But the Samba shares are.

    I'm not sure if the nigh on 100% CPU consumption for eventlircd is an issue or not?

    The machine shuttles between being near the TV, to being tucked away under the stairs headless. And when headless, it would be nice to think it's idling away not consuming much in the way of resource.

    I guess I could replace Kodi's DLNA shares with another daemon, as a workaround for DLNA sharing.

    Or is there another method to run Kodi headless? Could be useful for me to just play audio, via a Kore remote if connected to a stereo say. Am I missing something?

    I guess I'm thinking if plugged into the TV, start as usual, if not, start Kodi headless.


  • Thank you, okay I have updated to 9.2.

    $ cat /etc/release

    In top: 104 mins near 97% cpu for eventlircd.



    # cat /proc/loadavg
    1.09 1.05 1.03 4/131 14139

    Is the system effectively doing nothing at this point, so all resources are pointed at eventlircd?

    I'm not sure if I'm understanding this correctly.

    Okay, connecting back to the TV, I have system messages, followed by a blank screen.

    I tried:

    # killall eventlircd

    Then kodi emerged on the screen.