LibreELEC-RPi4.arm-9.1.501 upgraded from .001 ar RPi4 messes HDMI

  • Something is wrong with the HDMI signal with latest Beta1. TV returns to RPi4 connected HDMI1 automatically after power up. Previous versions did not have this problem. Now RPi4 acts like CEC is turning the port on its own.


    At RPi4 I have had LibreELEC-RPi4.arm-9.1.001 installed. I just upgraded manually to latest LibreELEC-RPi4.arm-9.1.501. CEC is turned off (I verified).


    Description: I use HDMI2. (RPi4 is connected to HDMI1 with main menu screen of Kodi being pasive). Turn off TV with HDMI2 active. Turn TV back on to the same HDMI2 port. HDMI2 source is displayed. After few seconds, HDMI1 port on myTV activates on its own and switches to RPi4 HDMI1. I must manually select HDMI2 to return to where I was.


    I can see and verify my remote is not sending any codes and can not cause this problem. My remote turns on TV on HDMI2 and waits. When picture (HDMI2) displays, TV is switched to RPi4 HDMI1 on its own in a second or two. Like CEC is requesting activation of that port.


    But, if I turn TV off with RPi4 HDMI1 port active, I can normally turn TV on and remote will switch it to HDMI2 after few seconds.


    If I am at HDMI2 and restart RPi4, it will not switch to HDMI1 when LE9 boots.

    Seems like a bug. Can it be at least manually overriden? I would prefer answer than blindly trying to reconfigure HDMI port on my RPi4.

    Edited once, last by pila ().

  • You can configure the behaviour of the PI in the following menu: Settings -> System -> Input -> Pheripherals -> CEC Adapter
    Hope this will help.

  • You can configure the behaviour of the PI in the following menu: Settings -> System -> Input -> Pheripherals -> CEC Adapter
    Hope this will help.

    No help since I wrote: "CEC is turned off (I verified)." CES is off. Same as in the version before it.

  • When TV is working on HDMI2, if RPi4 is powered on, it will also turn on HDMI1 to which RPi 4 with latest LE beta is connected without a reason.


    Looks like CEC is active even when it is disabled.

  • KODI CEC Adapter config may help, give it a try. You may disable this function in the menu of the TV as well. Or the ultimate solution to use a "CEC less" adapter.