Raspberry PI 4B, Sharp Aquos (~2011), LibreElec = Scrambled Video

  • Hi Folks,

    I'm new to the forums and LibreElec in general. I'm having a problem getting LibreElec working with my Raspberry PI4B and my old Sharp Aquos ([email protected], ~2011, based on firmware date). I've tried flashing the (and I realize it's still Alpha) previous (Alpha-001) and current (Alpha-002) version of LibreElec for the Pi4B with Etcher, the LibreElec flasher and Win32DiskImage on several different sdcards. These are completely fresh installs, no modifications to the config.txt. The results are I can see the software booting up based on the irregular flashing the PI4's led, which after a while stops flashing however I'm getting this from the tv and even though I've used nmap to ensure I'm trying to SSH in to the correct ip address of the PI4, I only see port 80 open, there's no ssh server running. My router is configured to issue a static IP to the PI4's mac address and pinging the Pi4 works.

    I'm stuck and could use some assistance as to fixing the problem.

    Thanks for taking the time to read my ramblings:?:

    Edited: Afterthough, I've tested the Pi4 with Raspbian desktop version and that work, so I know it's not a hardware issue. Thanks

    Edited once, last by diggmc ().

  • Edit the cmdline.txt file on the FAT partition of the SD card and add "ssh" (after "quiet", with a space between) - ths will enable ssh. You can do this from Windows, but make sure you use an editor that uses unix line endings, like Notepad++

    Then ssh in and post the outputs of the following commands

    1. journalctl -a | pastebinit
    2. tvservice -s
    3. tvservice -m CEA
    4. tvservice -m DMT
    5. pastebinit .kodi/temp/kodi.log

    BTW: Do you see the LibreELEC splash screen when the system starts or is the screen scrambled from the beginning?

    so long,


  • Im at work right now but I'll try your suggestions as soon as i get home. Unfortunately no, i don't see the splash screen, just what you see in the photo. Thank you, at least if i can ssh into it, I've got a hope of diagnosing the problem.

    P.S. I'm a VI guy 😁

  • Hello Hias,

    Well there's good news and bad. First the good; adding ssh to the cmdline.txt file did indeed fire up the ssh server and allowed me to access the system.

    Now the bad, all three 'tvservice' commands appeared to hang the ssh session and offered no output at all. As for the journalctl -a & kodi.log. I'm not familiar with the 'pastebinit' command but I assume it has something to do with the pastebin service. Unfortunately this setup has no internet access, so I've uploaded the output from those commands to my Google drive and offer links to them, rather that try and post a wall of log files here I hope that's acceptable.

    Output from journalctl and kodi.log and edid.dat

    I very much appreciate the help.

    Thank you again

    Update: I noticed in the journalctl output something about "consider forcing hotplug if HDMI is attached", so I enabled hdmi_force_hotplug=1 in the config.txt file ane rebooted. Unfortunately I am not getting any video output, not even the garbled screen but I do get information from the 'tvservice' commands now:

    LibreELEC:~/.config # tvservice -s

    state 0x6 [DVI CUSTOM RGB full 4:3], 1024x768 @ 60.00Hz, progressive

    LibreELEC:~/.config # tvservice -m CEA

    Group CEA has 4 modes:

    mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive

    mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive

    mode 95: 3840x2160 @ 30Hz 16:9, clock:297MHz progressive

    mode 97: 3840x2160 @ 60Hz 16:9, clock:594MHz progressive

    LibreELEC:~/.config # tvservice -m DMT

    Group DMT has 1 modes:

    (prefer) mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive

    Edited 2 times, last by diggmc ().

  • Hi (again),

    I appear to be making some progress. After putxing about with tvservice, I've managed to get the following. Only problem is that the screen stays black for a while and the tv's firmware kicks in reports "retrieving data". I think the problem is mode 81 wants 60Hz and TV service -s is reporting 59Hz.

    LibreELEC (official): 9.1.002 (RPi4.arm)

    LibreELEC:~ # tvservice -s

    state 0xa [HDMI CUSTOM RGB full 16:9], 1366x768 @ 59.00Hz, progressive

    LibreELEC:~ # tvservice -m CEA

    Group CEA has 18 modes:

    mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive

    mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive

    mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive

    mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive

    mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced

    mode 6: 720x480 @ 60Hz 4:3, clock:27MHz x2 interlaced

    mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced

    (native) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive

    mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive

    mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive

    mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive

    mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced

    mode 21: 720x576 @ 50Hz 4:3, clock:27MHz x2 interlaced

    mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced

    mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive

    mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive

    mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz progressive

    mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive

    LibreELEC:~ # tvservice -m DMT

    Group DMT has 11 modes:

    mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive

    mode 5: 640x480 @ 72Hz 4:3, clock:31MHz progressive

    mode 6: 640x480 @ 75Hz 4:3, clock:31MHz progressive

    mode 8: 800x600 @ 56Hz 4:3, clock:36MHz progressive

    mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive

    mode 10: 800x600 @ 72Hz 4:3, clock:50MHz progressive

    mode 11: 800x600 @ 75Hz 4:3, clock:49MHz progressive

    mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive

    mode 17: 1024x768 @ 70Hz 4:3, clock:75MHz progressive

    mode 18: 1024x768 @ 75Hz 4:3, clock:78MHz progressive

    (prefer) mode 81: 1366x768 @ 60Hz 16:9, clock:85MHz progressive

    LibreELEC:~ #

  • ...and I continue to make progress. I added the following lines to the config.txt:




    Now when I boot, I see the title page/Libreelec logo but the screen get garbled when (I assume) switching to Kodi.

    I recall reading something about modifying some Kodi configuration XML file to fix these problem but I don't recall where. The quest continues...

    Edited: I'm stuck now. I found what I think are incorrect values in the kodi guisetting.XML but every time I reboot my changes are reverted.


    Edited 2 times, last by diggmc ().

  • Thanks for the info, I've informed popcornmix (one of the RPi devs) about it - it's a bit puzzling and I'm not 100% sure what's going on/wrong there.

    so long,


  • I just noticed that the latest RPi firmware contains a fix for 1366x768 mode - see bug discussion here rpi4 hdmi not working with motorola atrix lapdock · Issue #1202 · raspberrypi/firmware · GitHub

    Testing with that might be worth a try (drop hdmi_drive/group/mode from config.txt and only keep hdmi_force_hotplug=1). Use the following commands to update to the latest firmware:

    1. mount -o remount,rw /flash
    2. wget -O /flash/start.elf https://github.com/raspberrypi/firmware/raw/master/boot/start4x.elf
    3. wget -O /flash/fixup.dat https://github.com/raspberrypi/firmware/raw/master/boot/fixup4x.dat

    so long,


  • Hello Hiss,

    Good catch, unfortunately no joy in LibreElec-ville. I tried your suggestion by replacing start.elf/fixup.dat and commenting out the hdmi_drive/group/mode but upon reboot, I got no video at all, just a black screen. So I re-added the hdmi_drive/group/mode, which gave me the splash screen and then a black screen as opposed to the pre-start.elf/fixup.dat which was the splash screen and then garbled (similar to my original photo).

    So I guess these changes could be considered a half step forward.

  • An interesting observation about the original start.elf/fixup.dat. If I poke about on the keyboard attached to the PI4 with those, I can hear Jodi's whoosh/beeps but with the updated versions, there's no sounds at all. This leads me to believe that either Kodi has crashed or there's an audio problem with them.

  • I've poked the hdmi experts for advice. Can you report output of "tvservice -s" when using raspbian (and display is working)?

  • Hi,

    Thanks for taking time to help me out. TVservice is reporting:

    state 0xa [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60Hz, progressive

  • state 0xa [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60Hz, progressive

    Okay so that is using a more standard resolution so not surprising that worked.

    Was that the default resolution when you booted raspbian or did you change it yourself?

  • Its been changed since I started fooling about with Libreelec. As I recall when I first hooked up the pi the desktop defaulted to 1024x768 with raspian

  • Sort of, I get the scrambled screen (as in my original photo during the Linux boot aka dmesg information) and then the raspian desktop appears but TVservice reports the aspect ratio of 4:3 and the resolution to be 1024x768 progressive.

  • That sounds like 1366x768 doesn't work on raspbian (the scrambled display should be showing a dialog saying "do you want to keep this resolution" which is timing out and putting you back to the old resolution)

    Can you confirm that it still fails with latest firmware (using rpi-update on raspbian).

    Assuming it does then this is a firmware issue rather than a kodi issue and reporting it here would be best:

    Issues · raspberrypi/firmware · GitHub