Nightly images for A64, H3, H5, H6 and R40 boards

  • Hello,


    Trying LE11 nightly builds with a Pine A64+.

    DVB-T TV dongle well recognised, tvheadend works ok.

    But video is black and red ... (black + moving parts of the image displayed in reddish colours). Same with LE10 (that's why I tried LE11 nightly builds).


    I get a normal image by disabling deinterlacing in the video options of Kodi, but then it seems to switch to software deinterlacing which is not really smooth. And I need to do that again for each channel...


    Is hardware deinterlacing supported on A64+ ?


    Thanks

  • I think I experienced something like that on occasion on OrangePi PC2 (H5), so it could be driver issue (same driver as on A64). I'll look into it when I find time.

  • oddebian Can you dump your DVB-T stream to a file and test if offline playback also causes same issue? If it still does, please provide me that file. I have Pine64+ board and if I can reproduce your issue, debugging is much easier. I have an idea what could be the problem in the driver, but I need realiable way to reproduce it in the first place.

  • oddebian I tested all my interlaced videos (MPEG2 and H264) on Pine64+ and they all work. I would really need your video sample to reproduce it.

  • I'll try that, thanks.

    How do I use this tar file ?

    Am I supposed to overwrite the existing "overlays" directory on my sd card with the "rdparty/bootloader/overlays" directory of the tar file ? And the same with the root sd directory with the "target" directory ?

  • Issue still there with your update on 10.0.2. Strange.

    So, to sum up :

    1) You can reproduce my issue with the official 10.0.2 version

    2) Issue is still there for me with nightly build, but not in your test of the same nightly build

    3) Issue disappears in any of your own builds

    4) Still there for me in official 10.0.2 + your update


    I checked again my board : it is a 2Gb Pine A64+ (the one with micro usb power, so not the LTS board) and the images are the right ones.

  • Just tried nightly image (12 may), same problem. Black and red/blue tv play.


    (image used : LibreELEC-A64.arm-11.0-nightly-20220512-c12dcf6-pine64-plus.img)

    Edited 2 times, last by oddebian: Are there any data that I can dump into a file in order to help ? ().

  • oddebian Currently I can't think of any data that would help in narrowing down issue. Sadly only way to fix it, is to reliably reproduce it on my development system, but I don't have any success with that.

  • Can you give me the characteristics of you pine A64 board ? Maybe there's a difference ?

    Here's mine :

    Pine 64 A64+ 2Gb (two Gb version, not one) ram.

    Power is through Micro USB, so it is an A64+, not the LTS board (which comes with a Jack connector).

    I attach a picture for more details.


  • oddebian I have exactly the same board, with same markings on the board. So it must be something on SW side. I did few more tests with official LE 10.0.2 release and I managed to get corrupted deinterlacing only once. However, it stayed corrupted also over reboots until I plugged off power supply for few seconds and plugged it back on. After that, I couldn't reproduce it anymore. So it must be some issue which persists over boot. Maybe some clock setting. Can you provide output of cat /sys/kernel/debug/clk/clk_summary, executed during bad deinterlacing?


    EDIT: I managed to reproduce it once on latest, self-build image. However, reboot restored deinterlacing.