MiniDLNA tested and working on on LE 9.x

  • As I was searching for help with MiniDLNA add-on on LE 9.0.1 - I came across this post from Klojum on the Kodi forum:

    "We recently tested a version of MiniDLNA on a LibreELEC 9.x test build and it worked".


    I've tried and failed to get MiniDLNA working on LE about a year ago - could you please share your test copy of the conf file and the relevant file locations to edit and commands?

    Thank you!

  • Iridium

    Changed the title of the thread from “Klojum - MiniDLNA tested and working on on LE 9.x” to “MiniDLNA tested and working on on LE 9.x”.
  • How do I restart minidlna on LE using Putty commands?


    How do I point it to scan external USB? The default is

    media_dir=V,/storage/videos

    I'm using the string below - what's the correct syntax for USB source?

    media_dir=V,var/media/SSD-500

  • This is a copy of the post I made on Thoradia thread by accident.


    I've installed miniDLNA from default add-on library and got it running. The actual PuTTy cmd commands are:

    >>> systemctl start service.minidlna

    >>> systemctl stop service.minidlna

    >>> systemctl restart service.minidlna

    >>> systemctl status service.minidlna


    I now have LE 9.0.1 installed on the internal NVME drive and there are 2 external USB's - NTFS formatted as SSD-500 and WD3Tb

    LE mounts these USB's automatically at boot and shares them to local network across SAMBA - nothing to tweak there, apart from LE options.

    After installing miniDLNA add-on on LE, all you need to do is stop the service using PuTTy and edit minidlna.conf which is located here -

    \\192.168.1.LE_IP > Userdata > addon_data > service.minidlna > config > minidlna.conf

    When you 2-click on the file, it opens in Word and changes that you make are saved to conf in ASCII.

    After applying the changes - go back to PuTTy, start the service and check the status

    The most difficult part is providing correct path(s) to media sources. My "cleaned-up" <minidlna.conf> looks like this:


    media_dir=/var/media/SSD-500

    media_dir=/var/media/WD3Tb

    media_dir=./storage/downloads

    friendly_name=miniDLNA

    inotify=yes

    enable_tivo=no

    strict_dlna=no

    serial=12345678

    model_number=1

    notify_interval=1800


    miniDLNA builds a library very fast, all 3 sources are getting scanned and broadcasted across DLNA including artwork embedded in FLAC's

    Had a bit of trial and error with "downloads" before figuring out there should be a dot in <media_dir=./storage/downloads> line

    Very happy :) Hope someone finds this little [How-To] useful.

    Edited once, last by bpr323 ().

  • Recently I encountered a problem after renaming root folders with media files on one of the USB drives miniDLNA kept broadcasting the old folder structure and not finding files there even after restart of the service.

    Solution was to delete the "old" files.db file in

    \\Libreelec\Userdata\addon_data\service.minidlna\db\files.db

    and >>> systemctl restart service.minidlna

    Upon restart, miniDLNA creates a new files.db file and rescans and rebuilds library for 4Tb total storage in under 5 min !