Dual TBS 5520SE Libreelec 9.0.0 Intel Generic

  • Hi everybody,

    I have classic x86 setup and two dual T2 tuners. First is TBS 5281. I used it with Libreelec 8 and crazycat drivers. It worked fine.

    I just bought WinTV-dualHD. This tuner need kernel 4.1.17 and newer. So I have finaly updated to libreelec 9 and I can see WinTV-dualHD, but TBS 5281 stopped working:

    EDIT: I have done some more tests in ubuntu 18.0.2 LTS with 4.20 kernel. Drivers from TBS page can not be build (TBS Linux Driver is upgrated to v170330) and latest TBS opensource drivers (GitHub - tbsdtv/linux_media: TBS linux open source drivers) have same issue. I have created https://github.com/tbsdtv/linux_media/issues/155

    Edited once, last by iwik ().

  • TBS support requested remote access and check my setup, only reply from them was " please make sure the insert port is usb 2.0 ."

    I currently have it in virtual machine with USB 3 only, but error "cx231xx_send_usb_command: failed with status --32" was same like in setup with lenovo x230 and libreelec. My second tuner "Hauppauge WinTV-dualHD DVB" is working well in this setup.

    Maybe tdanicek can you provide your USB port version?

    Edited once, last by iwik ().

  • i think all usb 2.0 ports in modern hw connected to usb 3.x host controller (xhci host drivers), but provide power restricted to usb 2.0 standard.

    i have some old PC with Intel B75/Z77 chipsets - this contain separate usb 2.0 host controller (ehci) for usb 2.0 ports, and separate usb 3.0 host (xhci) for usb 3.0. All PC DVB USB devices work well in usb 3.0 ports, at least with LTS kernels (Ubuntu 14.04.x with 3.13, 4.4 kernels; Ubuntu 18.04 with 4.15)

    So please provide info about usb host controller.

  • I use Intel® NUC Kit NUC6CAYH. When I used LE 8.0.2 everything worked fine. The TBS 5281 was plugged into the same USB ports. After upgrading to LE 9.0.1, TBS no longer works.

  • So some issues in xhci drivers in latest kernels.

    Interesting. Maybe there will be more devices with cx231xx affected.

    My test virtual machine have this USB controller: USB controller: Renesas Technology Corp. uPD720202 USB 3.0 Host Controller (rev 02)

    It is pcie card passed to vm.

    I dont have Lenovo X230 right here, but accrording to spec it is "Mobile Intel QM77 Express Chipset"

  • About kernel panic and.the tbs5520se, it happened to me when I powered the tuner via a raspberry usb port, when the tuner is powered by an independant power supply no more kernel panic.

    Friend tell in detail the model of powered USB hub you are using, please thanks.

    What independent power supply are you using? jcoenen :thumbup:

    Edited once, last by Fran ().