Problems with Logitech Harmony One

  • Hey guys.

    I've been having a hard time getting my new Kodi setup running.

    For many years I've been running 2 x AppleTV2 with Kodi, and using my Logitech Harmony One to control, TV, Receivers and AppleTVs.

    But I finally had enough with lag and no more updates to Kodi, so I bought 2 Raspberry Pi 3 and 2 IR receivers (TSOP382).

    Decided on Libreelec and everything was running fine within minutes, but when I tried setting up my remote using this guide ModMyPi | Head Case OpenELEC IR Receiver Setup I started having problems.

    When I run the command mode2 -d /dev/lirc0 and press buttons on my remote the IR recives tons of data, so the assembling of the IR receiver looks fine.

    I thought I would keep it simple, so I just kept using the Logitech Harmony One set as a AppleTV remote while doing irrecord .
    But I kept getting and error during "Checking for toggle bit mask" where as soon as I enter a button I get "Cannot find any toggle mask.
    But I know for sure that RC6 has a toggle bit!"

    I also tried reconfiguring my Harmony One as a Microsoft Mediecenter remote, but still the same error.

    So I went back as an AppleTV remote and tried using irrecord raw mode, and it helped a little, but I could never get all buttons to work, like sometimes up, down, right would work but no left, and if I tried irrecord in raw mode again, some other buttons would stop working.

    Are there anyone here using a Logitech Harmony One, that can tell me what they have set their remote to and can possible share their conf file?

    If you need any more info, logs, screenshots or anything please do tell.