[9.X-devel] LibreELEC builds for g02ref/g18ref_th2 (Prima PM-6001, VS-IP166, VS-IP015, ...)

  • This is a LibreELEC build for g02ref/g18ref_th2 devices (Prima PM-6001, VS-IP166, VS-IP015, or other similar MX boxes)

    with Amlogic AML8726-MX/M6 SoC (Amlogic Meson6).

    It is based on current LibreELEC WeTek Play build and my code port for g02ref.

    It is using the WeTek Play LibreELEC Addons repository so you should be able to install binary addons from the official repository.

    Known issues:

    - no build-in dvb-S2 tunner support yet.

    - enable bootscreen text (tty0)


    - dvb-S2

    - vfd driver

    Installation instructions:

    It is a sdcard boot image, so you can just use the LibreELEC usb-sd creator to flash your card.

    so old bricked boxes can also be used for it ;)

    Download (updated 03 04 2019):




    Release img


    Addon VFD (Prima PM-6001, VS-IP166)


    special thanks for providing kernel & examples to:



    LibreELEC Device build source:



    + patch mkimage script to use ext3 for storage build/ old kernel package

    Supported devices:

    It is tested on VS-IP166 (videostrong)/Prima PM-6001. If your device has different remote try connecting USB keyboard.


    flash the image on a usb stick/hdd and copy the aml_autoscript from the first usb partition (FAT) to a sdcard (FAT) using common winpc.

    Plug in usb (port 1, rigth one on in my case) and sdcard, box will now load the image from usb port 1.

    Have fun :)

    Edited 21 times, last by emanuel4you ().

  • easy update via ssh:

  • Would this work on a vigica c70s ? I wrote the "LibreELEC-Amlogic_G02REF.arm-9.0-devel-20190106221300-df9076a.img.gz" to usb and booted with sd card. Wifi is working too. How do I enable dvbs2 now ?

    edit : I can't update to latest , I ssh , write update file , reboot but system opens like it forgets everything including time date wifi information and it also does not update. Can you include the update in a new img file ? And -how do I enable dvb-s2 ?- Thanks. Otherwise it works great.

    LibreELEC-Amlogic_G02REF.arm-9.0-devel-20190307225115-0e98e15.img.gz file link doesnt work. Was that the updated image ?

    Edited 3 times, last by patientx ().

  • That link is -still- not working.

    edit : the link is missing a word used the ones from previous ones and now downloading.

  • I have tested this image in may old tvbox and ot worked but I'm triing to install on internal flash but it doesn't work... Is this possible?

  • Even after I install tvheadend it says pvr is starting and hangs at %0. I don't think it recognises the device.

  • @patientx You first have to setup tvheadend. log in web interface and you can see if your addaper is recognised.

    Setting up an easy Linux Kodi with Live TV (LibreELEC)

    or see:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    @amelendez no I haven't made bootargs for nand boot. But high class sdcard is very cheep.

  • OK I am getting how to setup the tvaend but ... nothing saves between boots. Everything resets. Everytime I open libreelec I setup from zero. How to solve this?

  • Sounds to me like there is something wrong with your sdcard. Could you try an other one? Or you also can use an usb-stick on usb-port 1.

  • Take either a usb stick or a sdcard. But do not mix. after the first boot, the storage partition is adjusted, as with any libreelec.

  • My device doesn't boot from usb so I need the sdcard -only with amlscript file- to direct the booting to usb stick. And it boots from the 1st slot as you said but after booting and making changes etc. the next reboot, it forgets everything. Like it resets all the changes even file downloads , updates to system etc.

  • can you use sdcard only without usb?

    I tried that : not only it didn't work, it also somehow deleted the actual firmware on the device's main memory and I had to setup everything from zero. I think I'm done here thanks.

  • I wonder if it's possible for you to provide a zipped upgrade package instead of a disk image. My nand layout is different, but you seemed to have solved the issue with the box crashing