Astrometa T2Hybrid

  • I've recently bought an Usb Dvb-t/t2/c analog/fm stick. I knew there was no support in linux/libreelec but in windows works very well.

    The stick is better described here: tv tuner-lte,wifi router,mifi,mobile signal booster,tv tuner,Shenzhen NewSky Co., Ltd.. It has R828D+MN88473+CX23102.

    Recently saw this: [media] cx231xx: Initial support Astrometa T2hybrid - Patchwork, and so had little hope in linux support.

    Googling i've found this: howto: ubuntu 16.04 Tvheadend DVB-C/S(2)/T & non-DVB (ipcam/DV) rotate recording, and noticed that it could be more than a hope.

    In LibreElec 8.2.3 and latest milhouse builds, both dvb-t and dvb-c are recognized, but the stick can't tune or scan any services (in tvheadend).

    DMesg reveals a tuner frequency out of range error.

    Saw in howto: ubuntu 16.04 Tvheadend DVB-C/S(2)/T & non-DVB (ipcam/DV) rotate recording that "Still compared to the Microsoft Windows driver of the Astometa DVB T2, one issue remains with the current linux tuner driver which is an issue with tuning/scanning high frequencies/muxes leading to no channels or high error rates. This is however fixable by building you're own linux kernel module from the V4L2 media_build on linux kernel version 4.10.x and applying the r820t tuner patch suggested by Эдуард Мяги."

    Tried to build in Ubuntu media_build drivers and applied the patch suggested in howto: ubuntu 16.04 Tvheadend DVB-C/S(2)/T & non-DVB (ipcam/DV) rotate recording, that is

    Code
    1. sed -i '0,/air_cable1_in = 0x60;/s//air_cable1_in = 0x00;/' ../media/drivers/media/tuners/r820t.c

    This way my Astrometa T2Hybrid can tune some channels, scanning still doesn't work, but better than nothing.

    Can anyone help me to make it work in Libreelec? It's a very good usb stick and costs only 22 Euro.

    Thank you

    sdf

  • Thank you CvH,

    it seems to me I've already tried v 8.2.0, but maybe LE9 build ...

    thank you,

    sdf

  • How about this suggestion ?

    USB DVB-T2 HDTV Digital TV Stick Remote Receiver DVB-C DV ESY1 FM DAB - US$22.99

    Hi There, Yes it is Linux and Raspberry 2/3 compatible. The only Thing you need to do is :

    Remote to Raspberry using SSH first, after that enter those commands:

    Code
    1. cd /lib/firmware/
    2. # if v1 so use this command
    3. sudo wget http://palosaari.fi/linux/v4l-dvb/firmware/MN88473/01/latest/dvb-demod-mn88473-01.fw
    4. # if v2 (hybrid !?!) use this command
    5. sudo wget http://palosaari.fi/linux/v4l-dvb/firmware/MN88472/02/latest/dvb-demod-mn88472-02.fw
    6. sudo reboot


    I have a V1 tuner, but because I have no good UHF antenna so must wait for a while so I can test it.

    Yes I know you have a Hybrid tuner, but you can try MN88472 here Index of /linux/v4l-dvb/firmware

    or try to extract yourself at AstroMeta_integrated solution (choose hybrid driver)


    Good luck guy,

    Edited once, last by rfc_club ().

  • Quote

    Yes, I knew that.

    They're all hybrid 2832u realtek usb sticks.

    The difference is that I needed analog fm support.

    In Libreelec ther's no fm support (apart from rtl-sdr etc.).

    Also in windows these rtl2832u sticks aren't directshow compatible, as they don't expose an fm tuner dshow filter.

    Realtek has made available only a dll, so there are only few software that can use fm (and dab part).

    That is why I bought the Astrometa T2Hybrid, that has a directshow classic filter (and also analog in).

    Quote

    you can try MN88472 here Index of /linux/v4l-dvb/firmware

    or try to extract yourself at AstroMeta_integrated solution (choose hybrid driver)

    Thank you so much. Didn't know that there was a specific firmware already extracted from Astrometa drivers (was thinking doing it myself). I was using 88472.fw extracted from other sticks. Maybe that is the culprit.

    Will try and report.

    Quote

    Good luck guy,

    Thank you so much. You helped me a lot.

    Bye,

    sdf

  • It works!

    The problem is that my (latest) version of T2hybrid (conexant chipset) has 88473 demod, while the firmware extracted from Index of /linux/v4l-dvb/firmware was 88472 for the T2Hybrid, and 88473 for the fm/dab (realtek chipset).

    I needed 88473 for T2hybrid.

    Just to help anyone who wants to buy this stick, will tell what I've done.

    1) Downloaded Windows driver from Astrometa site (latest version) and unzipped it, and found the .sys file.

    2) I saw from README that the firmware was extracted (i suppose with the help of an usb sniffer) this way:

    Code
    1. dd if=AMDVBT2BDA.sys ibs=1 skip=169296 count=2271 of=dvb-demod-mn88473-01.fw

    3) so tried to do the same for my drivers, hoping the firmware was in the same place (in the .sys windows driver), and did

    Code
    1. dd if=AMDVBT2Hybrid.sys ibs=1 skip=169296 count=2271 of=dvb-demod-mn88473-01.fw

    4) copied the resulting .fw file to /lib/firmware, overwriting the older, and rebooted

    Now it works (in Ubuntu).

    Didn't test extensively, but now tuning works.

    The only thing is that can't use the new firmware in LibreElec (I copied it in /storage/.config/firmware), but it seems that the old .fw is used.

    There is a solution?

    Thank you,

    sdf

  • could you share an dmesg from the old and the new firmware ? there should be some version included

    btw could you upload the recent version that works ? So we could add it to the repo (maybe).

  • A little bump on this thread.

    Tried latest milhouse nightlies with all drivers combos.

    I have three usb dvb sticks:

    1) Astrometa T2 Hybrid DvbT/T2/C/Analog/FM Stick (15f4:0135);

    2) Dexatek/Logilink/MSI rtl2832 DVBT Stick (1d19:1101);

    3) Geniatech HDStar Dvb-S2 v 3.0 (14fd:3000).

    My results:

    A) Ubuntu 17.10 with media_build drivers compiled from git://linuxtv.org/media_build.git

    - All three stick recognized by TvHeadend

    - Astrometa and Hdstar no signal. Only Rtl2832 works

    B) Ubuntu 17.10 with drivers compiled from updatelee / v4l-updatelee — Bitbucket

    - All three stick recognized by TvHeadend and working

    C) Libreelec 8.2.3

    - All three stick recognized by TvHeadend

    - Astrometa no signal

    D) Libreelec 9.0 Default

    - All three stick recognized by TvHeadend

    - Hdstar no signal

    E) Libreelec 9.0 Crazycat

    - All three stick recognized by TvHeadend

    - Astrometa no signal

    F) Libreelec 9.0 Hauppauge

    - All three stick recognized by TvHeadend

    - Hdstar no signal

    Now my question. There's the possibility to join together these drivers and make all my sticks work in Libreelec?

    For example, Geniatech Hdstar 3.0 works perfectly in Librelec 8.2.3 but not in LE 9.0 with default drivers? Why? There has been a regression?

    Anyway, there's the possibility to reorder this "little mess"?

    Thank you,

    sdf

  • Astrometa hybrid issues related to V4L DVB drivers and this is same from all repos. So you have driver & signal issue for Astrometa (sometimes work, somtimes no)

  • Thank you crazycat for your answer.

    Tested the stick extensively, only related to dvb-t part (interested in fm also, but it seems to me no one coded drivers), and can tell that it works perfectly:

    1) with updatelee drivers;

    2) With Libreelec 9.0 default and Hauppauge drivers.

    Is it possible for you to look at that code and verify if there are differences with your drivers?

    This way with your drivers I could use all the three stick.

    Remember this is T2Hybrid (conexant 0135) and not the Realtek 0131 one.

    Thank you

    sdf

  • Thank you very much crazycat for your time.

    Maybe it's something firmware related?

    Can't verify in Libreelec (can't change firmware), but in Ubuntu the firmware that works (dvb-demod-mn88473-01.fw) is 2,2k from Palosaari site.

    Bye,

    sdf