Remote not responding for one minute after turning on TV

  • Hi,


    I'm investigating a weird problem: I'm using libreelec 8.2.1 on an Intel HTPC based on this board and with this remote (lircd is disabled of course). After switching on my TV (an old Samsung) the remote does not work for about one minute. After that delay it is working perfectly. I'm sure the problem is triggered by the TV set: If I press buttons with the TV turned off, I can see the control-LED of the USB dongle react on every keypress. As soon as I turn on the TV, the LED will not react at all. The problem vanishes after one minute. I already played around with CEC settings of the TV (turned CEC off completely meanwhile) and also tried various BIOS settings of the board. I even went as far as to recompile libreelec with CEC disabled, but still no solution. Does anybody have an idea what could cause this strange behaviour? Of course I can use yatse on my smartphone as a workaround and then switch to the remote after one minute, but it is still annoying as I prefer the remote over yatse.


    Btw, I'm using the dvb image from CvH as I recently switched to a digital devices v7a card which works absolutely perfectly! Kudos and big thanks to CvH for your work :love: But problem also exists with the official image (when using a DVB card that has already supported drivers there).


    I also have a Raspberry3 with the same remote, but there I do not have the problem. But it is connected to a different TV which might be the problem. Cannot test the raspberry on the problematic TV at this time of the year :)


    Alternatively I would be interested in recommendations for a good remote (time is more precious than money); preferably some wireless so I can hide the receiver behind the case...