Le Potato SBC (Libre Computer ​AML-S905X-CC)

  • Anyone got LibreELEC working on the "Le Potato" board? Any obvious reasons why the current builds would not work?

  • Thank you Kszaq. It works.

    I have a chinese box with s905x with your latest build and Le Potato with this test build.


    It seems like Le Potato UI is faster but the other box has more addons so I can't compare

    I can provide logs.

    pastebin.com/0suzzccy


    One thing I noticed is that the MAC address is always random after a reboot.

  • Thank your for your response. It doesn't work. Any reboot a different MAC and a different IP from the DHCP server.

  • Interested to see if it works for cata747 as I not test the one linked on Thursday, however the current image I can't get to boot on my Le Potato.


    Though personally have found it quite sensitive to boot from any images created for them compared to the few Pis I have.

  • I tried to write the image but there is something wrong. I am using dd and it doesn't create the LIBRELEC_DISK. The resulting sd it doesn't boot at all.

    I don't know if i am doing something wrong on my part. I'll try rufus or the official sd card creator but first i will download again the file.

    I will report soon.


    Edit: after all the tries, i wrote again the official img from the s905x folder and it works. I mean the mac address is still random.

  • Update: Libreelec SD Card Creator did the trick but unfortunately the MAC Address is still random. Three reboots with three different MAC Addresses.

  • Tomorrow I will ask a developer who has the board about ideas on the MAC address.


    In the meantime LoveRPi offered me a sample board so I should be able to solve that kind of issues much easier. :thumbup:

  • Create a file in udev rules folder under config, called 99-mac-address.rules

    Add these lines with whatever mac addresses you want. This will stop random macs etc.

    SUBSYSTEM=="net", KERNEL=="wlan0", RUN+="/sbin/ip link set dev %k address D8:FC:93:6F:29:2C"

    SUBSYSTEM=="net", KERNEL=="eth0", RUN+="/sbin/ip link set dev %k address D8:FC:93:6F:29:3C"

  • The first thing I tried by myself was this solution which I found in khadas vim post having the same mac address. Doesn't work I'm afraid.

  • Happy Holidays to everybody!


    I only wanted to report that the update image with 8.2.2.1 for Le Potato doesn't work. I tried sd card creator, rufus, i even let LE do the update and doesn't boot after. I don't have a log file.

    Same sd card, I downgraded to 8.2.1.2 and is working.

  • bo1e  cata747  LuRcH  Redferne Can any of you get me please a log from serial console when trying to boot 8.2.2.1? I need to see what the issue is to fix it. I repeat - I don't have to board, simply stating "it doesn't work" gives me no hints what should be fixed.