Posts by smp

    Just to make things clear: media_build has nothing to do with the issue from my original post. I made 2 versions (media_build and non-media_build) because some DVB devices only work with media_build drivers and some devices for whatever reason only work with default kernel drivers.

    The issue occur with and without media_build as long as the build is based on 4.9 kernel.

    Kernel 4.10 has the same issue as 4.9 - it does not fix anything. Only kernel 4.8 and earlier work as expected.


    I assume you're running oscam on same machine as vdr backend?



    Can you help me set it up as this what you talking about TVH drives me crazy for a week now ;/

    Make sure that the options for DVB-Api are correct (Config-->DVB-Api from Oscam's web interface):
    PMT Mode=4
    Listen port=2000


    Now I can see it is on the edge when wathcing a single HD channel. I assume paralel recording or timeshifting can be completely forgotten.

    Not sure about RPi2 but RPi3 is usable as a DVB receiver. However, some tweaking is obviously required to get an acceptable performance. Also, in my experience VDR is far more robust than Tvheadend, so you definitely should give it a try.


    Which kernel does your custom build use?



    I can't think of a reason why an older kernel would work better, but if it does I'd like to know why.

    I'd like to know this myself. I noticed the inferior performance of kernel 4.9 back in December with Milhouse build #1215. The issue is easy to reproduce as long as you have a DVB tuner connected to the Pi and PVR server/client are on the same Pi. The difference in performance is huge, with kernel 4.8 I can run this setup without a single issue (with Advanced deinterlacing enabled). With kernel 4.9 I absolutely have to disable Advanced deinterlacing (even increasing arm_uc doesn't help).

    I also tested Milhouse's kernel 4.10-RC builds and they are just as bad as 4.9.x.


    - "vcgencmd arbiter set arm_uc 12 0" command improves the behavior but it is still present. Shall I try with other parameters?

    No, other parameters will not improve anything.
    With the latest LE builds that use Linux kernel 4.9.x - "arm_uc 12 0" will not fix those errors.
    Use an older, pre-kernel 4.9 build (or my custom 7.95.2 build) + "arm_uc 12 0" and the errors should be gone.


    - "Switch from Advanced deinterlacing to Bob". There are only MMAL BOB and MMAL BOB halved options. By selecting them there is no picture. The configured HW acceleration is OMX and not MMAL. Does it matter?

    Always use mmal. Never enable omx except for troubleshooting purposes.

    I run VDR on my RPi3 24/7 for months without a reboot. It is rock stable, not a single crash.
    Tvh crashes every chance it gets. It would *always* cause Kodi to crash when the signal is poor (e.g. during rain) but sometimes it crash for no apparent reason. I actually thought it was a Kodi issue until I switched to VDR.
    The only nice thing about Tvh is it's web interface.


    I still see some sporadic artefacts while watching TV but the recorded streams are perfect.

    Try to switch from Advanced to Bob deinterlacing. Advanced is using a lot of RAM bandwidth and it may cause issues (especially on HD channels) when both PVR client and server are on the same Pi.
    Also, increasing "arm_uc" value should help a lot with sporadic artefacts. The default value is "10 0". To check the current value run "vcgencmd arbiter status".
    "arm_uc 12 0" works great for me, anything higher will cause HDMI dropouts.
    To change it to "12 0" run "vcgencmd arbiter set arm_uc 12 0", you can add it to to make the setting permanent.


    Will you provide one for the final release, too?


    I assume you're running both Tvheadend server and client on the same Pi.
    I had the same issue with my DVBSky s960 + RPi3. Here's how you can fix it:

    1) Switch from Advanced deinterlacing to Bob. Advanced deinterlace is using a lot of RAM bandwidth and it may cause issues (especially on HD channels) when both PVR client and server are on the same Pi. This is not the best solution because Advanced looks better than Bob.
    2) Increase the "arm_uc" value (I use 12 0). The default value for Pi3 is "10 0". For Pi2 it is probably the same. Run "vcgencmd arbiter status" to check the current value.
    To make the new setting permanent add this to file:

    1. vcgencmd arbiter set arm_uc 12 0

    ^This setting completely fixed the issue for me, I didn't have to disable the Advanced deinterlacing.
    RAM overclocking will also help a bit.

    Also, see this thread - thread-4235.html
    Linux kernel 4.9.x perform poorly on the Pi. The latest LibreELEC builds are based on kernel 4.9.x. Use a build based on pre-4.9 kernel.