Posts by HuwSy

    Hi. I'm not tethering on the wifi I'm tethering on the ethernet port as the tv doesn't have wifi support and I don't have an ethernet port/cable anywhere near by. So all the RPi should be doing in this instant is speaking to the internet over wifi and forwarding on some of that traffic through a NAT/tether to the tv via ethernet. Which does work and is stable and sufficient speed for the tv, it's just that if it connects the tethered ethernet line faster than the wifi connection the routing seems to be incorrect hence my non persistent tether and autostart script.

    I currently have my RPi3 running libreelec daily (April 7th I think). It's using wifi as the default route to the internet and the ethernet port is connected to a not too smart tv. It's taken some time to get working persistently through reboots and all but I don't think it's the right way about it.


    1. Setup ethernet in gui to auto obtain ip (not used once tethered but I did initially use a static ip conflicting with wifi below)

    2. Setup wifi in gui to correct ssid, passphrase and static ip (static here is for my own sanity, not really needed)

    3. Set firewall rules in gui to custom ensuring -P FORWARD ACCEPT was included in the config (initially I was blocking all this traffic)

    4. Copied default connman config into ~/.config/ and set tethered to allow ethernet, prefered devices to include wifi first and online check to true


    This all works after I initially rebooted then ran "connmanctl tether ethernet on" but as soon as I rebooted again the Pi and TV had no Internet. It seemed the ethernet tether was becoming the preferred route and no Internet traffic went via wifi which was the most preferred route in connman and was marked online.


    From here on is where things don't seem correct as I have had to bodge the process.


    5. Also in connman config I have set persistent tether to false, always enable wifi and default to wifi

    6. Added to ~/.config/autostart.sh containing:

    (

    sleep 10;

    connmanctl tether ethernet on

    ) &


    This now drops the tether setup every shutdown and reenables the tether 10 seconds after booting by which time the wifi is already established and in use as the default route.


    Can anyone suggest how I fix my tether so I don't need this autostart script etc.


    Thanks