Posts by chewitt

    We block lots of words that are frequently used in pharma spam. It's annoying to find words that are blocked, but the occasional apology (sorry) is less work for the forum staff than having to delete a daily deluge of pharma spam posts.

    This is what I see in the first dmesg:

    ata1.00 = link down

    ata2.00 = 6Gb/sec = WD60EFRX = /dev/sda

    ata3.00 = 3Gb/sec = Samsung 840 = /dev/sdb

    ata3.01 = 3Gb/sec = ST3000DM001 = /dev/sdc

    ata4.00 = fail to resume link / link down

    ata4.01 = fail to resume link / link down

    ata5.00 = 3Gb/sec = WD60EFRX = /dev/sdd

    ata6.00 = 3Gb/sec = WD40EFRX = /dev/sde

    This is what I see in the second dmesg:

    ata1.00 = link down

    ata2.00 = link down

    ata3.00 = 6Gb/sec = Samsung 840 = /dev/sda

    ata3.01 = 3Gb/sec = ST3000DM001 = /dev/sdb

    ata4.00 = failed to resume link / link down

    ata4.01 = failed to resume link / link down

    ata5.00 = link down

    ata6.00 = 3Gb/sec = WD60EFRX = /dev/sdc

    I'd start by updating the BIOS/firmware on whatever kind of x86 device it is you're using .. including any third-party SATA controller cards and check that everything is set to allow 6Gb/sec operation - I can see several drives that flip between the two which either indicates bad settings or bad cables or an insufficient power supply. Check the cables and jumper settings on drives. Then i'd start rebuilding with the SSD and get that on a 6Gb/sec channel. Then I'd add the two 6TB drives and ensure those come up. Then i'd add the 4TB .. then 3TB.

    As a general comment: each time I see someone struggle with cables/connectors and drives like this I think "get a NAS box" .. because media collections are so much easier when you make the HTPC a dumb/simple/cheap client device and use a decent NAS for storage.

    LE uses alsa and BT output requires pulse audio. We have both in the image but if you switch output to pulse you disconnect audio from alsa and deliberately lose the HDMI output. If you configure a custom pulse configuration it's completely possible to have pulse output to both a device and HDMI at the same time, but how that's done is not really documented anywhere so you'll need to fiddle and experiment until it works.

    Funding a pirate IPTV service and being an expat pensioner doesn't legitimise the fact it's a pirate IPTV service. Now I am willing to be proven wrong but I am assuming it's a pirate service because in the 8+ years I've been associated with this project (and 15+ years i've been an expat myself) I still haven't encountered any legitimate IPTV services - only ones full of stolen TV feeds (if BBC UK channels are present is a reliable indicator as the BBC don't license their content to anyone). So as a pirate user you are in violation of our forum rules. And VPN is fine for privacy (some parts of the world have invasive tracking which is why we include it) but using it to defeat geoblocking also puts you on the wrong side of forum rules and the content activities we want the project to be associated with. The project aims for a neutral (not for, not against) position on such topics and we do not consider whether something is legal or illegal in whatever jurisdiction you happen to reside in. We are not lawyers and it makes no sense in the context of a global 'internet' project (everything is legal somewhere and illegal somewhere else) but piracy is always still piracy and we are not piracy friendly. You are welcome to do whatever you like with our software (we don't care) but if you are a pirate keep it to yourself or our project staff will act to maintain our neutral position.

    There is low appetite among current staff to add a package manager to our deliberately HTPC-client focussed distro. We are more interested to know what the 3-4 extra apps are that everyone has a burning desire to run (as long as they aren't content stealing/theft/piracy tools) so we can consider packaging them as addons or asking the linuxserver.io folks to add a lightweight docker container.

    Installing docker adds directories where binaries live to the shell PATH so you can run commands. However, PATH is not updated dynamically so if you have a shell open before you install docker, it can't find the binaries until you log out and back in again. Once you log in again the new shell has the updated PATH and can find them.

    "MPEG-4 part 10" refers to a section of the H.264 specification. It does not mean 10-bit video (which is a problem on most hardware). If you look at the ffmpeg analysis a few lines before CDVDVideoCodecFFmpeg::Open in the log:

    Code
    14:28:18.222 T:139708148455168    INFO: ffmpeg[7F10568F9700]:     Stream #0:0(eng): Video: h264 (High), yuv420p(progressive), 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc

    I've no idea what the problem is, but ^ that shows standard 8-bit H.264 video not 10-bit, so that's not the issue.

    The original error is caused by the kernel boot= param being wrong or (more likely confused) so it fails to mount the partition with the SYSTEM file and dumps you into the initramfs debug shell (which is pretty limited). If you're installing this doesn't make sense because the entire install process runs within the initramfs environment (in the KERNEL file) and you never reach the point in the boot process where SYSTEM would be required.

    So I think the USB bootloader is finding boot params on the SSD (for normal boot) but then you have some kind of disk label clash that results in it failing to find the SYSTEM file and boot fails. If you already made a backup of the existing system and exported that off-box for safe keeping, boot from an Ubuntu LiveUSB and reformat the SSD (any format is okay) then try to reinstall.