If you share "dmesg | paste" and "lsusb -v | paste" output (URLs) with the controller attached we can see the device ID's are, and start investigating.
Posts by chewitt
-
-
*DEBUG* log .. else we can't see the detail needed to diagnose things.
-
Code
2019-03-11 22:36:08.402 T:1790935920 ERROR: GetAddon failed on addon plugin.radio.dancefloor 2019-03-11 22:36:08.402 T:1790935920 ERROR: SQL: [Addons27.db] SQLite error SQLITE_CORRUPT (database disk image is malformed)^ delete the DB file. It will be recreated on restart, but with add-ons disabled, so you will need to go re-enable them.
-
You need to set a Samba username/password in the LE settings add-on (and leave SMB2/3 defaults enabled, not SMB1). Win10 requires authenticated SMB connections.
-
Five Ninja's ran a successful kickstarter and shipped product, but RPi2 appeared shortly after the CM(1) based slice appeared which reduced demand and I also have an impression the folks behind the company had crazy-busy day jobs so the venture didn't quite get the attention it needed to survive in the long-term. Last I heard Pimoroni retains a small spares stock to service customers, but otherwise Slice has come to an end. In the future LE will drop support for the dedicated image; it's not worth sustaining for the small number of users. Instead we will roll it into our normal Pi images.
-
Our master branch bumped from SSL 1.0 to 1.1 which includes a breaking API change. All binary add-ons will need to be rebuilt, re-published, and re-downloaded by users. Master is in a pre-Alpha state at the moment so we are fine to do this, i.e. user update issues are not something we consider at this stage of LE 9.2 development.
-
Please provide a full debug log.How to post a log (wiki)1. Enable debugging in Settings>System Settings>Logging2. Restart Kodi3. Replicate the problem4. Generate a log URL (do not post/upload logs to the forum)
use "Settings > LibreELEC > System > Paste system logs" or run "pastekodi" over SSH, then post the URL link -
Are you trying to update (via tar file) or do a clean reinstall of the OS?
-
The big change between OE (and older LE versions) and LE 8.2 or newer is that SMB1 is no longer used by default (client or server). LE clients will need to set user/pass credentials on all shares accessed, configure Kodi to use them, and use SMB2/3 *or* (against our advice) force Kodi to use SMB1 by setting the Kodi SMB client (in Kodi settings) to use min/max SMB1. Really ancient old NAS may also need the SMB legacy security option checking. If using LE as the server; we now default to SMB2/3 but this can be changed. Older Samba clients may default to SMB1 so cannot see the shares requiring config in the LE settings add-on to be changed *or* (better) you should update the Samba version on the other Linux OS to something less prehistoric.
-
-
The default KEYDB.cfg file we include is only a placeholder. You will need to source your own file that actually has content before discs will work. Then if you're lucky there are keys in the file for the discs you're trying to play.
-
Any ETA on WG becoming part of the Linux kernel, since Torvalds loves it so much?
Nope. And considering it didn't even compile on ARM hardware until I made an attempt (and failed, and reported the bug to the devs) in late December I'd guess WireGuard has some way to go before it gets merged. It's great but definitely a bit rough around the edges.
-
It shouldn't be too hard to figure out a systemd service that can be placed in /storage/.config/system.d/ to start the server.
-
"WARNING: [pool www] server reached pm.max_children setting (5), consider raising it"
^ that setting needs to be raised in the php-fpm config, but whether that's the cause or simply a symptom of simply running out of RAM is anyone's guess. For the quantity of containers you're running an RPi3 is inadequate. You'd be a lot better off with a basic NUC or a basic Synology NAS and then use the RPi3 as a dumb client device.
-
Seeing error messages like "Your kernel does not support cgroup memory limit" makes me think the Allwinner kernel defconfig doesn't have all the required cgroup/namespace options set.
Ping jernej ^
-
-
TVHeadend (server) add-on and the Kodi PVR (client) add-on for TVHeadend. Both are in the LE repo.
RPi Zero is going to be weak for this. RPi3B+ would be better.
-
WireGuard is a kernel module (currently out-of-tree) and a userspace config tool (wg) that are used to configure a wg0 network interface that presents in the OS much like a normal Ethernet interface. I'm still actively working on the userspace packaging so balbes150 images are usable with some caveats but also subject to change. I've also identified an interesting connman bug with NTP (reported upstream last night) that needs fixing before it'll be possible to use automatic WireGuard connections on boot. It's also untested on Generic/RPi so I need to spend some time on that too. I'm hoping to get it merged as an LE9.2 feature. Compared to OpenVPN the initial config process has more confusing terms (lots of things that sound the same) but it's actually rather simple and connections take a second to create.
Have a look at /storage/.config/wireguard.conf.sample .. rename to wireguard.conf and it will start the connection on reboot, but this will cause NTP to fail and if the system clock is wrong most SSL certificates will fail validation causing other issues. You need to stop, pause, restart wireguard.service to workaround that until the connman fix comes in.
project: add wireguard package · chewitt/LibreELEC.tv@d82a723 · GitHub
balbes150 images do not have the latest changes I pushed last night so "wg-quick" does not exist until his next rebase/release.