Posts by jdpc

    jdpc Please test this: libreelec-h3.arm-9.80-devel-20190920211508-9d2b397.tar

    It has a hack to make I2S settings exactly the same as on old OpenELEC. If that still not it, we'll move focus on HDMI.

    Nope, it doesn't work. This is the output of the two commands in case you want it:


    jdpc   patrickkfkan can you provide output of following commands during playback of video with 48kHz audio?

    Code
    1. cat /sys/kernel/debug/clk/clk_summary
    2. cat /sys/kernel/debug/regmap/1c22800.i2s/registers

    I would still like to resolve this issue, if possible.


    I've run those commands at 44.1 kHz and 48 kHz, in case it helps you.


    For 44.1 kHz:


    For 48 kHz (bad audio):


    Thank you very much for all your work! I watched a two-hour long movie tonight and I can confirm that the audio is perfect at 44.1 kHz and 24 Hz refresh rate.

    jernej I've been testing the build more thoroughly and I've found some interesting things and a workaround to fix the sound issues.


    The first thing I tested is playing a video at 1080p 60 Hz. As always, the problem is still there, even with the interface sounds. But then I decided to try at 1080p 30 Hz. I played a YouTube video and found the sound issue to be completely gone, but when trying with a movie the sound started to cut off again. This was already reported by other users. When tweaking the sound settings, I found the culplit: when limiting the audio sampling rate from 48 kHz to 44.1 kHz, the problem is completely gone for every video. That's why YouTube was working before, because its audio sampling is 44.1 kHz.


    The rest of the audio settings doesn't seem to affect anything. I then tried 1080p 60 Hz with the audio sampling limited to 44.1 Hz, but the audio cuts off again. So to sum up, I think there are actually two different sound issues:


    - When using 1080p 50 or 60 Hz

    - When sending a sampling rate of 48 kHz or more


    Maybe this information helps you solve the problem. For now, I can use 1080p 23.98 Hz and 44.1 kHz to watch movies. patrickkfkan   shahidali55 you could try this too, maybe limiting the sampling rate also works at 60 Hz on your TVs.

    Tried it on my Orange Pi PC and unfortunately the problem still persists. Thank you anyway.

    Hi, I'm still having problems with HDMI audio. I'll try to summarize the problem and attach some logs in case they're useful.


    I have a Orange Pi PC and a Samsung TV from 2009. When running at 1080p 60 Hz, the audio only works for a fraction of a second and then stops working for some seconds repeatedly. When changing the refresh rate to 23.98 Hz it seems that the problem is gone in the UI sounds, but there are still some audio cuts for 2 or 3 seconds when playing videos, but less frequently than at 60 Hz. The problem still persists at 720p 60 Hz and 50 Hz. When using a much lower resolution the problem is gone.


    I tried 2 different HDMI cables and other HDMI inputs in the TV to no avail. It doesn't seem to be a problem with the TV, because it works fine with the old OpenELEC builds with legacy kernel. Also, it works fine with two other monitors at 1080p 60 Hz.


    Here are the logs:


    dmesg



    edid-decode /sys/class/drm/card0-HDMI-A-1/edid



    dmesg.txt

    edid-decode.txt

    I'm having the same problem with an Orange Pi PC and Samsung UE37C5100 TV from 2011. Sound works for less than a second, then silence for some seconds, then sound again, and so on. I also discovered that sound works fine when using 1080p but a refresh rate lower than 50 Hz, like 24 or 30. Sound worked fine in the old OpenElec versions based on legacy kernel.


    jernej if you want some logs just ask and I will provide them. In any case thank you so much for everything you have done, everything else is working fine