Posts by chunki

    I don't know but I think the sound is a bit overmodulated? Also I have a problem when I start/stop my vpn, spotify connect breaks and doesn't come back up.


    First of all - great idea with "configuration wizard", very user friendly


    I have tested with my Trust 5.1 USB soundcard and I was now able to control the volume, using the following device/mixer combinations:

    • Device: default:CARD=Device + Mixer "Speaker"
    • Device: sysdefault:CARD=Device + "Mixer "Speaker"


    Mixer "Line" didn't work for both of them - no sound output, at least for my soundcard cabling.


    BUT: the sound was blurred - not a problem of overmodulation, rather it looks like as if the channels are not adressed properly. Within in Kodi you can choose the channel configuration (e.g. 2.1) - maybe the same needs to be done too here in the config.


    Another comment, that may help during bugfixing - I got an UI popup add-on error, when I choose one of the following items as device:front:CARD=Device,DEV=0
    surround21:CARD=Device,DEV=0
    surround40:CARD=Device,DEV=0
    surround41:CARD=Device,DEV=0
    surround50:CARD=Device,DEV=0
    surround51:CARD=Device,DEV=0
    surround71:CARD=Device,DEV=0
    iec958:CARD=Device,DEV=0


    The error log for the above error is as follows:

    Code
    1. Aug 09 18:37:11 LibreELEC sh[9443]: Starting spotify-connect-webAug 09 18:37:14 LibreELEC sh[9443]: Loading Spotify library...Aug 09 18:37:14 LibreELEC sh[9443]: Traceback (most recent call last):Aug 09 18:37:14 LibreELEC sh[9443]: File "loader.py", line 3, in <module>Aug 09 18:37:14 LibreELEC sh[9443]: File "runpy.py", line 180, in run_moduleAug 09 18:37:14 LibreELEC sh[9443]: File "runpy.py", line 72, in _run_codeAug 09 18:37:14 LibreELEC sh[9443]: File "/storage/.kodi/addons/service.spotify-connect-web/main.py", line 14, in <module>Aug 09 18:37:14 LibreELEC sh[9443]: from connect import ConnectAug 09 18:37:14 LibreELEC sh[9443]: File "/storage/.kodi/addons/service.spotify-connect-web/connect.py", line 9, in <module>Aug 09 18:37:14 LibreELEC sh[9443]: from console_callbacks import audio_arg_parser, mixer, error_callback, connection_callbacks, debug_callbacks, playback_callbacks, playback_setupAug 09 18:37:14 LibreELEC sh[9443]: File "/storage/.kodi/addons/service.spotify-connect-web/console_callbacks.py", line 104, in <module>Aug 09 18:37:14 LibreELEC sh[9443]: mixer = alsa.Mixer(args.mixer, **mixer_card_arg)Aug 09 18:37:14 LibreELEC sh[9443]: alsaaudio.ALSAAudioError: Unable to find mixer control Mixer,0 [hw:1]Aug 09 18:37:14 LibreELEC sh[9443]: Failed to execute script loaderAug 09 18:37:14 LibreELEC systemd[1]: service.spotify-connect-web.service: Main process exited, code=exited, status=255/n/aAug 09 18:37:14 LibreELEC systemd[1]: service.spotify-connect-web.service: Unit entered failed state.Aug 09 18:37:14 LibreELEC systemd[1]: service.spotify-connect-web.service: Failed with result 'exit-code'.Aug 09 18:37:14 LibreELEC systemd[1]: service.spotify-connect-web.service: Service hold-off time over, scheduling restart.Aug 09 18:37:14 LibreELEC systemd[1]: Stopped spotify-connect-web.Aug 09 18:37:14 LibreELEC systemd[1]: Started spotify-connect-web.Aug 09 18:37:14 LibreELEC sh[9466]: The hw:d,s device specification is unreliable. Use names instead



    I hope this helps.


    Cheers
    Chunki

    Back at home I have tried both values 'Line' and 'Speaker' as setting for "mixer", but afterwards the service didn't start, hence the device was not visible anymore. I am happy to provide error log dumps if you guide how to get. Thanks!


    Cheers
    Chhnki


    Hi,
    my amixer -c 1 output is as follows:


    Simple mixer control 'Speaker',0
    Capabilities: pvolume pswitch pswitch-joined
    Playback channels: Front Left - Front Right - Rear Left - Rear Right - Front Center - Woofer - Side Left - Side Right
    Limits: Playback 0 - 197
    Mono:
    Front Left: Playback 197 [100%] [0.00dB] [on]
    Front Right: Playback 197 [100%] [0.00dB] [on]
    Rear Left: Playback 197 [100%] [0.00dB] [on]
    Rear Right: Playback 197 [100%] [0.00dB] [on]
    Front Center: Playback 197 [100%] [0.00dB] [on]
    Woofer: Playback 197 [100%] [0.00dB] [on]
    Side Left: Playback 197 [100%] [0.00dB] [on]
    Side Right: Playback 197 [100%] [0.00dB] [on]
    Simple mixer control 'PCM',0
    Capabilities: cvolume cswitch cswitch-joined
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 6928
    Front Left: Capture 6928 [100%] [11.06dB] [on]
    Front Right: Capture 6928 [100%] [11.06dB] [on]
    Simple mixer control 'PCM Capture Source',0
    Capabilities: enum
    Items: 'Mic' 'Line' 'IEC958 In' 'Mixer'
    Item0: 'Mic'
    Simple mixer control 'Line',0
    Capabilities: pvolume cvolume pswitch pswitch-joined cswitch cswitch-joined
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 8065 Capture 0 - 6928
    Front Left: Playback 6144 [76%] [-0.01dB] [off] Capture 4096 [59%] [-0.01dB] [on]
    Front Right: Playback 6144 [76%] [-0.01dB] [off] Capture 4096 [59%] [-0.01dB] [on]
    Simple mixer control 'Mic',0
    Capabilities: pvolume cvolume pswitch pswitch-joined cswitch cswitch-joined
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: Playback 0 - 8065 Capture 0 - 6928
    Front Left: Playback 0 [0%] [-24.00dB] [off] Capture 0 [0%] [-16.00dB] [on]
    Front Right: Playback 0 [0%] [-24.00dB] [off] Capture 0 [0%] [-16.00dB] [on]
    Simple mixer control 'IEC958 In',0
    Capabilities: cswitch cswitch-joined
    Capture channels: Mono
    Mono: Capture [on]


    Sounds like as if mixer setting 'Speaker' (or 'Line') could work regarding volume control, what do you think? Didn't try yet since I am not at home currently.


    Cheeers
    Chunki


    Ok, understood, thanks for the explanation! My amixer says:


    Simple mixer control 'PCM',0


    ...hence I used 'PCM' as mixer entry in settings.xml field 'scw_m', but I still cannot control the volume. Also, obviously the "auto detect" setting for 'playback route' (settings.xml field 'pcm_3') is not working reliably for my USB sound config (as you have already assumed), it only works from time to time, when I stop and restart Spotify app on my Android tablet.


    Any idea which settings I can use for the settings fields 'pcm_3' (playback route) and 'scw_m' (mixer) given my USB device config (all details see below)? Many thanks for your help!


    Here's is the lsusb output:
    Bus 001 Device 004: ID 145f:0143 Trust


    Here is the full amixer output:
    Simple mixer control 'PCM',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback -10239 - 400
    Mono: Playback -10239 [0%] [-99999.99dB] [off]


    This is the dump of aplay -l:
    **** List of PLAYBACK Hardware Devices ****
    card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
    Subdevices: 8/8
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2
    Subdevice #3: subdevice #3
    Subdevice #4: subdevice #4
    Subdevice #5: subdevice #5
    Subdevice #6: subdevice #6
    Subdevice #7: subdevice #7
    card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: Device [USB Sound Device], device 0: USB Audio [USB Audio]
    Subdevices: 0/1
    Subdevice #0: subdevice #0


    Here is the dump of aplay -L:
    null
    Discard all samples (playback) or generate zero samples (capture)
    default:CARD=ALSA
    bcm2835 ALSA, bcm2835 ALSA
    Default Audio Device
    sysdefault:CARD=ALSA
    bcm2835 ALSA, bcm2835 ALSA
    Default Audio Device
    default:CARD=Device
    USB Sound Device, USB Audio
    Default Audio Device
    sysdefault:CARD=Device
    USB Sound Device, USB Audio
    Default Audio Device
    front:CARD=Device,DEV=0
    USB Sound Device, USB Audio
    Front speakers
    surround21:CARD=Device,DEV=0
    USB Sound Device, USB Audio
    2.1 Surround output to Front and Subwoofer speakers
    surround40:CARD=Device,DEV=0
    USB Sound Device, USB Audio
    4.0 Surround output to Front and Rear speakers
    surround41:CARD=Device,DEV=0
    USB Sound Device, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=Device,DEV=0
    USB Sound Device, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=Device,DEV=0
    USB Sound Device, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=Device,DEV=0
    USB Sound Device, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=Device,DEV=0
    USB Sound Device, USB Audio
    IEC958 (S/PDIF) Digital Audio Output


    And finally this is my choosen Audio device config in LE:
    ALSA: USB Sound Device (@:Card=Device,DEV=0), Analog


    Again, many thanks for your help!


    Cheers
    Chunki

    Hi,
    thansk for your quick reply. I now found it, many thanks!
    Now lets see I will get it working with my USB soundcard


    Cheers
    Chunki
    [hr]
    Hi,
    my USB soundcard output basically does work , with setting "hw:1,0". Unfortunately, I cannot control the volume (neither via Spotify client nor via RBPi remote). Which mixer do I need to configure?


    My USB soundcard config looks as follows (aplay -l output):
    card 1: Device [USB Sound Device], device 0: USB Audio [USB Audio]


    The LE audio config is as follow:
    ALSA: USB Sound Device (@:Card=Device,Dev=0),Analog


    Accordingly, I have set the config to "hw:1,0" and playback route to "auto detect". But no mixer configured yet.


    Any idea? Many thanks!


    Chunki

    Hi,
    sorry, maybe stupid question, but in which repository and in which subcategory can I find the addon? I am running LE 7.0.2 on RbPi 2 and I have looked under "LibreELEC Add-Ons" in all subcategories, but was not able to find it. Do I need to update something before I can see the addon?


    BTW, I was looking for an addon like this since long time, hence many thanks for your work


    Cheers
    Chunki