Posts by iashok

    the driver crashed (line 867) - no idea whats wrong

    you can open an issue at Issues · tbsdtv/linux_media · GitHub or maybe crazycat can help

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Good news from my side - TBS5520SE is working on my RPi 2/3 and LE 9 Release.

    I have not not tried DVB-T tuner, DVB-S2 is working - but ONLY with external power supply - on the red USB


    -----------------------------

    [ 2.434877] usb 1-1.4: New USB device found, idVendor=734c, idProduct=5521, bcdDevice= 0.01

    [ 2.434897] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0

    [ 2.434909] usb 1-1.4: Product: TBS 5521

    [ 2.434920] usb 1-1.4: Manufacturer: TBS-Tech

    ...

    [ 11.726565] Latest git patches (needed if you report a bug to [email protected]):

    [ 11.726565] b9ac0e830b87e363d357353ab54ae9f892bbd821 si2183: i2x_mutex in base.

    [ 11.735432] dvb-usb: found a 'TBS 5520se USB2.0' in cold state, will try to load a firmware

    [ 11.778694] dvb-usb: downloading firmware from file 'dvb-usb-tbsqbox-id5521.fw'

    [ 11.778722] tbs5520se: start downloading TBS5520se firmware

    [ 11.920932] dvb-usb: found a 'TBS 5520se USB2.0' in warm state.

    [ 11.921690] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.

    [ 11.929158] dvbdev: DVB: registering new adapter (TBS 5520se USB2.0)

    [ 11.929199] usb 1-1.4: media controller created

    [ 12.084823] dvb-usb: MAC address: 00:22:xx:xx:xx:xx

    [ 12.088469] dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.

    [ 12.125591] i2c i2c-3: Added multiplexed i2c bus 4

    [ 12.125618] si2183 3-0067: Silicon Labs Si2183 successfully attached

    [ 12.148039] i2c i2c-4: av201x: Airoha Technology AV201x successfully attached

    [ 12.170440] si2157 4-0061: Silicon Labs Si2147/2148/2157/2158 successfully attached

    [ 12.222853] usb 1-1.4: DVB: registering adapter 0 frontend 0 (Silicon Labs Si2183)...

    [ 12.222904] dvbdev: dvb_create_media_entity: media entity 'Silicon Labs Si2183' registered.

    [ 12.223383] usb 1-1.4: DVB: registering adapter 0 frontend 1 (Silicon Labs Si2183)...

    [ 12.223425] dvbdev: dvb_create_media_entity: media entity 'Silicon Labs Si2183' registered.

    [ 12.230229] dvb-usb: TBS 5520se USB2.0 successfully initialized and connected.

    [ 12.230624] usbcore: registered new interface driver tbs5520se

    [ 29.081567] si2183 3-0067: found a 'Silicon Labs Si2183-B60'

    [ 29.123819] si2183 3-0067: downloading firmware from file 'dvb-demod-si2183-b60-01.fw'

    [ 29.792597] si2183 3-0067: firmware version: 6.0.13

    ----------------------------

    Agree, it's the same with my TBS 5520SE - it's working on my Debian Stretch Intel 64 bit HTPC with the same compiled drivers.

    My RPi with CrazyCat drivers and latest alpha 009 hangs immediately when I connect the board. With the previous alpha there was a lot

    of kernel oops, but the system was operational. Is there a major ARM issue with these drivers /maybe firmware/ or something else?