Posts by chook55

    When I changed to a 2.0 spec cable the plastic connector molding was a little larger. I use the Argon 1 case. The connector didn't feel right so I marked it out and filed the case so the connector fitted properly. It was a millimeter or two that needed filing so the connector clicked in properly. I guess it depends on your connector.

    OK I have the TV to myself today.


    I discovered a bug.


    I removed the Justboom HAT and config code to temporarily remove any unknowns.


    I used HDMI from the with SPDIF passthrough from my TV set to Optical out. So the TV plays back in 5.1 channels to the AMP from both TV direct first and then through KODI.


    I tested this with my sample DOLBY ATMOS and DTM files. These all played perfectly. I noted that all of these samples are H264 DOLBY or DTM 5.1 channel codec videos.


    When I play H265 encoded files they play in 2 channels only. I checked again with a non demo H264 encoded Dolby Video and 5.1 channels worked perfectly.


    So I suspect there is a bug in that H265 encoded videos are no longer able to decode polyphonic audio. I will re-code one of the H254 DOLBY demo files to x265 and confirm KODI is no longer decoding this properly.


    chook


    My theory doesn't hold true. I converted "THX Deep note Genesis4k.mkv" which never displayed BTW, to HEVC-265 and resized it to 1920x1080. It plays fine. So I'm back to square, one. I try re-coding some of the x265 videos to 265again. See what happens.

    RPI4B

    LG OLED TV

    Marantz SR55000 AVR

    I see HDR is working on the Nightlies. Well done.

    An observation.

    1. The control panel overlay is also in HD while video is playing. Accessible by pressing ESCAPE.

    The glare from the overlay makes is undesirable. I have an OLED screen and am wary of staying on this screen for more than a few seconds in case it burns in. Is this something that can be controlled or avoided.

    2. Nice logo by the way.

    3. How does one disable HDR


    chook

    Yes I'm using the option in the AVR SPDIF (AC3/DTS)[ column.


    If I use the JustBoom SPDIF option as audio out and passthrough device Dolby Sample files play as they should with 5.1 channels. However videos which I know are Dolby 5.1 audio will play as 2 channels only with identical options.


    I havent had opportunity to reconfigure and recommission the HDMI to SPDIF splitter. This I know will play multichannel videos correctly.

    It seems there is a problem detecting the audio encoding, though this shows in the info display widget correctly. I'll be a day or so before I can continue forwards.

    Chook

    So I'm using the JustBoom DIGI HAT and using the S/PDIF Optical source to connect to a Marantz Amplifier.


    Dolby 5.1 DTS 5.1 and ATMOS 5.1 sample video files utilize all 5.1 channels with the Audio profile using the JustBoom Digi HAT option. However TV shows and Movies with Dolby 5.1, AAC 5.1 codec are out puting using only 2 channels. I'll reinstall a HDMI SPDIF splitter and remove the JustBoom HAT to see if it's a configuration problem or a firmware problem.

    This worked well. I had the noisey stock fan running flat out when I rebooted. I edited "argononed.conf" with 4 lines of °C to % fan settings after removing 1=100.

    ie

    42=25

    44=50

    46=75

    48=100


    I didnt try through their app.


    Chook

    29/10/21 7:30am It seems the wrap is caused by booting from the USB-SDD. To confirm I removed the USB-SSD went back to SD card. No problem with display wrap. Is running 40°C on idle and 43°C while playing a video.


    29/10/21 8:17 AM To replicate the issue I have booted again with the USB SSD (Sandisk Extreme Pro USB 3.2 SSD) and can confirm the wrap around is back. Boot time was over a couple of minutes by the way.


    I'm going to update to the latest nightly. 2021/10/28. Done. Result: Screen Wrap is still evident. At idle temperature settled to 41°C


    chook

    I upgraded to the nightly in question on a SD card. Did a system backup. Installed the latest nightly on a new USB SSD. I booted from the USB SSD then restored the backup. After a restart and re-enabling code for the Justboom digi hat. All seemed to be running OK but was running much hotter than normal. I rebooted after moving the USB SSD to the powered USB hub as the SSD was quite warm. This made little difference to the temperature which was creeping up with nothing running. The screen wrap was still evident at this time. I decided it was running several degrees cooler on the SD card so removed the USB SSD. And the pixel wrap has gone. So maybe it was power supply issue? Though the Powered USB has a separate 4A power supply. I'm wont pursue this further assuming it was a power issue.


    Update: While the screen wrap issue has resolved itself using the SD card, the temperature is still running at 48°C compared to 39°C to 43°C. I've checked that WiFi is off. I use a wired network.


    chook


    Ah...thanks for clarifying for me. Pass-through was on. It can be hit and miss depending on the file audio.


    thanks for your time.


    chook