Posts by kaibenn

    There is a problem in CoreElec again.


    If librespot is activated, you cannot switch live TV channels (TVHeadend) anymore. The screen is black and TVHeadend seems to be crashed.


    CoreElec 8.95.0,

    librespot 111,

    TVHeadend is 4.2 9.0.115,

    TVHeadend HTSP Client is 4.3.4.2.


    It seems to be independent of the audio settings of librespot. It occured as well with ALSA and Kodi audio mode.

    In the Kodi audio settings I can switch to ALSA: AML-M8AUDIO, HDMI.


    Then it seems to work, at least during the first tests. Good!


    I am not sure what is the difference between the 'ALSA: AML-M8AUDIO, HDMI' and the 'ALSA: Default (AML-M8AUDIO Analog), PCM' it was set to previously. It is not going over HDMI, only. I still hear it over the optical out and my audio receiver.

    librespot plugin does not run satisfactorily on CoreELEC 8.90.3 (Wetek Play 2).


    I wrote the issues also in a thread at CoreELEC, but because it seems unclear if the issue is CoreELEC, Leia or librespot specific, I want to inform you as well.


    The issue depends on the used audio system:


    1) ALSA


    * If librespot is active playing, the Kodi GUI is not working anymore

    * If I stop the playing and try to use Kodi again, it crashes

    * last lines of kodi_crash.log:

    15:04:48.020 T:4064277360 INFO: CActiveAESink::OpenSink - initialize sink

    15:04:48.020 T:4064277360 DEBUG: CActiveAESink::OpenSink - trying to open device ALSA:default

    15:04:48.020 T:4064277360 INFO: CAESinkALSA::Initialize - Requested layout: FL, FR

    15:04:48.021 T:4064277360 INFO: CAESinkALSA::Initialize - set digital_codec 0

    15:04:48.021 T:4064277360 INFO: CAESinkALSA::Initialize - Attempting to open device "default"

    15:04:48.024 T:4064277360 INFO: CAESinkALSA - Unable to open device "default" for playback

    15:04:48.024 T:4064277360 ERROR: CAESinkALSA::Initialize - failed to initialize device "default"

    15:04:48.025 T:4064277360 DEBUG: CActiveAESink::OpenSink - trying to open device ALSA:default

    15:04:48.025 T:4064277360 INFO: CAESinkALSA::Initialize - Requested layout: FL, FR

    15:04:48.025 T:4064277360 INFO: CAESinkALSA::Initialize - set digital_codec 0

    15:04:48.025 T:4064277360 INFO: CAESinkALSA::Initialize - Attempting to open device "default"

    15:04:48.029 T:4064277360 INFO: CAESinkALSA - Unable to open device "default" for playback

    15:04:48.029 T:4064277360 ERROR: CAESinkALSA::Initialize - failed to initialize device "default"

    15:04:48.029 T:4064277360 ERROR: CActiveAESink::OpenSink - no sink was returned


    It seems Kodi is not able to get back the ALSA sink.


    2) Kodi


    I can switch between the use of librespot and Kodi without crashes. But sometimes (maybe after librespot was restarted) the audio output is stuttering.

    Hello awiouy, great, what a fast response!


    I today recognized that librespot does not work anymore on my krypton LibreElec (Raybuntus variant, Wtek Play2). I assume this is the same issue and you provide a new version for LE8 as well?


    What is the new version number of the librespot addon, because I would have to fetch it via wget. I am currently using service.librespot-8.2.110.zip.