Posts by mchehab

    Part of the fix for upstream Kernel is to add vchiq DT data:

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    That makes it to create /dev/vchiq devnode.

    With that, kodi doesn't crash anymore, but those messages are generated:


    Code
    [    6.846340] vchiq: module is from the staging directory, the quality is unknown, you have been warned.
    [    6.851573] vchiq: vchiq_init_state: slot_zero = ea880000, is_master = 0
    [    7.027647] [<bf00c794>] vchiq_doorbell_irq [vchiq]
    [    8.022814] Modules linked in: cfg80211(+) vc4(+) snd_soc_core ac97_bus snd_pcm_dmaengine snd_pcm snd_timer snd crc32_arm_ce brcmutil soundcore vchiq(C)
    [  106.220212] vchiq: vchiq: connect: could not lock mutex for state 0: -4
    [  149.432097] vchiq: vchiq: could not connect: 1


    Maybe vchiq DT data changed since Kernel 4.11 (the last time I used my RPi3).

    @HiassofT: Thanks for the detailed explanation! it worked as a charm.
    The only detail is that here, I installed it via NOOBS, dual-booted with raspbian and LibreELEC. The kernel image file is named kernel.img. I'm also using the standard serial interface (with is ttyS1 on Kernel 4.14), instead of PL011.


    It is funny that Kodi didn't work. I don't think it is due to a DRM module, as 4.14 comes with VC4 driver (with is enabled here and works on raspbian here). Maybe it requires some other Kernel feature that it is not enabled (like some namespace feature). Anyway, this shouldn't matter for tvheadend to work. The only thing is that, without Kodi, it won't be possible to test recording while watching a movie on RPi.


    As a reference, this is my .config file, with contains several media drivers enabled:

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    I maintain the media subsystem at the Linux Kernel. I'm trying to debug this issue with an upstream Kernel and see if it is just softirq or if are there any other adjustments to be made at the media drivers. I just setup libreElec here with a serial console, but I'm not sure what parameters should be passed to Kernel's command line, as the ones that boot with Raspbian don't work on LibreElec. I'm getting this here:


    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    I'm basically adding those to config.txt:

    kernel=upstream/vmlinuz-4.14.11-mcc+

    device_tree=upstream/bcm2837-rpi-3-b.dtb


    (The Kernel/DT files I'm using were stored at /dev/mmcblk0p6 under /upstream dir)


    That's the content of cmdline.txt file:

    boot=UUID=39F7-FE9B disk=UUID=6ccbd2e9-3b41-4fbd-9af6-f520be468511 root=/dev/ram0 rdinit=/init usbcore.autosuspend=-1 pi3-disable-bt console=ttyS1,115200


    Commenting the kernel/DT lines at config.txt makes it boot RPi's Kernel fork, as usual. So, boot arguments at cmdline.txt should be ok.


    I suspect some sort of initramfs is needed, but I'm not sure how to generate it for libreELEC.