Posts by ukjackbauer

    I have a U1 also (8.02b and U1 device tree) and audio output is set HDMI, however it goes over the optical (I only have optical inputs on my soundbar and it is not connected to my tv - just directly to cable box and U1). Pass through is enabled and soundbar receives DD and DTS. Not sure why it works, hopefully someone with more knowledge than me can explain.

    Yep this is expected. Audio is output over all interfaces simultaneously. Just be sure to set the channels to 2.0 so that DD and DTS are passed through the optical. I used that same type of setup for quite a while and and it works well.

    Thanks so much for the replies. Really appreciate it.


    I was hoping to be able to select the SPDIF device for the "audio passthrough" section, though - which would mean that HDMI sound would be stereo (which my TV can handle), and optical would be Dolby or DTS.


    Is there anything I can do to make the SPDIF device appear separately? Looking at the device tree, the details of the SPDIF device are there - which is why I can't understand why it doesn't appear in any of the "audio output" lists.


    Thanks again - really grateful that I can get a bit more life out of this box (I wasn't educated enough at the time to know that Amlogic was dying out)...

    Hi,


    New user, and very much new to the world of LibreELEC - but I've managed to get it up and running on my Minix Neo U1 (S905).


    Thank you so much for all your brilliant work, kszaq. Before today, I'd not been able to get Kodi to "accept" that the output was set to 4K and videos were being downscaled, due to Amlogic support being pulled.


    Thanks to you, I've got it working in 4K now - but I've got an audio output problem I can't get my head around.


    I've used the Neo U1 device tree from the site linked to in the first page of this topic - and I've taken it from the last firmware update myself - PLUS I've tried generic ones. But I absolutely CANNOT get the optical audio port (TOSLINK) to appear in the list of audio devices.


    My TV won't passthrough surround sound via HDMI, so I've got the Neo U1 connected to my sound system via an optical cable. The optical port is recognised by Kodi if I boot the Minix system - but with LibreELEC, my only choices are HDMI or Pulse bluetooth.


    Other than trying different device trees, I don't know what else I can try - please can you help me? Is there any information I can provide that might give you a clue as to what's going on?


    Thanks again for all your efforts, I'm genuinely really grateful to you for extending the life of my box...