[8.1.9] LibreELEC 8.2 for S905/S905X

  • I am a noob and am ordering the Mecool M8S Pro Plus, I would like to run it with LibreElec, but the instructions to do so seem very daunting to me. Can a Noob do it by following step by step instructions or will I be in over my head?

  • What Device Tree did you use ?

    You Haven't mentioned Device Tree at all in your install information.

    I used the device tree


    gxl_p231_2g_dvb.dtb


    which I believe is correct for my box Mecool KI pro that has S905D, but I also tried with gxl_p230_k1_pro.dtb and gxbb_p201_2G.dtb in LE 8.1.7 and LE 8.1.8 and did not find the wired network, only found wireless network


    One more detail, the first time I installed connected on a 10/100 Mbits router, then I connected to another Gigabit router and reinstalled again and still did not find the wired network


    Ubuntu Pastebin

  • To be honest, i'm really surprised that somebody faced the problem with unwanted repeates, because i've tested 8.1.7 at all my boxes (A95X, K1 Plus, K2 Pro, Coowell V5) with their IR-remotes

    I was the one with the problem with a HID Xiaomi Bluetooth remote - all sorts of unwanted repeats and strange stuff was occurring due to the HID patch.

    Quality BT remotes like that one already have fast enough repeat keystrokes, turbo charging such activity really caused issues.

    Revert the HID Kernel patch and the problems disappeared.

  • For KI Pro you should use "gxl_p230_k1_pro.dtb". Why do you post Kodi log if this is a hardware issue?

  • Hello!

    I have nfs mount like this:

    Code
    1. 192.168.1.254:/tmp/mnt/WD-MPU/export/HOME /tmp/g nfs ro,sync,noexec,relatime,vers=3,rsize=524288,wsize=524288,namlen=255,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,hard,noac,proto=tcp,port=2049,timeo=70,retrans=3,sec=sys,local_lock=none,addr=192.168.1.254 0 0

    Files under the the /tmp/g are vissible like this:

    But when I add a video source like this:

    Code
    1. <source>
    2. <name>g</name>
    3. <path pathversion="1">/tmp/g/</path>
    4. <allowsharing>true</allowsharing>
    5. </source>


    all my videos (.avi, .mkv etc) kodi sees as a directories and when I press OK on remote it tries to "cd" in them:


    Mounting by smb works well.



    PS. I have Nexbox A95X 1/8 and LibreElec 8.1.8

    WiFi connection.



    PPS. It is quite possible that unfsd (user space nfs daemon) running on my NAS is quite buggy, but my other boxes (sat receivers and bd-player) see my nas pretty well.


    Thanks.

    The post was edited 3 times, last by rx5670 ().

  • not updated for a while, the known issues reports rgb mode doesn't work in 8.2, does that mean the fix mentioned here no longer works?

    Anyone know if this is likely to ever be fixed?

  • I am a noob and am ordering the Mecool M8S Pro Plus, I would like to run it with LibreElec, but the instructions to do so seem very daunting to me. Can a Noob do it by following step by step instructions or will I be in over my head?


    1) Download the image file

    2) Download the device tree file

    3) Download the LibreElec USB-SD creator

    4) Plugin the SD or USB flash drive in your computer

    5) Run the LibreElec USB-SD creator (step #3):

    - a) select the image file (step #1)

    - b) select the path of the SD or USB flash drive plugged in (step #4)

    - c) click write image

    - d) at the end of the process the USB/SD card will be recognized by your operating system and you will be able to navigate into the USB/SD drive

    6) Rename the device tree file (step #2) in dtb.img

    7) Navigate into the USB/SD folders (step #5-d) and overwrite the dtb.img file with the file renamed in the step #6

    8.) Unplug the SD/USB drive from your computer

    9) If you are using the USB flash drive, plug in on the first USB port from the top of your Mecool device

    10) Unplug the Mecool box's power supply cord

    11) In the front of your Mecool box you will see a tiny push button. With a toothpick push it and keep it pushed.

    12) Reconnect the power supply

    13) After ~30sec the LibreElec logo will be displayed on your TV. Release the push button (step #11)


    Every time that the USB/SD card (created with this procedure) is plugged in your box, LibreElec will run automatically (you don't need to push the button again).

    To run your android system, just unplug the USB/SD card from your box.


    If you want to install permanently LibreElec in your box, follow the guide 

  • For KI Pro you should use "gxl_p230_k1_pro.dtb". Why do you post Kodi log if this is a hardware issue?

    For KI Pro you should use "gxl_p230_k1_pro.dtb". Why do you post Kodi log if this is a hardware issue?

    Thanks for the attention, I had tried with this Device Tree and it did not work, but I'll try again, I'll get another SD and format.


    It does not seem to be a hardware issue because the wired network works on LE 8.0.2 and Android , it just does not work on LE 8.1.7 and LE8.1.8

  • Hi all,

    Wondering if someone can help. I installed librelec+Kodi to my internal nand after using it for a while from my microSD card. I now seem to be experiencing a lot of buffering from my SMB shares. If I boot from my microSD, there is hardly any buffering and it's really quick when skipping through a large mkv file. Any ideas please?

  • I'm trying to update to 8.1.8 from 7.0.3.012l by copying the LibreELEC-S905.arm-8.2-8.1.8.img.gz and dtb file into .update folder. It installs the update/dtb but when it reboots it hangs on the initial splash. I have confirmed I am using the correct dtb via sdcard with 8.1.8.


    I know I can just install via sdcard and installtointernal but I would prefer to update a few family members devices via the update folder.

    Can anyone help?

  • updated 64bit image with some addons built from kszaq 8.1.8 git tag to LE – Google Drive

    player : Mini MX-G p200_2G & Inphic Spot i7 PRO p212
    monitor : iiyama ProLite E2283HS
    speaker : UE Boom 2
    dvb-t : PCTV microStick (79e)
    firmware : android | kszaq LE 64bit | balbes armbian | own gentoo

  • Post by Brachiator ().

    This post was deleted by the author themselves ().
  • I'm trying to update to 8.1.8 from 7.0.3.012l by copying the LibreELEC-S905.arm-8.2-8.1.8.img.gz and dtb file into .update folder. It installs the update/dtb but when it reboots it hangs on the initial splash. I have confirmed I am using the correct dtb via sdcard with 8.1.8.


    I know I can just install via sdcard and installtointernal but I would prefer to update a few family members devices via the update folder.

    Can anyone help?

    Use the tar file in the update folder not the gz file.

    Minix U1, S905 chipset, Dual Boot Libreelec / Android 5.1 lollipop, Samsung UHS-1 32GB Micro SDHC Memory card

  • Use the tar file in the update folder not the gz file.

    Tried the gz, tar, & img files with the gxl_p212_1g.dtb file. I've also tried renaming the dtb file to dtb.img. I've also tried downgrading to a different LE7 build then upgrading. I've even tried to manually install dtb again via ssh console. I've re-downloaded all the img & dtb files again in case they were corrupt.


    It hangs with all of these yet the sdcard boots fine. I'm totally stumped, I've done this many times in the recent past but for some reason just won't work.

  • I give up !!


    It is some incompatibility of my box with newer versions of LE. I checked with other owners of KI pro and LE 8.2-8.1.8 is working fine.


    In my box:


    Installing LE 8.0-8.0.2c with device gxl_p230_k1_pro ... success


    Installing LE 8.2-8.1.8 with device gxl_p230_k1_pro .... fails, does not install


    Installing LE 8.2-8.1.8 with device gxl_p231_2g_dvb .... install but do not find wired network


    I even tried to install alpha version LE 9.0 and also can not find the wired network. It seems that it is some software incompatibility with my box



    Thank you to anyone who tried to help me !!

  • Tried the gz, tar, & img files with the gxl_p212_1g.dtb file. I've also tried renaming the dtb file to dtb.img. I've also tried downgrading to a different LE7 build then upgrading. I've even tried to manually install dtb again via ssh console. I've re-downloaded all the img & dtb files again in case they were corrupt.


    It hangs with all of these yet the sdcard boots fine. I'm totally stumped, I've done this many times in the recent past but for some reason just won't work.

    So I updated my MiniMX 2G (S905) from LE7 to LE8 using gxbb_p200_2G_1Gbit and it boots fine, but my X96-1G & X96-2G (S905X) using gxl_p212_1g/2g.dtb doesn't boot afterwards, just stuck at the initial boot screen. Is this because my X96 boxes have a non-standard partition layout and my MiniMX does? and the the update basically needs to be applied twice to format the partitions correctly?


    If so, is there any way around this?