Edimax EW-7811UTC wifi dongle support RPi3?

  • wlan1 Link encap:Ethernet HWaddr 74:DA:38:73:41:B3
    inet addr:192.168.1.106 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:80274 errors:0 dropped:58 overruns:0 frame:0
    TX packets:692 errors:0 dropped:18 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2319460 (2.2 MiB) TX bytes:145074 (141.6 KiB)


    LibreELEC-U:~ # lsusb -t
    /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
    |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc980M
    |__ Port 4: Dev 4, If 0, Class=Vendor Specific Class, Driver=rtl88480M


    this make sense to anyone? In particular to the 5G instability?

  • I can honestly say I have never had an issue like this for years. I must of put at least 50 hours into solving how to turn the damn power management off wlan1 permenantly and still nothing. I have learnt the inside and outside of SSH/putty/commands as a bonus though. Please somebody must know?

  • look at the output of

    Code
    1. lsmod


    then find the kernel module in use, for example mine is "8192cu"


    then run

    Code
    1. modinfo --parameters <module name>


    for example mine shows


    then

    Code
    1. echo "options 8192cu rtw_power_mgnt=0" >> /storage/.config/modprobe.d/8192cu.conf


    to check if it is working, reboot, then run the following (make sure to adjust to your module name)

    Code
    1. for i in /sys/bus/usb/drivers/rtl8192cu/module/parameters/*; do
    2.   echo "$i: $(cat $i)"
    3. done


    then you'll see the output

    Code
    1. /sys/bus/usb/drivers/rtl8192cu/module/parameters/rtw_power_mgnt: 0


    You might also be able to define a channel and other properties this way.

    Edited once, last by lrusak ().

  • LibreELEC-U:~ # lsmod
    Module Size Used by
    hci_uart 14478 1
    btbcm 5379 1 hci_uart
    bluetooth 282086 3 btbcm,hci_uart
    brcmfmac 172683 0
    brcmutil 4893 1 brcmfmac
    bcm2835_gpiomem 2652 0
    bcm2835_wdt 2777 0
    8812au 1500982 0
    cfg80211 229385 2 brcmfmac,8812au


    which part am I taking from here?



  • It would be too easy to show up as simple as your setup wouldn't it!

    Edited once, last by nickrob84 ().

  • looks like it's the same
    try

    Code
    1. echo "options 8812au rtw_power_mgnt=0" > /storage/.config/modprobe.d/8812au.conf


    then reboot,
    then check the output of

    Code
    1. cat /sys/bus/usb/drivers/rtl8812au/module/parameters/rtw_power_mgnt


    it should show 0

  • It accepted the firet command but after the reboot its coming up with:

    Code
    1. LibreELEC-U:~ # cat /sys/bus/usb/drivers/rtl8812au/module/parameters/rtw_power_m
    2. gnt
    3. cat: can't open '/sys/bus/usb/drivers/rtl8812au/module/parameters/rtw_power_mgnt': No such file or directory
  • try


    Code
    1. cat /sys/bus/usb/drivers/rtl8821au/module/parameters/rtw_power_mgnt
  • Code
    1. LibreELEC (official) Version: 7.0.1
    2. LibreELEC-U:~ # cat /sys/bus/usb/drivers/rtl8821au/module/parameters/rtw_power_m
    3. gnt
    4. 0
    5. LibreEL


    could that be it? actually solved?

  • Code
    1. LibreELEC (official) Version: 7.0.1
    2. LibreELEC-U:~ # cat /sys/bus/usb/drivers/rtl8821au/module/parameters/rtw_power_m
    3. gnt
    4. 0
    5. LibreEL


    could that be it? actually solved?


    sure? perhaps power management isn't even enabled on this module by default.


    Does it work properly now?

  • Well i'm off today and tomorrow and I got a lot of TV catch up to do so if it survives that there willl be a £25 donation referrenced to yourself. Thank you.

    Edited once, last by nickrob84 ().

  • Well after some extensive testing over both boxes, neither have skipped a beat. I mean I haven't exactly stressed tested them but they have both played several hours of 1080p footage (including live) with no buffering or any issues at all over the 5G network. Not even one. Even afer 12 hours idle they were instantly ready to go. I am a man of my word. There will be a £25 donation in reference to Irusak's help on this subject at some point over the weekend when the wife feels like returning my cards!! Thanks again.

  • Does everything still works?


    I am thinking about to buy a very similiar or the same Edimax dongle with rtl8812au chipset.