RetroELEC (Generic/RPi/XU4) Emulationstation/RetroArch/Kodi

  • It's already packaged as an addon I think. I have no need for it so not going to integrate in the build.

  • 20160606 (rpi2) and previous build both gave me a weird error if i added video files from USB to the library.


    Everything goes well, indluding file scanning, but the moment i click to enter the video library, screen goes black and stays black even after hard reset.


    Ill try 20160609 later tonight and give more info if i can get the same error.


    WORKS: couldnt reproduce it with 20160609. Will play with removing usb + inserting, and with emulationstation, but for now it looks OK. YEAY

    Edited once, last by jayfkay ().

  • I've added an "RPi3" build with specific compiler optimizations. No noticeable difference, but perhaps someone would like to benchmark.

    Edited once, last by escalade ().

  • Hi escalade,
    maybe there are someting wrong in your common-shaders script:
    LibreELEC.tv/package.mk at emu · escalade/LibreELEC.tv · GitHub

    Code
    1. PROJECT=RPi2 ARCH=arm scripts/build common-shaders


    will work only if you never launched this command, otherwise no.
    Of course, this affect also retroarch compilation (no common-shader-latest folder in build directory)


    To make it work you need to manually change the folder name inside the script, like:

    Code
    1. unzip -o -d common-a shaders_glsl.zip


    Code
    1. cp -R common-a/* $INSTALL/usr/share/retroarch/shaders

    Edited once, last by lollo78 ().

  • That goes for any package, you need to clean it after building. There's a stamp that decides whether the package should be built or not.

  • yes, I notice this, but for common-shaders there is someting that seems doesn't works fine.
    I tried also to delete common-shaders-latest folder insider build-LibreELEC-* but

    Code
    1. PROJECT=RPi2 ARCH=arm scripts/build common-shaders


    doesn't works.
    There is another path?
    I searced also in source folder, in /tmp but there are no trace of common-shareds folder.
    Any advice on what I have to clean to make it works again?
    Thx

  • Hi there just stumbled abon your release and it looks awesome I have a few question I hope thats ok.
    Ive recently moved from openelec to libreelec using lrusak's retroplayer build and was wondering if there were any plans to incldue retroplayer features in the future. I understand you like a frontend but I must say native kodi support is coming on leaps and bounds.
    Secondly Ive noticed that your build required the system partition to be at least 500mb which is unabling to to update my current build. Is there a way to get around this for example bootling a live gparted and resize the system partition? I have my roms setup on the hd and it would be a pain to to a full install.
    The build sounds amazing and I'm itiching to try it.
    Kind Regards
    Lefty

  • If you want retroplayer, why not keep using lrusak's builds? i prefer standalone emulators for reasons listed in the first post. As for the system partition size, it's already 512MB default in LE. If you come from an older OE release you should back up, wipe your disk and re-install. My image is larger than a regular image because of the added emulators and cores.

  • Thanks for the advise :) I'll given it a whirl. Theres nothing wrong with lrusak's builds I just like the idea of being able to load emulationstation as well as having retroarch/retroplayer. Do you know if the build is compatible with zackmorris's Internet archive Rom launcher addon? I'd image the retroarch is diffrent from tsmek's openelec version. Since retroarch is not an addon in your build. I'll give it a test.
    Thanks for this project cant wait to give it a blast.

  • I wouldn't know, I don't use IARL or retroplayer for that matter. I do know that retroarch is not used though, retroplayer simply loads the libretro cores inside Kodi. Which is where it fails to begin with if you ask me, as I can't imagine Kodi as fat as it is will offer the same low inputlag as standalone retroarch running with KMS. This is purely speculation from me though, so feel free to prove me wrong.


  • I wouldn't know, I don't use IARL or retroplayer for that matter. I do know that retroarch is not used though, retroplayer simply loads the libretro cores inside Kodi. Which is where it fails to begin with if you ask me, as I can't imagine Kodi as fat as it is will offer the same low inputlag as standalone retroarch running with KMS. This is purely speculation from me though, so feel free to prove me wrong.


    IRAL has support for both retroplayer and standalone retroarch. It can be used as a front end without the need for users to populate the roms manualy. It pulls the roms from the internet archive and launches then via the core in the case of retroarch. It has support for openelec, windows, mac, and rpi. It also features an inbuild wizard to setup the addon with the correct retroarch cores for your setup. It also scrapes the archives with covers and links to ingame movies via youtube.
    It also supports mame soft lists so systems like c64, apple2, colecovision, neogeocd ect can be ran via the mame core. Might be worth looking into if you havent.


    Here is a little iral compatibility list I have asked Zackmorris to take a look at it. I found the launch script so I'll let you know how it goes.

    Edited once, last by lefty420 ().

  • I have a quit big problem with your build/sources as i can't access the libreelec addons repository.
    Tested it with official 7.90.002, Irusak's build where it works but with your build and selfbuild from your sources it says it can't connect to repo with the folling error in kodi.log

    Code
    1. 04:05:18  50.644604 T:1755956128   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 403
    2. 04:05:18  50.644848 T:1755956128   ERROR: CCurlFile::Open failed with code 403 for http://addons.libreelec.tv/8.0/RPi2/arm/addons.xml.gz.md5
    3. 04:05:18  50.645016 T:1755956128   ERROR: Open - failed to open source <http://addons.libreelec.tv/8.0/RPi2/arm/addons.xml.gz.md5>
    4. 04:05:18  50.645130 T:1755956128   ERROR: CRepositoryUpdateJob[repository.libreelec.tv] failed read checksum for directory 'http://addons.libreelec.tv/8.0/RPi2/arm/addons.xml.gz'
    5. 04:05:22  55.156284 T:1962332160   ERROR: GetDirectory - Error getting addons://repository.libreelec.tv/
    6. 04:05:22  55.156841 T:1962332160   ERROR: CGUIMediaWindow::GetDirectory(addons://repository.libreelec.tv/) failed