RetroELEC (Generic/RPi/XU4) Emulationstation/RetroArch/Kodi

  • fneves


    I use a NUC which is also Intel HD, and Super Mario 64 is smooth as butter here. I think a Celeron 2955U might be a bit weak for proper N64 emulation.


    pandaadnap


    Ah, I see. The OEM packages means all my extra packages, so disabling that you'll have a plain LibreELEC build. You can start with the RPi2 package in packages/escalade/oem/RPi2, so copy it to Odroid_C2 and give it a shot. I'm guessing you will run into compile issues with some of the packages.

    Edited once, last by escalade ().

  • Hi


    I tried multiple things
    1. I tried to compile for RPi2 (following the doc on github). I get an error

    Code
    1. [b]INSTALL[/b]    libc [b](target)[/b]      [b]INSTALL[/b]    toolchain [b](target)[/b]          [b]INSTALL[/b]    configtools [b](host)[/b]          [b]INSTALL[/b]    make [b](host)[/b]          [b]INSTALL[/b]    xz [b](host)[/b]          [b]INSTALL[/b]    sed [b](host)[/b]          [b]INSTALL[/b]    pkg-config [b](host)[/b]          [b]INSTALL[/b]    autoconf [b](host)[/b]          [b]INSTALL[/b]    automake [b](host)[/b]          [b]INSTALL[/b]    libtool [b](host)[/b]   [HEADERS] include   [HEADERS] libxfsBuilding includegmake[2]: Nothing to be done for 'include'.Building libxfs    [TEST]    CRC32    [CC]     rdwr.lo    [CC]     trans.lo    [CC]     util.loIn file included from [b]/home/moi/libreelec/libreelec_escalade_rpi2/build.LibreELEC-RPi2.arm-8.0-devel/toolchain/armv7ve-libreelec-linux-gnueabi/sysroot/usr/include/features.h:392:0[/b],                 from [b]/home/moi/libreelec/libreelec_escalade_rpi2/build.LibreELEC-RPi2.arm-8.0-devel/toolchain/armv7ve-libreelec-linux-gnueabi/sysroot/usr/include/stdio.h:27[/b],                 from [b]../include/platform_defs.h:24[/b],                 from [b]crc32.c:36[/b]:[b]/home/moi/libreelec/libreelec_escalade_rpi2/build.LibreELEC-RPi2.arm-8.0-devel/toolchain/armv7ve-libreelec-linux-gnueabi/sysroot/usr/include/gnu/stubs.h:7:29:[/b] [b]fatal error: [/b]gnu/stubs-soft.h: No such file or directorycompilation terminated.Makefile:124: recipe for target 'crc32selftest' failedgmake[3]: *** [crc32selftest] Error 1gmake[3]: *** Waiting for unfinished jobs....include/buildrules:35: recipe for target 'libxfs' failedgmake[2]: *** [libxfs] Error 2Makefile:70: recipe for target 'default' failedmake[1]: *** [default] Error 2make[1]: Leaving directory '/home/moi/libreelec/libreelec_escalade_rpi2/build.LibreELEC-RPi2.arm-8.0-devel/xfsprogs-dev-53cefc4'Makefile:12 : la recette pour la cible « image » a échouéemake: *** [image] Erreur 1


    I don't get this error when compiling for Odroid.



    2. When I compile for Odroid c2, I get an error


    Error:


    I will try to see if I find the correct flag tomorrow.
    Thanks


  • lollo78


    I have no interest in that for the same reasons as mentioned above, mame2010 was updated last november 2015. If you want to create packages you need to put in the work yourself, I can help you if you have a specific question. There is a ton of similar packages already that you can look at and learn from.


    ;) OK


    About specific question... :D
    For common-shaders you download both "common" and "retropie".
    But if you would advice only one?


  • Hum, but I get stable 60fps, maybe it's just that I'm more sensible? Not sure, I'll make a video and try other games aswell!


    EDIT: found the issue, I activated "Threaded Video" and that makes buttery smooth vsync impossible!

    Edited once, last by fneves ().

  • That's the default, set in /etc/retroarch.cfg by package.mk:

    Code
    1. sed -i -e "s/# video_threaded = false/video_threaded = true/" $INSTALL/etc/retroarch.cfg


    So I'm guessing you must have changed this.

    Edited once, last by escalade ().


  • That's the default, set in /etc/retroarch.cfg by package.mk:

    Code
    1. sed -i -e "s/# video_threaded = false/video_threaded = true/" $INSTALL/etc/retroarch.cfg


    So I'm guessing you must have changed this.


    Yup, it was me who activated it, thinking it was a good thing


  • Deactivated you mean


    Or that, I'm confused now :D


    Btw, have you tried "Supermodel" emulator? I wanted to emulate Super Model 3 roms. Not sure if you included this emulator or not. I should compile it from the source, does this distro have all the necessary stuff to compile it?


    Thanks!

  • No, I haven't. The emulators included are listed on the first page. You'd have to investigate yourself if you want it.

  • Since i setup the TV right... this is the best OS for me, so i'm sticking with it.


    Best way to keep up with your versions is cloning? Or do i just install it fresh and copy over backup user folders?


    Thank you

  • Hello! Thank you for your work , it works perfectly . But it would be a problem. I can not find anywhere in the PVR menu. If I replace skin will not appear on the PVR menu . I found which could be made between actively settings . I would like to use the IPTV Client Simple add-on. The other problem is that the supplements LibreElec(repository) passed over it is not connected to the server. Kodi supplements connected. Sorry for the grammar problem,I used google translate for writing .

    Edited once, last by Aryan ().

  • Which build are you using? I don't use PVR myself. Does it work differently than regular LibreELEC? The only relevant change I think, is that I'm using a newer git revision of Kodi.


  • Which build are you using? I don't use PVR myself. Does it work differently than regular LibreELEC? The only relevant change I think, is that I'm using a newer git revision of Kodi.


    2016.05.25 the build date. I will try your new builds. I tried original LE 7.01, the pvr (TV) menu in main menu visible when i "enabled" in pvr menu.
    I used your build on nvidia ion system.

    Edited once, last by Aryan ().

  • I really love it, but whenever i start retroarch i get an annoying mouse cursor in the middle of the screen. I am running full screen and even disabled the mouse in the kodi menu, nothing helped. I am on the latest build. Anyone else having this?