LE8 "Remix" (Generic/RPi) Emulationstation/Chrome/Spotify PROVIDE LOGS IF PROBLEMS

  • I've spoilt myself with an LG OLED and I gotta say this is a gamechanger. As you can direct play 4k HDR files through Plex I'm not sure what I need Kodi for anymore. Probably not going to worry about rebasing on LE9 any time soon. Just a heads up :)


    It is a pity that you will no longer make any updates, how do you use the emulators now?

    HTPC : Intel i5 4430 , MSI GeForce GTX 1050 2GT LP, 4GB , Asrock B85M-ITX , 60GB SSD

    NAS : Synology DS3617xs , 10 x 4TB WD red , 2 x 3TB WD red , 250GB SSD

  • I just want to thank you for the help you have provided while I have been using your build. Your hard work is greatly appreciated.

  • It is a pity that you will no longer make any updates, how do you use the emulators now?

    I will most likely continue making updates, just at this point I'm not sure to what degree I will focus on Kodi if at all. I still consider LibreELEC as the perfect JeOS for emulators :D

  • I will most likely continue making updates, just at this point I'm not sure to what degree I will focus on Kodi if at all. I still consider LibreELEC as the perfect JeOS for emulators :D

    Since we're talking about emulators. Are you able to compile and start the latest ppsspp version (01be9ff)? First it failed to start because of a missing libsnappy.so lib so I added a snappy package and build a shared library. Now I can start games but ppsspp fails to load and I get the following dmesg output:

    Code
    1. [ 1178.032331] retroarch[1729]: segfault at 968 ip 00007fdff139d52d sp 00007ffea28a7a80 error 4 in libX11.so.6.3.0[7fdff1368000+125000]
    2. [ 1182.708851] retroarch[1746]: segfault at 968 ip 00007f492db7f52d sp 00007ffe613acf10 error 4 in libX11.so.6.3.0[7f492db4a000+125000]
    3. [ 1187.822172] retroarch[1763]: segfault at 968 ip 00007fb7be39b52d sp 00007fff8ea4f770 error 4 in libX11.so.6.3.0[7fb7be366000+125000]


    When I create a "nokms" file in the retroarch folder I can start ppsspp and it works fine but all other libretro cores fail to start then.


    Well this gave me some headache ¯\_(ツ)_/¯

  • oddly enough, PPSSPP is the one emulator that worked on this build out of the box for me, but I can not get working on Lakka

  • For some reason after latest update, EmulationStation won't launch anymore, I get a black screen for one second and get kicked back to Kodi. What log can I open to see the problem ? Thanks.

  • LE8 "Remix" (Generic/RPi) Emulationstation/Chrome/Spotify PROVIDE LOGS IF PROBLEMS

    Quote

    How to ask for support:

    1. If your problem exists on regular LibreELEC then create a new thread. That means you should compare with regular LE if possible.

    2. Reproduce your issue then post the zip file from the logshare together with information about your hardware.

    3. Ignore these instructions and you will be ignored (or maybe insulted depending on the mood).


    Provide Log File [LibreELEC.wiki]

  • escalade


    Well looks like recent spotify versions need "libcurl-gnutls.so.4"? I was thinking about enabling gnutls for curl but there is a note that suggests to build it without. Any hints about that?



    Actually this bug should be fixed #14674 ([RPI] Videos played from https (and webdavs etc.) don't play) – Kodi - TRAC


  • 5schatten


    No problems compiling and running latest ppsspp here, included in the latest avx build. As for Spotify, it's set up to use libcurl-compat so if you want to enable gnutls do it in the correct package.

  • escalade


    Thx I already found the source package for libcurl-compat ;-) Is this lib needed for other packages too? My solution was to enable gnutls & add a new line to cp a l"ibcurl-gnutls.so.4" additionally to libcurl-compat.so but could I just rename the compat lib & change the LD_PRELOAD in the shell script?


    It's pretty strange... I can also compile ppsspp but still get a segfault when starting in KMS mode. You use GL or Vulkan as backend?

  • That you can find out by using find and grep. As for libs, you need to provide those the application are linked against. That can be done in different ways. Google LD_PRELOAD for an explanation on what that actually does and then you have your answer.


    I use GL.