[HOW-TO] TBS 5520SE Drivers for LE11, LE12, LE13 on RPi4

  • 28/05/2024 - Attached to this post:
    a) the patches ;
    b) a link to a compilation of LE13-devel with TBS drivers (17th May 2024):

    Following the compiled drivers for TBS 5520 SE DVB receiver for LE10 on RPI4 (available here: LE10 & TBS 5520SE on RPi4 // updated drivers [SOLVED])

    I've created this thread to share the source code of the patches to apply, compatible with LE11 and LE12 and LE13 current source code from GITHUB.

    The patches were made by smp (thank you :) ).

    I've just made some small offset adjustments to go on with kernel source code updates.

    - 2 patch files are included :

    a) lepatch_prepare_tbs_module_enable.patch - to enable tbs5520se module compilation in kernel;

    b) lepatch_code_changes_tbs5520se.patch - to add tbs5520se needed source code;

    - how to apply these patches for RPi4:

    download and go into LibreELEC git source local copy:

    git clone https://github.com/LibreELEC/LibreELEC.tv.git
    cd LibreELEC.tv

    copy the attached patches to LibreELEC git source directory:

    then run:

    cp lepatch_code_changes_tbs5520se.patch projects/RPi/devices/RPi4/patches/linux
    git apply lepatch_prepare_tbs_module_enable.patch

    - if later on git complains about branches mismatch or similar on updating sources

    git stash
    git pull

    then, re-apply the patches.

    Goodluck !


  • For those who only use the satellite tuner I modded the driver to disable the DVB-T/C tuner.

    TBS 5520SE has 2 tuners attached to a single demod. DVB core apparently does not support 2 tuners on 1 demod so the driver used a hacky way to split the adapter in 2 virtual frontends. This cause all sorts of issues with tvheadend (e.g. "no free adapter available"). I modded the driver so si2157 DVB-T tuner is not attached and only 1 DVB-S frontend is created.


  • Hi,

    can you tell if there is a new version of the patch available ? i tried to alter the existing patch to the newer version of Libreelec, but i failed to compile that completly.

  • The master branch on github now seems to started LibreELEC 13 development.

    There may be some changes at the kernel level that could create issues with TBS patches.

    Give me some days to look at it.

    Meanwhile you can checkout a previous commit - I'm currently using commit 4513878 from April 29th, which compiles tbs patches just fine.

  • ^ changes for kernel 6.6

  • ...

    The compilation of LibreELEC13 devel, commit from today with TBS patches worked just fine.

    But ... The patches are different from thes one i've previosly shared.

    In fact I've changed the patches with the help of smp and forgot to update the last version.

    The last version is already available in the first post.


  • Hi NVDIAS, is is possoble, that the wrong (old) libreelec add on repository i copiled with your version? The Version11.0 is in the image... i think for Version 13 there has to be something like 12.80 ? Am i wrong here ? After migration to the image some apps dont work anymore including tvheadend client and ffpmeg streamig addon, because they dont update and stay on the verision from nexus....