Libre Computer Renegade (ROC-RK3328-CC) USB 3.0 problem

  • Hey all,


    Just got a Libre Renegade and specs are impressive but when I got the latest image build, not a nightly, I fired it up and first thing I noticed was my old wifi dongle wouldn't work but does show up on Ubuntu image for this board. Not sure but still tinkering with that. Its an RTL8192SU which after digging I didn't see any firmware 100% related to this chip. Not the main question though.


    My main issue I noticed last night was when I tried to use the USB 3.0 port to access a flash drive that is also USB3.0. Nothing showed up. Ran some dmesg to check and all I see is USB 2.0 hubs and 1.1 hub for some reason, but no 3.0 hub or device. I'll try to get a pastebin of it to load on here. Also lsusb only shows those as well and no 3.0 device that I can tell. Is there a way I can verify or check if my board has a bad plug/device before contacting them for support?


    EDIT: So with an ubuntu image I am able to access a flash drive on the USB 3.0 port. I did do a dist-upgrade like the guide says to on Libre Computers site. Going to try out another unofficial image for this board and see what happens. Again, will try to get dmesg on pastebin if I have issues. Wanted to see if anyone else was having problems with it or not.


    Also, what image is everyone use for this specific board? The unofficial one? Or the one linked by the LibreELEC site?


    EDIT2: With the unofficial image (20221130104423) for rk3328-cc was able to get the USB3.0 working but still the wifi card isn't, yeah wasn't main topic of question and I am figuring I'll have to install/compile the firmware for it to work. Any recommendations on that?


    Thanks,


    FurmanSK

    Edited 3 times, last by FurmanSK: Further testing. ().

  • On what? The USB3.0 issue? I just used a more later nightly build. I even compiled my own kernel to test. Think it is working now but haven't checked. I gave up on the WiFi dongle. I used an older Panasonic dongle I had and it worked just fine connecting. Maybe once they go with a later version that's released I'll swap back over to the other dongle.

  • Hi, yeah the usb 3.0 issue. I burned one of the latest nightly builds and I saw the same behavior, but I can't remember if it was LE10 or LE11.


    Which version did you have success with?


    Thanks!