Problems after update 10.0.2 > 10.0.3: Image on boot, CEC, GPIO DAC

  • Hi guys,

    I updated manually from 10.0.2 to 10.0.3 and have a couple of nasty problems:


    1. No video output past rainbow splash screen
      Switching sources back and forth brings back the Kodi login screen.
      On 10.0.2 I had this working line in my /flash/cmdline.txt:
      drm.edid_firmware=HDMI-A-1:edid/edid-HDMI-A-1.bin video=HDMI-A-1:D
      This does not work anymore.
      I ssh'ed into the machine checked the file for existing lines and fired the 'getedid create' command and it added the same line as above.
      Original RPi HDMI Adapter, used port close to power plug.
      Switched HDMI cables eventhough on 10.0.2 the existing cable worked fine.
      What else can I do?
      WORKAROUND in Post #2
    2. CEC Problem
      Since the upgade I have to toggle CEC Plugin off and on again to make it work.
      WORKAROUND from Post #2 seems to fix this as well.
    3. GPOI IQaudio DAC+
      Adding this line to /flash/config.txt worked on 10.0.2:
      dtoverlay=iqaudio-dacplus
      This does not work on 10.0.3 anymore. The audio device won't show up in the list.
      ROOT CAUSE of the problem in post #4

    My update process was a little rocky: I updated placing the update.img.gz in the .update folder but because I didn't get an image I did a full reset and clean install. After that I restored the whole /STORAGE/ partition from the 10.0.2 version.


    Model : Raspberry Pi 4 Model B Rev 1.1
    TV: LG 42LW4500


    Help would be appreciated. Thank you.

    Edited 2 times, last by spk-uke ().

  • Go to Best Answer

  • Okay, I found a workaround (thx yullaw ) [0]:


    Added the following to /flash/distroconfig.txt

    Code
    hdmi_group=1
    hdmi_mode=20


    Still this is a temp solution because if I understand correctly, distroconfig.txt will be overwritten bei updates.


    I have no idea what those values mean but is there a different way to add these settings permanently?


    Source: RE: LE 10.0.1 / Rpi4 / No picture after update from LE 10.0.0

    Edited once, last by spk-uke ().

    • Best Answer

    As a temporary workaround add the hdmi_group/mode settings to /flash/config.txt, that will survive updates.


    They set a different video mode than the usual default (which will later be used during LE startup) which seems to be enough to make the TV happy and show a picture.


    so long,


    Hias

  • 3.
    GPOI IQaudio DAC+
    Adding this line to /flash/config.txt worked on 10.0.2:
    dtoverlay=iqaudio-dacplus
    This does not work on 10.0.3 anymore. The audio device won't show up in the list.

    Okay I found the problem:

    Because of the cooling chassis I wanted to use an GPIO extension cable (see image).

    That caused the DAC to fail. It does work without the cable sitting on a GPIO stack expander (not ideal).


    Is this a known issue with RPis GPIO and extension cables?

  • Is this a known issue with RPis GPIO and extension cables?

    No. The length of the cable has a relation to electrical resistance, and reduces voltage. A stronger PSU can help to avoid such issues.

    DNB music-addicted finger drummer.

  • It might be the cable (or the connections between cable and IDC connector) is faulty, such things happen.


    so long,


    Hias

  • Thanks everybody. Maybe I'll try another cable and a different PSU, though I read it's recommended to use the original one...


    I just realized.. I have one more problem that I had for ages already and it corresponds to my CEC problem:


    When switching to a different HDMI source on the TV and back, the CEC remote stopped working. Only when I play a media file, the functionality comes back.


    Here the cec-client log:

    This is the log after I started playing a media file and CEC remote worked again:



    Is there a setting I have to change?


    /edit: SOLUTION

    I added hdmi_force_hotplug=1 to /flash/config.txt and no it kinda works. Needs some time to get activated (about 5 seconds).

    Edited 2 times, last by spk-uke ().