LE 11 Nightly - KODI does not start on RPi 4B after upgrade to 20211007

  • I have upgraded LE 11 Nightly from 20211005 to 20211007 but Kodi could not start afterwards. Then I tried to reinstall (by putting the image file to .update folder & reboot) with LE 11 Nightly 20211006 with the same result. Even reinstalling with (previously working) 20211005 did not fix the issue. Yestarday I tried to reinstall with 20211010, Kodi also does not start. After several attempts to start Kodi the LE reboots in Safe mode.

    Does anybody know how could I easily make it working again please (hopefully I won't need to revert to a bit older LE release & restore configuration from backup)?

    http://ix.io/3Bp4

    http://ix.io/3BpJ

  • If still not expecting support please do

    Code
    touch /storage/.config/debug.enhanced

    and post new logs

  • how to enable debug logs from console.

    This is is how to enable verbose crash logs.


    To enable kodi debug logging (without OSD) use

    XML: /storage/.kodi/userdata/advancedsettings.xml
    <?xml version="1.0" encoding="UTF-8" ?>
    <advancedsettings>
      <loglevel>1</loglevel>
    </advancedsettings>
  • The same issue with LE 11 Nightly 20211014 and 20211015.

    Found a thread discussing the error hdmi-audio-codec hdmi-audio-codec.1.auto: ASoC: error at snd_soc_dai_startup on i2s-hifi: -19

    that I am experiencing as well: https://github.com/raspberrypi/linux/issues/4575

    Tried to edit config.txt and cmdline.txt as outlined there but without any positive effect.

    cat cmdline.txt

    boot=LABEL=System disk=LABEL=Storage quiet video=HDMI-A-1:D


    http://ix.io/3BRm

  • Please create a debug crash log with WS-Discovery component logging by creating:


    Code: /storage/.kodi/userdata/advancedsettings.xml
    <advancedsettings version="1.0">
    
    <loglevel hide="false">1</loglevel> 
    <debug>
      <extralogging>true</extralogging>
      <setextraloglevel>8388608</setextraloglevel>
    </debug>
    
    </advancedsettings>
  • What if you disable ws-discovery by changing advancedsettings.xml to


    Code
    <advancedsettings version="1.0">
    
    <loglevel hide="false">1</loglevel> 
    <debug>
      <extralogging>true</extralogging>
      <setextraloglevel>8388608</setextraloglevel>
    </debug>
    
    <setting id="services.wsdiscovery">false</setting>
    </advancedsettings> 
  • Thanks a lot, you made it!!! :) My LE 11 Nightly is working again.

    After updating advancedsettings.xml in accordance with your advice & reboot, Kodi started and displayed announcment that there's no PVR installed. I have confirmed it, then Kodi's GUI appeared and some add-ons were updated automatically. Then Live TV started succesfully and everything seems to be working fine again.

    Thanks a lot for your help, mglae ! :)

  • The advice did come from @fuzzard on github.


    But why are you the only one seeing the crash? Can you try a fresh installation on a spare card?

  • OK, thank you both! :)

    Currently I am going to upgrade LE 11 Nightly 20211005 on another boot media (USB stick) to 20211015 to test if I fell to the same issue or not. I'll put a result here. I could also try a fresh installation later but I believe it will work at first attempt.

    I think my configuration is a bit specific - I am using Live TV / PVR with Astrometa DVB-T2 stick, also the i2c LCD display so some add-ons are also more or less a bit specific. Maybe that's why? Some add-on incompatible with fresh Kodi which couldn't be upgraded automatically without the advancedsettings.xml?


    Edit - upgrade another LE 11 from 20211005 to 20211015 stopped with new Kodi picture on screen after the bottom line, informing about add-ons migration, disappeared. Kodi log ends with Waiting message (about 25 minutes ago):

    http://ix.io/3BVG

    I'll try to reboot to see what happens afterwards.

    Edit 2 - after reboot Kodi started without issue and Live TV is working.


    Perhaps the original issue could be due the fact when LE 11 Nightly 20211007 was released, add-ons were not compiled yet so the add-on migration did not finish properly and it prevented Kodi from further starts?

    Edited 2 times, last by ghtester ().