LE-9.2.8 builds for some Amlogic S905x, S802/S812 and S805 devices

  • Hello. I installed your build on an mxq with s805 a few days ago. I did not have time to test it, because I also had to "revive" an mx4 pro 4k, but I was amazed with how trouble free its installation was. Flash to sd, boot the device from sd with the "toothpick method", installtointernal, done!


    Today I decided to test what it can play, so I downloaded a couple of h264 and h265 samples from jell.yfish.us. It can play both h264 and 265, but it really struggles on 10bit h265.

    I noticed that it does not get input via hdmi cec. When I press the remote control of my tv, its led blinks so it does get the input. Cec adapter (under settings > system > input > peripherals) is enabled and so are most of its options in there.

    Any ideas why?

  • Hello jim_p


    Which version did you install? If you use my old S905-based 9.0.2 (from 3rdParty), neither CEC nor amremote will work with it.

    Unfortunately, these do not work in the official LE kernel, which is why I switched to the previous kszaq version later in my own builds.


    You should try the 9.2.6 build for MXQ 4K Pro+ (2G):

    LibreELEC-MXQ-4K-Pro_2G.arm-9.2.6.img.gz

    with this DTB:

    gxbb_p200_1G_mxq_pro_4k.dtb


    IMPORTANT NOTICE:

    If you use an external DTB to boot, you should NEVER install it to the NAND directly, because it will NEVER boot!


    One more thing: if you have Realtek wifi in your box, it won’t work because those drivers aren’t currently in this image.

    But if this image works, we can easily help with that. ;)

  • I am talking about the one for s805, because that is what the plain mxq has, which I got from here.

    Index of /S805/


    If you want to read my... trials and tribulations with mxq 4k pro, please read my thread here.

  • I'm sorry, but it was not clear which device you were asking for help.


    10-bit H.265 hardware playback will not work on the S805.

    Hardware decoding: H.265 1080p [email protected] 60fps, H.264 4K [email protected] 60fps. (Source: Amlogic - Wikipedia)


    I can’t really help with CEC, as there are plenty of clones from the MXQ boxes, and unfortunately the experience is that some works and some don’t. Unfortunately, I already had a device that would have supported CEC, but that pin was not soldered to the HDMI port either.


    I’ve seen your tribulations before with the MXQ Pro 4K, and I tried to respond to this, because the other topic doesn’t really lead anywhere, as I see it.

  • I don't care about 10bit h265. In fact, the only time I have tried h265 playback on a device which I own (the 2 mxq boxes) was just a few days ago. H264 was all I could play until then.


    How can I check that I do not have the same issue with the unsoldered pin? I can open the box, but where is it located?


    As for the one with s905, today I will try your build with the device tree you suggested. How can I check if I have realtek wifi on it? There is no lspci and lshw -C network reports that rtl8189es is used for it, so I am 99.9% sure it is realtek.

  • How can I check that I do not have the same issue with the unsoldered pin? I can open the box, but where is it located?

    Did CEC work under the original Android? If it worked, the pin is soldered so the fault will be elsewhere.

    I would require a dmesg and an fw_setenv output from your S805 device, if possible.

    There is no lspci and lshw -C network reports that rtl8189es is used for it, so I am 99.9% sure it is realtek.

    The Realtek-based wireless chips are always connected to USB:

    Code: M8Q
    M8Q:~ # lsusb
    Bus 001 Device 003: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
    Code: MXQ-m201d
    MXQ:~ # lsusb
    Bus 001 Device 003: ID 0bda:0179 Realtek Semiconductor Corp. RTL8188ETV Wireless LAN 802.11n Network Adapter
  • I can not remember if hdmi cec was working when it had the android os. Here is the output of dmseg and fw_setenv

    http://ix.io/37WR

    Code
    # fw_setenv
    ## Error: variable name missing

    You are also right about lsusb showing the wireless card

    Code
    # lsusb
    Bus 001 Device 003: ID 0bda:0179 Realtek Semiconductor Corp. RTL8188ETV Wireless LAN 802.11n Network Adapter

    Because the mxq's wireless reception is kinda bad where my hdmi cec capable tv is located, I did not connect the tvbox to it in order to get all the above without lagging. I have it next to my pc, running with no "monitor", so I could connect easily.

  • "fw_setenv" -> Okay, I typed it wrong, I originally wanted this: "fw_printenv".

    (The "fw_setenv" is for adding or modifying uboot variables, while "fw_printenv" is for showing only.)

    Bus 001 Device 003: ID 0bda:0179 Realtek Semiconductor Corp. RTL8188ETV Wireless LAN 802.11n Network Adapter

    Is this wifi chip of your S805 or S905 box?

  • Here is the output of fw_printenv on the plain mxq with s805, the one that does not work via hdmi cec. The forementioned wifi is also on this tvbox.

    http://ix.io/3co2


    I have not tested the build for s905 that you suggested on message 56, because I do not have a spare sd card available right now.

  • Code: fw_printenv | grep cecconfig
    cecconfig=cec0

    This "0" in your uboot config for CEC means that is turned off.


    You need to try this:

    Code
    fw_setenv cecconfig cec1f

    ... and then reboot.


    If that doesn't work either, make sure your TV has CEC enabled on the input source you are currently using, or try another HDMI cable.

    After that, a solution may be to go to Settings/System/Input/Peripherals/CEC Adapter -> "Reset above settings to default" and reboot again.

  • The change via fw_setenv worked after the reboot! Thank you very much!
    I will post again when I try the le 9.2.6 build for s905.

  • So I found an sd and tried your build of le 9.2.6 that you mentioned. And as you predicted, wifi was not available at all.

    What can I do? Maybe use a different device tree?

    Edited once, last by jim_p ().

  • So I found an sd and tried your build of le 9.2.6 that you mentioned. And as you predicted, wifi was not available at all.

    What can I do? Maybe use a different device tree?

    No, this is not a DTB issue as most Realtek wifi chips are connected via USB, so those are like external wifi interfaces.

    I previously removed support for these from my S8X2 and S905 images to make the disk image smaller, but I didn’t really gain much with it, so I’ll be back on them soon.


    However, did you find any other problem with the image besides the wifi issue that will be fixed soon?

  • Wifi is a major issue for me :P Hdmi cec seems to work on that one, installation on the rom does not (as you mentioned, I have not tested it and I am not willing to) so what else shall I test?

    Ce on the 905 works as it should with no major issues, but I hesitate to install it on the rom.


    On the s805, the wifi reception is poor where the tv is. Thus, I either can not install anything because downloads time out, or, when they don't, it takes minutes to download even small addons like rar/libarchive support. I can move it next to my router and have better reception, but with no tv I have no way to press buttons etc so as to do more. That's why I decided to donate it to my brother.

  • Wifi is a major issue for me :P Hdmi cec seems to work on that one, installation on the rom does not (as you mentioned, I have not tested it and I am not willing to) so what else shall I test?

    Ce on the 905 works as it should with no major issues, but I hesitate to install it on the rom.

    So, now I ask the question:

    Are you interested in an LE image that can be installed on NAND on your MXQ Pro 4K (which also has working a wifi driver) or not?

    Because if not, then I'm not going to struggle with the image, and in that regard, I will leave the fight with your stuff and move on.


    However, if you are interested, then I need an "lsusb" output under CE, because we still haven’t clarified exactly what wifi chip is in your S905.

  • I am interested in a working os with a recent (= as recent as possible) version of kodi. I don't care if its ce, le, jim-elec or anything similar. If you don't have the time for bug fixing etc, don't worry, I understand. And since the development of your images has stopped, please do not continue working on them just for me. I will find a way sooner or later :)


    Here is the requested lsusb from ce. Don't ask me where the wifi card is :P

    Code
    # lsusb
    Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • Thank you so much for this,

    Revived my first tv box, an Amlogic s805 that I could not find working roms for!