Official LE Test Images for Amlogic (Kodi-20)

  • Hi chewitt , thanks for the updated K20 image.


    I just tried in on my S905 Box out of interest.

    The image is in comparision to the K19 more unstable (expected as Kodi is alpha) and crashes a lot.


    But with that Image it is possible to watch LiveTV in Mpeg2, which was not possible for your K19 images. Therefore the software decoder for Mpeg2 works good.

  • Hi there,


    I have a Vorke Z6 with a S912 and 3G ram. Ive tried both of the gxm device trees but cant get it to boot.


    Any ideas if I can get a matrix build on this box?

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • I have a Vorke Z6 with a S912 and 3G ram. Ive tried both of the gxm device trees but cant get it to boot.

    Both? .. there are at least 8x device-trees for GXM boxes and they are all mostly identical. If none of those work .. /shrug unless you attach a UART cable and share the u-boot serial console output so we can see where it gets stuck. Note the device-tree process is different in mainline images: You need to use the "box" image and edit the dtb name in uEnv.ini. if you start renamng files like legacy images do that's one reason none will boot.

  • The LE 10.80.0 (Nexus) images in my team share https://chewitt.libreelec.tv/testing/ contain an experimental fix from Martin B for "the noise" that can be experienced with GXBB, GXL and GXM devices using the AIU audio driver. If you have an S905, S905X/D/W/Y or S912 device; please reduce volume on your TV or AVR, update the image, then spend a few minutes navigating around and fiddling with switches and options in the Kodi audio settings page (normally an easy way to provoke that audio problem). Please post back with success or reports of 'the noise' or crackling or other audio oddities you experience?


    NB: These images have partially workiing hardware decode again, using the same ffmpeg patch-set as Raspnerry Pi. This is progress, but it means playback is worse in real-terms since ~50% of things now fail, whereas recent images had software-only decode (completely broken hardware decode) where 100% of 1080p media plays within CPU limits. TL/DR; If you're trying to run these images for daily use, you probably want to disable hardware decoding.

  • Both? .. there are at least 8x device-trees for GXM boxes and they are all mostly identical. If none of those work .. /shrug unless you attach a UART cable and share the u-boot serial console output so we can see where it gets stuck. Note the device-tree process is different in mainline images: You need to use the "box" image and edit the dtb name in uEnv.ini. if you start renamng files like legacy images do that's one reason none will boot.

    Ah helps if you edit the uEnv.ini Booted first time with meson-gxm-q200.dtb for a S912 Vorke Z6 if anyone is asking. Thanks

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10