Official LE Test Images for Amlogic (Kodi-19)

  • tavoc The images in Index of /testing/ might improve some of the switching behaviour (improve, not resolve). I'm not sure how to disable MPEG2 but I can have a poke around. Sadly the vdec isn't in brilliant shape.

  • chewitt i will try a build of yours. Can I cross update from this one?


    I will see what the codec info shows in tvheadend and try a few other ones.

    Are you interested in logfiles from tvheadend?

  • You can cross-grade from Nightlies to my images. You cannot cross-grade from Oleg's images (balbes150) due to different boot config. I'm interested to know what resolutions and codecs are problematic. I'm not interested in TVH logs (someone else's problem).

  • Cross-grade did not work from cvh version. But I installed it new.


    HD channels switch is better than on official - SD still does not work.

    HD resolution is 1280 x 720 and is decoded in hardware with: ff-h264_v4l2m2m-drm_prime, drm_prime


    SD resolution is720x576 and is decoded in hardware with: ff-mpeg2_v4l2m2m-drm_prime

    Booth @25 FPS




    Kodi Log



    SD channels / view in log are after

    Code
    INFO <general>: CDVDVideoCodecDRMPRIME::Open - using decoder V4L2 mem2mem MPEG2



    Does this makes any sense to you - or should I get any other information?



    EDIT: youtube works fine, regardless of the resolution

    Edited once, last by tavoc ().

  • Channel switching is all about support for flushing in the hardware decoder, which is partially implemented in ffmpeg in my images. I can make sense of the other infos. I'll look into the MPEG2 issue, but I don't code so I can't fix the driver (where the issue probably is) and will need to focus on seeing if simply disabling hardware decoding for SD resolutions is an okay workaround.

  • i tested the 9.95.2 today, sadly the mpeg2 decoding does not work. As an improvement I can hear audio in SD channels.

    HD is still fine.

  • Unless you see me comment about making changes to MPEG2, there are no changes to MPEG2.

  • Christian,

    i've burned on SD your LE 9.95.2 and it runs quite fine on my Tanix tx5 pro (s905x)


    1- wifi works fine (despite on last CoreElec is not working)

    2- BT do not (who cares?)

    3- decoder PRIME works, but only via software

    4- samba (with windows 8.1 PC) is a nightmare (culprit kodi matrix)

    5- only few addons are compatible with kodi matrix

    6- (very noob question) i can't "see" any eMMC (so no reboot from internal availabile) (it maybe android 6 of my box?)

    7- THANKS A LOT for your hard work!

  • Hey all,


    Awesome work! I'm excited to test a build.


    What build would I use, for my S912 based H96pro+ ?


    Cheers,

    Ken

  • Awesome thx for the tip, will look into that build, yes it is essentially an X92 box.

    Where are the dtb files located?


    Thx!

  • Awesome thx for the tip, will look into that build, yes it is essentially an X92 box.

    Where are the dtb files located?


    Thx!

    They are all in a sub directory on the image, other than with the other elec you shouldn't copy them around, but change a config file to point to the right dtb. In case you dont find the right one for your box it's worth trying the vim2, this works very well for my box. Sorry for my vague answers, I'm currently experimenting with manjaro on the box, but didn't start it in quite a while, as my new job keeps me quite busy nowadays...