[8.2.3.1] LibreELEC 8.0 for S805

  • kszaq, I found that russian modded OE virtmod-os 2.0 rc3 (kernel 3.10.99) has almost working internal DVB driver. It initializes amlogic-dvb device, creates /dev/dvb/adapter0 but without frontend0 file. In dmesg there are lots of DVB titled messages, finishing with: "DVB: Error attach AVL6211+AV2011". But in another version of Vitmod (ver 1?, kernel 3.10.75) I got this:


    OpenELEC (VITMOD) Version: 5.0.8

    OpenELEC:~ # dmesg | grep dvb

    [ [email protected]] DVB: aml dvb init

    [ [email protected]] DVB: probe amlogic dvb driver

    [ [email protected]] DVB: registering new adapter (amlogic-dvb)

    [ [email protected]] amlogic-dvb dvb.11: DVB: registering adapter 0 frontend 1426049722 (Availink AVL6211 DVB-S2)...

    OpenELEC:~ # ls /dev/dvb/adapter0/

    demux0 dvr0 frontend0 net0


    Maybe I could somehow move the driver or whole kernel from Vitmod to your version of LE to get DVB tuner working?

  • There is no source available for Vitmod driver and it can't be ported over because it's built into kernel.

  • hey guys, i'm new here, installed ver 8.2.1.1 and then noticed the date of this thread is 2016, anyway i installed this version, everything was working beautifully then my network stopped working, wireless and wired, i did notice in the FAQ's there is something about fixing this, but i'm not all that good in Linux, does anyone have a good easy walkthrough on how i can get this fixed? thanks very much for all your hard work!

  • Hi, is it possible booting libreelec from usb pendrive instead sd card? My sd port is damaged, so I'd like install libreelec on internal memory, but I dont know ho to boot into libreelec.

    Thanks

  • Thx for your answer. I tried to connect to PC USB port, and amlogic USB flash tool see It connected. Tried to load libreelec Image, but USB flash tool wont load It.

  • kubetts LibreELEC images are not compatible with Amlogic USB Burning Tool. I can't make it work that way for several reasons, most important is that it's a proprietary Amlogic format. The only way to install is using SD card.

  • Ken82 I moved your post to correct thread. There is no 8.2.1.2 build for S805, 8.2.2.1 is being compiled. For the latest build read OP.

  • Ken82 Please don't write your posts in CODE section, it makes them harder to read.


    Automatic updates will work starting with 8.2.2.1.

  • Ken82 Please don't write your posts in CODE section, it makes them harder to read.


    Automatic updates will work starting with 8.2.2.1.

    OK it's good. I also take this opportunity to ask for another thing. I have an all-black MXQ box with the latest LibreELEC version LibreELEC-S805.arm-8.2-8.2.1.1-HD18Q.img.gz. Everything works perfectly but the remote control after switching off does not turn on the box again and I have to turn off the power to turn it back on. I already had this problem in relase 7.0. Could you do something to solve this kind of problem?

  • Ken82 IR code to wake up the box is defined by u-boot (bootloader) and can be solved only by compiling it with correct code. Bootloader comes from Android firmware so it's nothing I can solve, unfortunately.

  • Hello everyone and good Christmas Eve. I upgraded my s805 architecture box to version 8.2.2.1 but I noticed a bug. After updating me from notifications available updates and I automatically download again the old previous version 8.2.1.1. I had to disable automatic updates otherwise I always download the old version.

  • Announcement: I have decided to discontinue working on Krypton builds. I consider them to be stable and good for everyday use with not too many bugs. I will now focus on bringing Leia to S805 (if time allows).