Unofficial LE version for RK3328\RK3399 3288\3188

  • What problems do you write about ? I have everything working in Armbian on T4, including WiFi And analog audio via 3.5.

    hi @balbes150, the problem I encountered are:

    1. wifi not working

    2. HDMI does not work with HDMI-DVI converter with screen resolution lower than 1080p.

    • Official Post

    Ver 20200826 kernel 5.8.4


    Pay attention. Starting from version (20200826), the configuration order for the used DTB changes.


    Please note that the algorithm for initial configuration of the system for startup has changed. Instead of a file "uEnv.txt", the file "/extlinux/extlinux.conf " is now used. The rules for editing a file remain the same.

  • First of all, sorry for my poor English and thank you for your work.

    I also own a NanoPiM4V2 and have tried the last few builds once. Most of the time, the RK3399 builds worked for me

    But my real question is about Docker. I would like to use that, but I am not offered the Docker Service for the Installation at all, which is required for the Linuxserver Docker.

    What can I do?

    Edited 2 times, last by Lucas70 ().

  • OK thank you for the info

    Is there a period when this will be supported again?

    Or in other words. Is there any way I can provide a Kodi 18 image that supports EMMC?

    Docker support would be just as important to me as the EMMC thing

  • Ver 20200826 kernel 5.8.4


    Pay attention. Starting from version (20200826), the configuration order for the used DTB changes.


    Please note that the algorithm for initial configuration of the system for startup has changed. Instead of a file "uEnv.txt", the file "/extlinux/extlinux.conf " is now used. The rules for editing a file remain the same.

    I will try this as the last few builds haven't worked for me (blank screen no ssh)


    I wonder if I'm doing something wrong though, do I still have to replace the U-boot (as per the instructions in the first post of this thread)?


    EDIT: Answering my own question. DL'd the latest version (for M4) flashed it and nothing happened. Went through the Uboot routine and it's now working (albeit no sound and lots of add ons from the kodi repository report dependency failures, I managed to install 'films for action from the kodi repo, but all the videos stop a few seconds in).

    Edited once, last by Rothchild ().

  • The M4 images also caused problems for me and didn't start.

    The RK3399 images from the same date started without having to change anything

  • Does analog audio through the 3.5mm jack work? (RockPro64)

    • Official Post

    Is there a period when this will be supported again?

    is unknown



    I wonder if I'm doing something wrong though, do I still have to replace the U-boot (as per the instructions in the first post of this thread)?

    Adding u-boot is mandatory (for models other than Nanopc T4 and Rockpi 4M2V). must also configure the correct DTB.



    Does analog audio through the 3.5mm jack work? (RockPro64)

    I don't have RockPro64, I don't know what works on this model.




    To All

    ver 20200901 fix audio 3.5 for Nanopc T4

  • Is there a list somewhere where I can see which Addons, Services, etc. work at all with these builds, or where I can track the status of the customizations?

  • ver 20200911 kernel 5.8.8

    fix USB WiFi


    for rk3288

    ver 20200911 kernel 5.8.8 + Panfrost

    Hi balbes150.

    Please tell me,

    How can I turn off at compilation such a parameter, which is designated as "Adjust display refresh rate" in the kodi?

    The fact is that I tried to disable this parameter in the "appliance.xml" file. But in any case, the display frequency adjusted to match video (the screen goes blank for 2 seconds). For some reason, the LibreELEC team builds images "on start/stop" for rockchip, and for x86_64 this parameter is disabled by default. Where can it be disabled in the git (in which file, in which piece of code)?


    Thank you.

    Odroid C2 2GB/Odroid N2 4GB/Rockpro64 4GB/Clone MXIII Plus 8-1.5GB

  • I tried latest builds(20200901-20200918) on H96 MAX+ RK3328 with rk3328-box-h96mp.dtb. But kodi crash with :


    Code
    Sep 18 10:42:28 LibreELEC kodi.sh[1197]: MESA-LOADER: failed to open kms_swrast (search paths /usr/lib/dri)
        Sep 18 10:42:28 LibreELEC kodi.sh[1197]: failed to load driver: kms_swrast
        Sep 18 10:42:28 LibreELEC kodi.sh[1197]: MESA-LOADER: failed to open swrast (search paths /usr/lib/dri)
        Sep 18 10:42:28 LibreELEC kodi.sh[1197]: failed to load swrast driver
        Sep 18 10:42:28 LibreELEC kodi.sh[1197]: ERROR: Unable to create GUI. Exiting
        Sep 18 10:42:29 LibreELEC kodi.sh[1193]: Segmentation fault (core dumped)
        Sep 18 10:42:40 LibreELEC kodi.sh[1193]: Crash report available at /storage/.kodi/temp/kodi_crashlog_20200918104229.log


    Armbian with this dtb works good. How I may try fix it?

    PS: You build from this (GitHub - 150balbes/LibreELEC.tv at master-arm) source?