Unofficial LE version for RK3328\RK3399 3288\3188

  • This has been fixed in the new images.

    Since which date? From 20200214 and on?

    Ive tried today's image and emmc installation doesn't work for me.

    The box doesn't see internal storage.

    Maybe I get something wrong?

    Do I have to kinda mount it manually or something?

    I have to mention that earlier releases (summer ones, which were removed from yandex recently) did work. And I'm using the same dtb "rockpro64".

    I did a clean install as recommended and now I can't move the system to emmc and roll back to a legacy build as it's no longer present in the cloud.

  • Use the latest versions, where NVMe is defined on RockPI4b.i

    20200214 works as 20200201, nvme was found after loading external kernel modules after mounting storage.

    If I config storage to nvme, system halted, nvme is not visible. If I manualy insmod dw-edma.ko dw-edma-pcie.ko nvme-core.ko nvme.ko, nvme was become visible. That files from /sysroot/usr/lib/kernel-overlays/base/lib/modules/5.5.1/kernel/drivers/....

    Edited 2 times, last by rua1 ().

  • Using the one stored in the new image

    Can you run the latest version of Armbian (the principle is the same as running LE)? In Armbian, you can easily perform a number of checks that will help understand the reason why eMMC does not work (they share a common core).

  • hey balbes150 Can you post your source? I'd like to test few changes wrt packages etc.

    email or PM me what model you want to build an image for , and I'll send you a link and commands to execute ( my build system is different from the official one).

  • I tried kwiboo's source and when I put it on sd card it no longer boots. However all your build are flawless

    write the Kwiboo image to a USB flash drive. Connect together with the SD card (with my version of LE that you have running) and the USB stick LE from Kwiboo and turn on the power. My images support starting the system from USB, if the flash drive has the correct DTB for your model, the LE Kwiboo system should start

  • Hi balbes150.I don't can start up your builds for rockpro64. I get boot screen LE and then the boot does not go. I tried 4 latest builds:





    Please help me.

    Odroid C2

  • Can i do replace u-boot on Windows?

    I have H96 Max Plus (Rockchip 3328) board.
    Image works is LibreELEC-RK3328.arm-9.80-devel-20191231082706-fae7724-rockbox.img.gz (kwiboo)
    with dtb(easyb) rk3328-box-h96mp.dtb

    There are some interface issues (when change the source on TV or turn on/off or unplug-plug in HDMI) then the whole image is red filter
    And repositories do not work (failed to connect)

  • Hi,

    I can confirm this a little bit, but my RockPro64 starts, "just" Kodi crashes. I can see that the RockPro gets a ethernet address assigned and can then access it via Samba for a short time, before it reboots. I use the normal DTB and not the V2

    Attached is the zip file with all the logs.The only error I see is: "ERROR: DBus error: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files"