Nightly images for A64, H3 and H6 boards

  • No, I made a PR for that but it has several issues (doesn't work in all cases and should be done with udev instead of services). I guess best solution would be to develop some kernel and U-Boot patches, so BT MAC gets set same way as ETH MAC.

    Found this:

    kernel/git/torvalds/linux.git - Linux kernel source tree


    There's one board in u-boot making use of "local-bd-address", maybe we can use it too? Which boards are affected? Is this just a orangepi3 issue?

  • There's one board in u-boot making use of "local-bd-address", maybe we can use it too?

    It was my plan to research this. I don't know enough details to answer this.

    Which boards are affected? Is this just a orangepi3 issue?

    From supported boards only OPi3 suffers this. But this is actually property of the used BT module if it has unique MAC address programmed in or it uses default one.


    If you can research this topic and make something that works well, I would be grateful. There is much to do and currently I'm working on media drivers (cedrus, deinterlacer)...

  • From supported boards only OPi3 suffers this. But this is actually property of the used BT module if it has unique MAC address programmed in or it uses default one.


    If you can research this topic and make something that works well, I would be grateful.

    Yeah, setting it via HCI_QUIRK_USE_BDADDR_PROPERTY and uboot gets it going: 0001-btmac.patch.txt

    But that's the ethernet mac with a bit flipped, I guess we want the wlan mac. Any idea how to get that from u-boot?

  • dhewg Nice! If you don't mind working with Linux and U-Boot upstream on that, I'll close my PR. This is much better.


    There is no wlan-mac set. Even setting ethernet addresses is platform specific. For sunxi, it is generated here: board/sunxi/board.c · master · U-Boot / U-Boot · GitLab


    shaneq718 I don't think that is samba issue but kernel issue. Can you tell me exactly which board you have? pine64, pine64 plus or pine64 LTS? Hopefully you took exactly the right image. In the past, mix-ups caused network issues.

  • It's the 1gb Pine A64 board. Just for kicks, I tried the release from about a month ago as well and it stops in the same spot.

  • Nice! If you don't mind working with Linux and U-Boot upstream on that, I'll close my PR. This is much better.


    There is no wlan-mac set. Even setting ethernet addresses is platform specific. For sunxi, it is generated here: board/sunxi/board.c · master · U-Boot / U-Boot · GitLab

    So where does the wlan mac come from? I'm getting an OUI of 6C:21:A2 AmpakTec AMPAK Technology, Inc.


    As for the bdaddr, I can try to get something upstream. But there's no opi3 support in u-boot atm. Even when adding that with the dts from linux, there's no ethernet support in linux mainline. And with the current dts copied to u-boot, my patch doesn't work because there's no "ethaddr"...


    So we need at least Add ethernet support for Orange Pi 3 on mainline before upsteaming u-boot. Until then we need to carry the bdaddr patches I guess...

  • So where does the wlan mac come from? I'm getting an OUI of 6C:21:A2 AmpakTec AMPAK Technology, Inc.

    Either this is also default one and it's handling is wrong or it indeed has custom WLAN MAC programmed in. I don't really know these modules well enough.

    As for the bdaddr, I can try to get something upstream. But there's no opi3 support in u-boot atm. Even when adding that with the dts from linux, there's no ethernet support in linux mainline. And with the current dts copied to u-boot, my patch doesn't work because there's no "ethaddr"...

    I added my own patches for OPi3 to U-Boot which includes ethernet node. I had a plan to upstream support when 5.5-rc1 is released (you have to specify Linux git hash of DT). As with everything done for the first time, you have to come with something and send it (marked as RFC), just to start discussion, even if it is totally hackish.

  • Short list of things happened lately:

    - Removing everything Python 2 related (Kodi also uses Py3 now), so there were issues like broken LE settings addon, but most (all?) of them should be solved now

    - Kodi was updated to development version, which also breaks plugin compatibility, especially those from third party repositories. However, this is important change which will help us iron out issues before LE 10 alpha is prepared.

    - Completely reworked HW decoding driver improvements - some of them will be included in Linux 5.5, other needs some more work. Anyway, with this update HEVC decoding should not crash anymore. All HEVC samples provided on forum which previously crashed VPU (green screen) work now. Unfortunately, 4K H264 on H6 still isn't decoded properly. Solution for that still eludes me.

    - high bitrate HDMI audio should work now - same solution might also fix other HDMI audio issues, please test!

    - board improvements - IR remotes enabled by default for Beelink X2, Tanix TX6 and Beelink GS1, OrangePi 3 bluetooth should work with next nightly, but it needs full update! For that you can just add full OPi3 image (.img) in update folder.


    Some near future plans:

    - VP8 HW decoding already works perfectly, but is not yet included. It needs some fixes for switching between H264 and VP8 (they use same part of VPU)

    - H6 is planned to switch to completely free and open source mesa GPU driver soon! This means that H6 won't use any kind of blob for essential functionality (RAM, VPU, GPU, etc.). However, various FW blobs for wifi and DVB dongles will still be included.

  • Hey, tnx for informing us Jernej, great progress.


    Quote

    - H6 is planned to switch to completely free and open source mesa GPU driver soon! This means that H6 won't use any kind of blob for essential functionality (RAM, VPU, GPU, etc.)

    .

    What is the situation with H3, will it be free too (if not already)?

  • What is the situation with H3, will it be free too (if not already)?

    I just tried lima and there is a bug. Kodi starts ok according to logs and sounds, but I can't see anything on screen. Some weird interaction between Kodi, mesa and display driver.

  • First of all, thank you for working on this. I've got an OrangePi 3 and I loaded nightly-20191015 on to see how it worked and was pleasantly surprised that it seems quite good. I loaded the mythtv plugin and found it works fine with this image.


    I did notice that LibreELEC will go to sleep or kind of turn off if the TV is turned off. But it doesn't wake up correctly. I'm sure there's a setting to prevent it from turning off that I haven't found yet. I'm hoping that the waking up will be fixed eventually.


    I wanted to try the newest nightly, so the other day I got nightly-20191118 and upgraded by putting the image into /storage/.update and rebooting. Apparently the mythtv plugin is not compatible with this version. Reading other posts, it appears I will need to build it myself if I would like to keep using it with the newer images. I'm looking forward to upcoming BT support on this platform.

  • https://drive.google.com/open?id=1jkoigg2ckogkas6uullzmyn6_qxis-ea

    First of all, thank you for working on this. I've got an OrangePi 3 and I loaded nightly-20191015 on to see how it worked and was pleasantly surprised that it seems quite good. I loaded the mythtv plugin and found it works fine with this image.


    I did notice that LibreELEC will go to sleep or kind of turn off if the TV is turned off. But it doesn't wake up correctly. I'm sure there's a setting to prevent it from turning off that I haven't found yet. I'm hoping that the waking up will be fixed eventually.


    I wanted to try the newest nightly, so the other day I got nightly-20191118 and upgraded by putting the image into /storage/.update and rebooting. Apparently the mythtv plugin is not compatible with this version. Reading other posts, it appears I will need to build it myself if I would like to keep using it with the newer images. I'm looking forward to upcoming BT support on this platform.

    https://drive.google.com/open?id=1jkoigg2ckogkas6uullzmyn6_qxis-ea



    Or maybe https://drive.google.com/open?id=1dyaiqol6jwxzgtiygj2oexmlkcluubik

    Edited once, last by jarda9 ().

  • Sweet. Thanks jarda9 .


    I compiled it myself, then put it on a USB drive to install. I got an unknown error, so I looked at the logs:


    Code
    1. ERROR: Unable to load /storage/.kodi/addons/pvr.mythtv/pvr.mythtv.so.6.2.4, reason: /storage/.kodi/addons/pvr.mythtv /pvr.mythtv.so.6.2.4: wrong ELF class: ELFCLASS64


    D'oh.


    I'll try the version you link.