Nightly images for A64, H3 and H6 boards

  • I prepared H264 and H265 (HEVC) fixes in this branch: GitHub - jernejsk/LibreELEC.tv at aw_linux_patches

    I'm waiting on some patches to be accepted to Linux before I make PR to LE github, but just for information on what I work on:

    - all known H264 issues fixed

    - H265 decoding improvement

    - 10-bit H265 decoding on H6 fixed


    If anyone wants to test that, please build image yourself. Otherwise wait until PR is prepared and accepted.


    BTW, I'll get OrangePi 3 shortly, so support for it will also added soon. Initial H6 HEVC 10-bit HDR test was also successful, but that won't be added soon.

  • 2. The second one was converted from MPEG4 to HEVC1 with default parameters. After trying to play it, the sound starts to play and the system immediately reboots.

    Kwiboo solved mystery with your video sample. It won't crash with very latest Kodi, but unfortunately, LE build system uses a bit old version. Not sure when will it be updated. However, it still won't be correctly decoded (blank screen). Your video uses RGB color space in GBR format (just color order is changed), which is not supported by Kodi's DRMPRIME renderer nor with HW video output. To properly display it, additional work on Kodi and maybe also on display driver is needed.


    It's strange that default conversion used RGB color space. YUV is much much more common.

  • How well does it work?


    If you'd like, open new topic with community image for this board. Otherwise this post will get lost (or not, now that's on first page).

    OrangePi One: Not good. Laggy and freeze..

  • BTW, I'll get OrangePi 3 shortly, so support for it will also added soon.

    Good news. Many people who waiting image for this board. Thanks!

    Board: Orange PI 3 H6 Quad-core 64-bit 1.8GHZ ARM Cortex-A53

    TV: TELEFUNKEN TF-LED65S75T2SU

  • Did somebody try HTSP Tvheadend Client? I am trying it on Orange Pi PC , but when I select some program HD or SD (doesnt matter) , nothing happens and Kodi freezes.

  • Don't have unlimited connection to download and pc to compile. Waiting mode update img

  • Hi all,

    I would like to ask you for help. I have problem with network connection - no wired network even if it is plugged in (during the first boot wizard showing info about language hostname and network - empty box.) I have PINE A64+ and tried these images LibreELEC-A64.arm-9.1-devel-20190416153844-ebf5f72-pine64.img, LibreELEC-A64.arm-9.1-devel-20190527100834-f1cc5ab-pine64.img, LibreELEC-A64.arm-9.1-nightly-20190529-1f19b2b-pine64.img with no success. I tried to activate network through system - network but it went always offline (GUI).

    I have also one old image LibreELEC-A64.arm-9.0-devel-20181220210336-147ea78-pine64_plus and this one works fine - network is connected with leased IP address (playback is so-so - new update welcomed).

    Is it possible to switch to command line, or anyone can help how to fix it any ideas welcomed.

    If it is important this board is one of those first from KS campaign (do not know if HW has been modified).

  • I have also one old image LibreELEC-A64.arm-9.0-devel-20181220210336-147ea78-pine64_plus and this one works fine

    This works because it is correct image for your board - note the "plus" in it's name. For some reason nightly image for Pine64 Plus isn't copied to download server (similarly as OrangePi Plus2E).


    Due to a lot of problems with nightly builds, I'll probably build images now and then and linked it in OP.

  • Updated report about orange pi one:

    After reboot libreelec works very well! Also HTSP Tvheadend Client. (I have also Orange Pi PC, my problem with HTSP Client was solved also by restart the system)

    Good work!

    In Orange Pi One I am using Orange Pi PC image.

  • jernej Thank you for your help - correct image working fine.

    But I thought that from the change you did is only on image for all pine a64 boards - my fault.

  • Hi jernej , at first, I would like to thank you for your GREAT work!

    I'm using Orange Pi PC Plus image and it works like a charm.


    I'm only surpised that H5 is missing here. Is there any reason for it? I'm not able to find this information anywhere in this forum :/

    I have Orange Pi Prime which is quite nice board, but couldn't find well working image for it ;(

  • I'm only surpised that H5 is missing here. Is there any reason for it?

    Yes, it is. It has different GPU than any other SoC. Even drivers from other companies which use same GPU are not compatible with it. Workaround exist, but adds additional processing for every image rendered, which is far from ideal. This platform waits on Lima to become good enough to be used instead of binary drivers.


    Two additional problems were observed - HDMI CEC is not working at all and image is unstable (freezes), maybe because of GPU driver hack or maybe RAM driver issues or maybe something else entirely.

  • Any chance of adding a build for the NanoPi M1?

    Yes, but note that only version with 1 GiB of RAM will be supported. If you have 512 MiB version you can still use same image, but I don't accept bug reports which occurs due to memory consumption. Which version do you have?

  • Yes, but note that only version with 1 GiB of RAM will be supported. If you have 512 MiB version you can still use same image, but I don't accept bug reports which occurs due to memory consumption. Which version do you have?

    Thanks! I thought you might say that - you have been very clear about 512MiB devices, and I can certainly understand your reasoning!


    I have a 512MiB device. I'm currently using a build from the previous thread. I haven't run into any low memory issues, but I'm a pretty light user.


    Thanks again

    Nik