Test LibreELEC images with KODI-19 for S9xxx

  • afaik these drivers are not at the mainline kernel ?


    I don't think they are, but I don't think they were in kernel 3.14 either. Anyway, it was just a way to answer the question if it had support for the dvb tuner in the ki pro.

  • It would have been useful if the announcement were a little bit more informative, ie only Kernel based dvb drivers are enabled.

    Shoog

  • 9-11 Odroid C2 build freshly installed on a brand new SD (for now I run CoreElec on an EMMC to keep the girls happy). It works rather well, but it halts when I do a reboot. The OS seems to be completely shutdown, the heartbeat led stops flashing, SSH of course is down at that point too (so I can't log anything), but it won't reboot, or at least it doesn't actually start booting.


    Passthrough audio not working well (I think that's to be expected at this point). DVD menu's (running from DVD ISO's) are not working properly. The studio-trailers run fine, but as soon as an interactive menu should show up, it's either blank, or sometimes the menu shows but the 'cursor' is flashing. Then, when for example I choose 'select episode' I get to the episode menu, but then there's no selector at all.


    I'm new to these test builds. Having read trough most of the posts in this thread, I'm not really sure if you guys want logs for these kind of issues, or it's too soon to iron these out?


    Anyway I want to applaud you guys in how far you've already come and how well this is already running on a recent kernel!

  • New look with KODI-19. Please note, this is the first trial version and many things may not work.




    Both Images for Nanopi-K2 won't boot on freshly burned SD: 20191010 and 20190911.

    To check the reasons I don't post the image for nanopi-k2. Can you specify the exact version of the image (full name) that runs from the SD card ?


    hi my beelink gt1 mini a no boot in all virsions

    I checked on the Beelink GT1 mini. Everything works, including WiFi. Follow the instructions exactly.

  • Hello balbes150 ,


    The last version that boots is LibreELEC-AMLGX.arm-9.80-devel-20190821172816-07b919f-nanopi-k2.img.gz.


    I've looked at your Github and it appears that the extra steps required to get u-boot working on the NanoPi K2 is missing in the latest builds. Copied from the u-boot readme for this boot, these steps are:


    These lines do show up in your Amlogic-Leia-4.x branch (in LibreELEC.tv/projects/Amlogic/bootloader/mkimage), but do not appear to have been merged into the latest builds. That's probably why the images are no longer booting? FYI, I compiled u-boot from the above instructions and burn it to the SD card that already has your image and it boots fine again.


    While you're at it, could you please test if playing DRM content works on your builds (any device and not just the NanoPi K2)? As mentioned in my earlier post, so far I've had no success and I'm not sure if it's your images that's not working, or it's the InputStream Adaptive add-on / libwidevine that's not compatible.. You can test with the Video Test Streams Add-on by Matt Huisman (choose "Input Stream Adaptive - Dash with Widevine").


    Thank you for your hard work!

  • New look with KODI-19. Please note, this is the first trial version and many things may not work.

    X96 MAX 64/4G eMMC and SD Card work.


    Does anyone have usable wireless? The box seems to get very upset with very little traffic.


  • Quote from balbes150

    To check the reasons I don't post the image for nanopi-k2. Can you specify the exact version of the image (full name) that runs from the SD card ?

    I don't test every single Version. Last build that was booting: LibreELEC-AMLGX.arm-9.80-devel-20190821172816-07b919f-nanopi-k2.img.

  • balbes150

    Version-20190913 Kodi 19

    Order placed, order fulfilled: LibreELEC Module Drivers.

    :thumbup::thumbup::thumbup:

    Even though it was not possible to test Driver TBS, Not even a tuner was detected on Tvheadend. (tests done with 3 drivers)


    Another problem: tvheadend htsp client the dependency on kodi.binary.global.gui version

    It is useless knowledge if not shared the world.

  • LibreELEC-AMLG12.arm-9.80-devel-20190913121812-60568a1-odroid-n2.img on Odroid n2 has an green overlay, after reboot over splasscreen and the menu.



    the same for s905x2 is testing now

  • Tests done on a KI Pro+TBS

    Same problems reported above!

    I followed documents for more information.

    lsusb dmesg

    lsusb, dmesg.txt

    It is useless knowledge if not shared the world.

    Edited once, last by erbas ().

  • Hello Balbes150,


    Both Images for Nanopi-K2 won't boot on freshly burned SD: 20191010 and 20190911.


    I've looked at your Github and it appears that the extra steps required to get u-boot working on the NanoPi K2 is missing in the latest builds. Copied from the u-boot readme for this boot, these steps are:

    Check the last option (20190916) to run from Sd card on nanopi-k2.



    While you're at it, could you please test if playing DRM content works on your builds (any device and not just the NanoPi K2)? As mentioned in my earlier post, so far I've had no success and I'm not sure if it's your images that's not working, or it's the InputStream Adaptive add-on / libwidevine that's not compatible.. You can test with the Video Test Streams Add-on by Matt Huisman (choose "Input Stream Adaptive - Dash with Widevine").

    Alas, I have no opportunity and time for such checks.

  • Check the last option (20190916) to run from Sd card on nanopi-k2.



    Alas, I have no opportunity and time for such checks.

    Did a quick test with the 20190916 image. Still doesn't boot - had to manually dd u-boot for it to work.

  • The last option (20190916)

    Same Problems

    tvheadend htsp client the dependency on kodi.binary.global.gui version

    Even though it was not possible to test Driver TBS, Not even a tuner was detected on Tvheadend. (tests done with 3 drivers)


    lsusb, dmesg.txt

    It is useless knowledge if not shared the world.

  • The last option (20190916)

    Same Problems

    tvheadend htsp client the dependency on kodi.binary.global.gui version

    Even though it was not possible to test Driver TBS, Not even a tuner was detected on Tvheadend. (tests done with 3 drivers)

    lsusb, dmesg.txt

    Code
    1. dvb-usb: found a 'TBS 5520se USB2.0' in cold state, will try to load a firmware
    2. [ 13.388144] usb 1-1.4.1: Direct firmware load for dvb-usb-tbsqbox-id5521.fw failed with error -2
    3. [ 13.388150] dvb-usb: did not find the firmware file 'dvb-usb-tbsqbox-id5521.fw' (status -2). You can use <kernel_dir>/scripts/get_dvb_firmware to get the firmware
    Code
    1. you have to add firmware folder dvb-usb-tbsqbox-id5521.fw


    dvb-firmware/dvb-usb-tbsqbox-id5521.fw at master · CoreELEC/dvb-firmware · GitHub

  • Afaik because C2 has its own bootloader (uboot) that can't be replaced with the much more recent version that is used at other images. Basically there are "crapfixes" at these bootloader that are not open source. Could be related to workaround the hw bugs of the C2 board.


    afaik these drivers are not at the mainline kernel ?

    Yes that would be correct... the C2 if you want to build uboot for it requires you to either include hk;s provided bl1 blob in the uboot build or you need to disassemble their blob and take its parameters and info and include it in your own custom bootloader...


    At least that is the way it was when i last looked a long time ago...