Test LibreELEC images with KODI-18 for S9xxx

  • In libreelec 9.0.1 the tuner also works (albeit not as good as under android), but then it's still using kernel 3.14

  • Yes, LE 9.0.1 includes DVB driver developed by afl1 .


    There is no support for built-in DVB tuner in mainline test images yet.


    As far as I can tell afl1 made his driver work with mainline Linux, so it should be doable to add this driver. Note that this won't happen in a minute, it will take some time.

  • Shoog Please don't confuse terms: DVB driver has nothing to do with Kodi version but is has all to do with kernel version.


    LE 9 uses Afl1's DVB driver with 3.14 kernel (and Kodi Leia but it doesn't matter).

    CE 9 uses Afl1's DVB driver with 3.14 kernel.


    This thread is about mainline (5.x) kernel.

  • X96 Max 2g/16G S905x2 used -rmii dtb


    the 20190430 installed


    WIred NIC still needs to be switched off and on again for it to connect, as before.


    It is not possible to get any sound working as the sound selection option is greyed out while showing the Bluetooth option.


    Tvheadend HTSP client installed ..... I was given three versions as options.

    The most recent worked fine so did not try others.


    Tvheadend server installed, but it did not install properly (apparently) and did not function.


    Mouse, keyboard, and remote functioned OOTB. I am unsure if all functions are available but there were sufficient to do simple tests.

  • Libreelec 8.2 had working driver support for your intternal tuner, I am not certain if it was ever ported over to the Leia builds.


    Shoog

    Good kszaq already replied to you.

    I hope you understand, Libreelec is working on bringing the best. We no longer use frankenstein versions.

  • Does anyone have an idea how to make kernel 5.1 images boot on Le Potato? I built from current LE Amlogic branch, edited uEnv.ini (dtb_name=/dtb/meson-gxl-s905x-libretech-cc.dtb) but it does not even attempt to boot up.

  • add UBOOT_SYSTEM=lepotato to build command

    I get this build error:

  • hi


    i tested libreelec 9.1 kernel 5.1 bellbas 150 for my wetek play 2 is work fine

    booting work fine after copy file boot.ini

    wifi work

    remote work

    video x264 and p1080 work and some 4k old work

    sound work

    my video tester

    YouTube


    hi balbes150 kszaq chewitt

    I have a question why LE not booting with android 6 in WP2


    LE with android 5.1 booting fine 100/100

  • Perhaps now is moment to start new kernel_5.x - LibreELEC Testbuilds for S9xxx (Kodi 19.0) thread to keep everyone updated on available alpha releases etc. With perhaps clarification within 1st post of current reference SOC S9xxx devices, most likely to gain full support in next LibreELEC version?


    Ive just performed live in situ update of my KVIM2 Pro (from LibreELEC-AMLGX.arm-9.1-devel-20190425 to LibreELEC-AMLGX.arm-9.1-devel-20190430) transfering downloaded tar file over network into update folder on VIM2. Rebooting device updates and maintains all existing user settings, addons installed etc.


    I am personally finding most recent alpha releases with panfrost graphics driver more stable and acceptable for below 4K test usage with local files, Internet streaming + Live Terrestrial TV served from rpi3 running Tvheaend. :)8) With understanding of existing limitations i.e. No wifi for KVIM2


    Thanks to everyone involved.

    rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV

    KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers