Test LE images with Kodi-19 for S9xxx

  • How are CEC support and HDMI audio pass-through support progressing for Odroid-C2?
    Any news in the latest builds? Is any of these working or close to be working soon?


    Thanks.

  • hi balbes150,


    Currently using LibreELEC-ARMv8.arm-9.80-devel-20201005141105-8945356-amlgx.img.gz for my Fiberhome HG680P

    There's a problem while connecting into wifi AP, when I tried to select Connect, it's just return into network AP list, it won't connect.


    Pls look into it, it uses rtl8188fu/rtl8189fs wifi module, thanx in advance.

  • Recently I found out that HEVC does not work (I'm not 100% sure when did it stop, or was it working previously at all). The following is observable on

    • LibreELEC-ARMv8.aarch64-9.80-devel-20201006082248-fe4b097-amlgx.img
    • LibreELEC-ARMv8.aarch64-9.80-devel-20200923122613-36bc7e3-amlgx.img

    using s905w HW:


    Found out these related issues:

    popcornmix/gbm branch unable to playback 4k HEVC 10-bit video but LE can

    kodi-git build script for mainline hwaccel media decoding


    Does anyone else experience this ?

  • Any new info about support for S905X3 devices?


    I have just ordered a X96 Air with 4 GB RAM / 64 GB eMMC and was wondering if it will be possible to run LE instead of CE.

  • it is still in development stage, this is beta version of Libreelec.

  • arm64: dts: meson: add support for the WeTek Core 2

    Thank you for the people who own this device.

    Core2 is an S912 device that was never released so I'm fairly confident I'm the only person who owns one :)


    I use it for Panfrost sanity testing on GXM when I get bored of using a VIM2.

  • Got a new Ugoos AM6 box;

    tried the 20.10 aarch64 g12; kodi segfaults;

    I am able to start the box using the aarch64 g12 build from 12.10. There I get occasional system freezes after a period of time (depending on my interaction with the UI).


    On both releases I get buggy u-boot.ext HDMI attempts (vertical random color lines) and no kernel issues in dmesg.

    Anyone else have these issues or I'm doing something wrong?

  • Same here with GT King Pro, mainline kernel is not stable for GT King Pro too.

  • GT-King/Pro/GS-King-X all have an issue with deadlocks under load that hasn't been figured out. I don't do code so have no clue where the problem really lies but suspicions are on the block subsystem - or in regulators - beelink wouldn't be the first vendor to share schematics that don't match the boards they produced. I've reported the problem upstream without much success (will redo on 5.10-rc1 shortly). FWIW, I don't see deadlock issues on other devices (VIMs, etc.) and overall I consider the mainline kernel to be very stable (not feature compelte, but stable within the features present. I only see deadlocks when experimenting with things that I expect to cause deadlocks.