[8.90.1] CoreELEC for S905/S912 devices

  • After updating from 8.90.5 to 8.90.1 my remote dont work


    Code
    # table airmouse, type: nec
    0x140 KEY_POWER
    Code
    # * * airmouse
    * * airmouse

    at 8.90.5 my remote work


    when i try "systemctl stop eventlircd" i get an error "Failed to stop eventlircd.service: Unit eventlircd.service not loaded."


    any idea?

    1. DTB.
    2. (Optional) Redo the remote config, there is a link in the FAQ.
    1. DTB.
    2. (Optional) Redo the remote config, there is a link in the FAQ.

    i have a x92 3+32


    1. i use q200_3g dtb this one works in all LE/CE versions.

    2 i redo the remote config but when i do "systemctl stop eventlircd" i get an error "Failed to stop eventlircd.service: Unit eventlircd.service not loaded."


    i will test the q201_3g dtb but there is no gigabit lan


    -- ok with the q201 is the same problem


    when i try to load my map with "ir-keytable -a /storage/.config/rc_maps.cfg -s rc0"


    it only shows "table from /etc/rc_keymaps or /usr/lib/udev/rc_keymaps"

    Edited 2 times, last by v0rtex ().

  • Maybe i'm wrong, but i think eventlirc is removed from packages.


    Remove eventlircd from virtual/remote · CoreELEC/[email protected] · GitHub


    On my system eventlirc is also not available, but remote works.


    Maybe check dmesg or kodi log files.



    boot2k3

    Is that file


    CoreELEC:~/.config/udev.rules.d # ls

    98-eventlircd.rules README


    still needed in 8.90.1?

  • no, you can delete 98-eventlircd.rules file

  • For X92 you need to use q200 dtb

    Please upload your rc_maps.cfg to check, must work

  • v0rtex


    1. You need to use the DTB from the device_trees folder on the root of the SD card, not the old one from the previous install.

    2. Regarding the remote, you're doing it wrong. I suggest you reread the first post in the remote thread, and post in that thread if you don't succeed.


    ersenos What kind of impact? The stock firmware shouldn't affect CE, so upgrading it won't do anything good.

  • After updating from 8.90.5 to 8.90.1 my remote dont work

    Then revert /shrug

    Or check the threads that are dealing with ir remotes 8o

  • @adamg PLEASE tell me that notifications are enabled for new releases. It's so painful having to come here to check for updates ;(

  • I have solved the problem by adding "systemctl stop eventlircd" in "/storage/.config/autostart.sh" (new file).


    I don't know why, but this helped.

    Unfortunately this didnt work for me :(

    2xMinix U1, Onkyo NR626 and Samsung 40" 4K TV

  • Sounds like a bad HDMI cable to me.

    Thanks. Have been doing some research and a bad cable could result in a behaviour similar to what I am experiencing.

    Based on a previous comment stating that it was a known issue to be fixed in latest version I had postponed its replacement.


    Will try a new one to verify if the issue is solved.


    Thanks again

    Beelink MiniMX III 2GB/16GB gigabit LAN
    LibreELEC running from SD card (will confirm version on post).

    Edited once, last by Gaudi ().

  • The auto update code is not complete yet, it will notify you that an update is available however you will have to download it manually at present until it is complete

    Thank you, will do!

  • Hi all,

    have been away for a while - just tried 8.90.1 CoreELEC on Le Potato - the crash issue on large file writes is still there.

    I'm wondering: Does this only bother me? It actually avoids recording, timeshift to disc and any larger media file copy to Kodi. I'd have expected that this is a problem for more people...

    Whatever I can do to provide in terms of insights, logs, UART output... into what's going wrong, just let me know.

    Cheers

    Hauke

  • My 2cents. Been using Kszaq's ver. 8.2 for about a year on my Mecool M8S Pro, mainly as my Tvheadend server for my DVR backend. Been following this thread for a long time and was kinda apprehensive about installing this alpha version on my box after reading all the horror stories about issues...


    Anyway, I updated my version 8.2, with Wrxtasy's improved version, but it killed my box (no offense to Wrxtasy). So, I figured it was an opportunity to try this port by Adamg and see how it worked. I figured my remote would not work (use Ethernet so not concerned about WiFi) after reading all the problems others have experienced.


    I only run OpenELEC, LibreELEC and now CoreELEC from microSD cards and not from the internal memory, so I just downloaded the latest build and used Etcher to create my bootable drive on my microSD card. After I created the bootable disk, I opened it with Windows explorer and copied the correct device tree form the folder that is included in the port. I pasted it to the root of the microSD card and renamed it to "dtb.img" and replaced the existing dtb.img file.


    Poped the microSD card into my Mecool box and from within Android, I opened my terminal emulator app and typed "reboot update". After it rebooted, it installed CoreELEC (love that opening screen), then the fun began.


    Since my memory is not very good, I had to pour over my notes on how to get the EPG working on my Tvheadend server. After a few tries, using Edit4ever's "script.module.zap2epg-0.7.4.zip", all my guide data fell right into place, no fuss, no muss. I had to use TVheadend server 4.2, because 4.3 could not find my HDHomeRun tuners, but 4.2 found them right away.


    So, I was very apprehensive, about installing this alpha version, but it is actually easier to install than earlier versions.


    That is my story and I am sticking to it.


    Of course there are a few hiccups, but nothing major.