[8.90.1] CoreELEC for S905/S912 devices

  • Thanks... any idea why? In my case, I have an Epson 5040UB, which only supports 4:2:2 10bit (really transmitted at 12bit for my PJ)...



    Kodi with full 3D & HD audio home theater enthusiast

  • Thanks... any idea why? In my case, I have an Epson 5040UB, which only supports 4:2:2 10bit (really transmitted at 12bit for my PJ)...

    No idea why it might be in this thread somewhere but it's a mess so doubtful you'll find it. You can set echo '422,10bit' > /sys/class/amhdmitx/amhdmitx0/attr in the autostart.sh and see if it helps

  • ce 8.90.1

    nexbox a95x


    Sourcefile is a 720p x265 10bit with AAC 5.1.mkv


    I use the following Kodi Features:

    "Sync Playback to Display": enabled

    "Threshold for Pitch Correction": 100

    "Allow Passthrough": enabled

    Enable Dolby Digital (AC3) transcoding: enabled


    All starts Sync but seconds later it begins to get async.

    Sound comes later and later and later and after a minute Video starts getting jerky.


    If Sourcefile is a 1080p x265 10bit with AC3 5.1.mkv all runs fine.


    Are there Problems with the AAC Decoder?

    Yesterday i had little Problems playing an AAC 5.1 Movie without any Kind of Passthrough (Just Stereo Output to TV).


    EDIT: Now i have Async with 720p x264 AC3 5.1.mkv

    EDIT: No Idea. Some Files are Sync some not...

    Edited once, last by thomaz ().

  • try to disable "Sync Playback to Display"

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Thanks... any idea why? In my case, I have an Epson 5040UB, which only supports 4:2:2 10bit (really transmitted at 12bit for my PJ)...


    yRtifRe.jpg

    I didn't realise so many people used it however it needs to be reworked and read supported colourspaces the same way supported resolutions are read rather than list all available options and then that way it won't cause any issues for people selecting an unsupported option. I would also like the settings to take immediate effect rather than having to reboot with a dialogue saying are you happy with this etc...

  • try to disable "Sync Playback to Display"

    i need this feature.


    no matter, downgraded back to ce 8.90.0 and on the first view all works.


    EDIT: BUT after hardreset and rebuild everything from scratch its again async/jerky.

    why did it work directly after downgrading to 8.90.0 with 8.90.1 configs?


    really strange.

    Edited 2 times, last by thomaz ().

  • I didn't realise so many people used it however it needs to be reworked and read supported colourspaces the same way supported resolutions are read rather than list all available options and then that way it won't cause any issues for people selecting an unsupported option. I would also like the settings to take immediate effect rather than having to reboot with a dialogue saying are you happy with this etc...

    Thanks. Not sure if an automatic option will work... I have to manually force [email protected] (or lower) for 10/12-bit and HDR to work w/Epson 5040UB even on my Android boxes like nVidia Shield and Zidoo X9S. This also applies to Epson 4000, 6040UB, and EU variants of these... all of which are limited by 10.2Gbps HDMI bandwidth (vs. 18Gbps).

    Kodi with full 3D & HD audio home theater enthusiast

  • ce 8.90.1

    gt1 s912


    ir configued, remote works.

    and suspend mode activated.

    gone to suspend mode and waked by ir remote.


    then ir remote doesn't work.

  • You have to disable "Sync playback to display" for hw accelerated playback. Video driver is running in "free-run mode" and syncing to display is possible only by skipping/dropping frames.

  • I use the following Kodi Features:

    "Sync Playback to Display": enabled

    "Allow Passthrough": enabled

    That's not a problem with this ROM. Please head over to the KODI forum, there are dozens of threads about this combination of settings from users who fail to understand what they're doing.

    T6 (2GB/16GB, S905x, Android 7.1.1, CoreElec - living on the bleeding edge)

  • Suspend mode is unsupported in current version.

  • Getting green screen again with both of these, which had been fixed by previous build (it was around April 6)...


    Code
    1. echo '422,10bit' > /sys/class/amhdmitx/amhdmitx0/attr
    Code
    1. echo '422,12bit' > /sys/class/amhdmitx/amhdmitx0/attr

    Kodi with full 3D & HD audio home theater enthusiast

  • Trying tvheadend 4.3 frequent locks, impossible to use

    Returning to tvheadend 4.2 super stable

    KI Pro afl1 :thumbup:

    The other functions have not encountered problems.

    It is useless knowledge if not shared the world.

  • thanks dev.

    then i will wait for patch

    There will be no patch so you will be waiting a long time, it either works for your box or doesn't, problem is in u-boot which we don't have source for.

    If remote not working why post here and not in issue tracker which all of the CE team monitor on a daily basis?


  • A small experience Story:


    I felt asleep while 4k tv channel was running via DVBViewer Addon.

    Thunderstorm came.

    Poor Signal.

    I woke up.

    Picture Frozen.

    I tried to switch the Channel 2-3 Times.

    Nothing happens.

    Then the Box didn't respond to Inputs anymore.

    I SSHed into the Box and did a "reboot".

    It shutted down but didnt came back.

    I had to disconnect and reconnet the Power Plug.