[8.90.1] CoreELEC for S905/S912 devices

  • It's a Panasonic plasma from 2012. Model is TX-P42X50B and has native display of 1024x768. It does have 1080p and 720p modes. I use 1080p/50Hz for CE.


    It still gives a great picture - I won't upgrade it until it breaks :-)

    For the true color replace kernel module/driver from addons/libreelec settings/drivers. I have panasonic plasma too, and this fixing it.

  • For the true color replace kernel module/driver from addons/libreelec settings/drivers. I have panasonic plasma too, and this fixing it.

    I just tried it on my second TV (a new 4k LED) and it does the exact same thing.


    How do you replace the kernel module/driver from addons/libreelec settings/drivers?


    UPDATE: The plot thickens............ Just tried it with a Sunvell S905X box (the previous box was Sunvell S905). Same sd card, same TV, same HDMI cable, swapped the dtb for s905x dtb and everything works - I see the shiny new red and white CoreELEC logo!!


    So is it a CPU issue?

    Edited 2 times, last by ukmark62 ().

  • I just tried it on my second TV (a new 4k LED) and it does the exact same thing.


    How do you replace the kernel module/driver from addons/libreelec settings/drivers?

    It's doing that because the settings are saved after first boot for your TV, if you do a fresh reinstall and then put it on your second TV you will find it no longer does it, failing that it's a poor quality HDMI lead, the only TVs with green screen issues are Philips ones from 2009.

  • How do you replace the kernel module/driver from addons/libreelec settings/drivers?

    In the add-ons there should be a libreelec icon with a gear. There are three modules (libreelec, crazy cat and another third). Here is the third one to enable and the system will be reboot with the new parameters.


    ps. I'm using s905d

    Edited once, last by A.S._id ().

  • In the add-ons there should be a libreelec icon with a gear. There are three modules (libreelec, crazy cat and another third). Here is the third one to enable and the system will be reboot with the new parameters.


    ps. I'm using s905d

    Thanks tried all of 3 of them (libreelec, crazy cat and hauppage) but none worked.

  • It's doing that because the settings are saved after first boot for your TV, if you do a fresh reinstall and then put it on your second TV you will find it no longer does it, failing that it's a poor quality HDMI lead, the only TVs with green screen issues are Philips ones from 2009.

    Do you (or anyone) know if there's a setting or settings on the box itself that can be changed?


    I tried the same sd card, same hdmi cable and same tv with a S905x box, different dtb, (original one with issue was S905) and that box worked perfectly.

    Maybe some setting to do with hdmi attributes etc needs changing on the box itself??


    EDIT: ignore that - if I boot the box from internal (LE 8 installed), the box boots showing the LE log (without any green screen) - so that would suggest the problem can't be on the box??


    EDIT2: Reinstall worked. Thanks adamg

    Edited 3 times, last by ukmark62 ().

  • Coreelec 8.90.0 works really well for me. Thought I'd let everybody know.

    Beelink MiniMXIII II 2GB, 32GB always running latest Libreelec from SD card. No issues so far(except for the ones already known or posted by me).

    Mecool m8s Pro+ which with widevine level 1, Android runs a hacked version of android TV.

  • I'm more than happy to give you my time and assist you if you make *some* effort at least.

    I think you dont know how many topics i`ve already read. I could say that I read all the pages of the Thread of kzsaq. And there was written that I need to download the DTB. I found some DTS in your Github and there was written that i need to convert the dts files. And thats why I ask you for the compiled DTBs...

    And please dont say something again. I ask politly and i wont have stress!


    Greeting`s

  • __:-)__ We've already explained, several times, that with CoreELEC you don't have to download anything. There is a device tree folder at the root of the SD card when you create it, and you get the DTB from there.

  • ir remote configued, it works good.

    but recovered from suspend mode,

    it doesnt..

    it works again after reboot.

  • now im wondering whether the problems i experience are related to updated dtb files.ive been updating from 8.2 to 8.90 pre alpha to coreelec and sometimes up and down from version to version with just .tar update files.maybe dtb file isnt updated correctly at some point.can someone please share the latest dtb file for kiii pro?i only have one usb drive that i boot from and i dont wanna write the new image on it and start from scratch.thank you.

  • I prefer the CE/LE built-in (if only because it doesn't require any other addons). The choice is yours, both of them just copy /storage/.kodi and some other key folders :)

    The CE one makes a complete carbon copy of your setup, whereas the Kodi one only copies key folders.

  • One thing I've noticed in the last few years is how many people want all their questions answered and free support for a free product. They don't want to spend the time researching and learning anything. Its the way society is headed I suppose. People Its all about how your ask for assistance and then how you show your gratitude. Respect that others are spending a lot of their personal time to help you resolve your issues. Perhaps just a little common courtesy is needed. Either that or go pay for a product that has a support element you can access.


    OK getting off my soapbox. I do appreciate all the effort from all the contributors to the Amlogic devices. I personally am at the age in my life that I don't have the energy to expend that all of you do. At 63 and spending the last 35 years working in this industry I just cant keep up with all of you smart developers. So in gratitude I say 'Thank You' for all that you do and I hope there will be others after you have burnt out and moved on.

    :)

  • now im wondering whether the problems i experience are related to updated dtb files.ive been updating from 8.2 to 8.90 pre alpha to coreelec and sometimes up and down from version to version with just .tar update files.maybe dtb file isnt updated correctly at some point.can someone please share the latest dtb file for kiii pro?i only have one usb drive that i boot from and i dont wanna write the new image on it and start from scratch.thank you.

    You can open the tar file with winrar, dig through the 3rdparty folder, you'll find the device_trees folder there.

  • You can open the tar file with winrar, dig through the 3rdparty folder, you'll find the device_trees folder there.

    thank you!as i suspected the problem was with the not updated dtb file.replacing the old one with this and...everythings working smoothly.thank you for all the efforts.