[8.90.1] CoreELEC for S905/S912 devices

  • Hei, so i have this problem, i was dumb enough to install to nand(adding the dtb file in the update folder). wasn't able to fix it using the dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256kcommand. managed to brick it. only way to get it work again was install lakka. I think i have broken the recovery button in the toothpick slot.
    So i tried to install again. just added the install to update of lakka. but it only install's once and then it isn't able to boot it.so i have installed lakka again i figured i might as well boot libreelec from sd card but now it wont boot from sd card either.


    any ides on how to get that working again?

    Thanks

  • Hei, so i have this problem, i was dumb enough to install to nand(adding the dtb file in the update folder). wasn't able to fix it using the dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256kcommand. managed to brick it. only way to get it work again was install lakka. I think i have broken the recovery button in the toothpick slot.
    So i tried to install again. just added the install to update of lakka. but it only install's once and then it isn't able to boot it.so i have installed lakka again i figured i might as well boot libreelec from sd card but now it wont boot from sd card either.


    any ides on how to get that working again?

    Thanks

    If it won't boot from USB then you are using the wrong DTB, this would also explain why you have also bricked your device if you have been using the wrong one.

  • it did boot from the sdcard after my first brick. i tried using the installtointernal, but that wasn't working. and after reading here why i gave up on that. and thats when i figured lakka might work as nothing else was. tried installing twrp but couldn't get it to boot that either. and i tired installing the LibreELEC-S905.arm-8.2-8.2.3.1-temp_sensor_disabled.im.tz but that didn't work either. and now it won't boot from sd card at all it seems, not even lakka. it might be that i need to wipe the sdcard.I am not sure.

  • so i finally got it to boot from sd again. is there anyway to install it? or should i just give up on that?

    If it works from SD card then the dtb is correct and so installtointernal should transfer it to internal and it should work. Can take two runs of the installtointernal script to bed it in. However since you have encountered problems so far running from SD might be more sensible.


    Shoog

  • If it works from SD card then the dtb is correct and so installtointernal should transfer it to internal and it should work. Can take two runs of the installtointernal script to bed it in. However since you have encountered problems so far running from SD might be more sensible.


    Shoog

    the problem is i'm not able to use install to internal command, if i understand correctly it's been disabled. the reason it wont work i think is becuase i'm not able to install it twice. but yeah you are probably right

  • Hello everyone.

    I just tested the latest Devel (09/04/2018) on the box GT1 Beelink S912 @ 3go DDR3 :

    With gxm_q200_2g.dtb it works, but only 2go are declared.

    With gxm_q200_3g.dtb, the box blocks on the "Beelink" startup.


    An idea ?

  • the problem is i'm not able to use install to internal command, if i understand correctly it's been disabled. the reason it wont work i think is becuase i'm not able to install it twice. but yeah you are probably right

    It was reintroduced into the latest devel builds. You need to ssh into a the running Libreelec to run it.

    However if you need this much assistance to run it maybe its not right for you.


    Shoog

  • What does that mean ?

    It means the downloads have been removed for the moment and you will have to wait for an official CoreElec thread to make them available again.


    Shoog

  • It was reintroduced into the latest devel builds. You need to ssh into a the running Libreelec to run it.

    However if you need this much assistance to run it maybe its not right for you.


    Shoog

    i am running libreelec on the sd card, and using the ssh and install to internal. i just keep getting


    LibreELEC (community): 8.90.6 (S905.arm)

    LibreELEC:~ # installtointernal

    -sh: installtointernal: not found


    I have done this before with previous builds and no trouble.

  • Its not in the 8.90.6 build, its in the later devel builds - which have now been taken down ready for an official release. You will have to wait till they are released.


    Shoog