[8.90.1] CoreELEC for S905/S912 devices

  • The 400mbps version plays without issue when I last tried from the eMMC, playback issues most often happen when playing via samba and/or wifi.

    If I "echo '420,10bit'... hint, hint :angel:


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray

  • If I "echo '420,10bit' > /sys/class/amhdmitx/amhdmitx0/attr" than this file plays fine, I also have a 140mbps version of this file, and it also plays bueno;)

    thanks, let me test again.

  • After updating to today's devel I have changed color space to 420 8 bits on my s905 Beelink minimxiii, and now I got locked out of the interface as my LG 4K Smart TV shows the screensaver after the LibreELEC logo.

    Is there a way to revert or change color pace from command line?

    Also, I did some search to look for correct settings for my box but could not find anything conclusive. What would be the right settings for s905 and s912 boxes, provided the TV supports the mode.


    Beelink MiniMX III 2GB/16GB gigabit LAN

    Edal T95Z Plus s912 2GB/16GB gigabit LAN

    LibreELEC running from SD card (will confirm version on post).

    Slowly being replaced by Intel NUCs (7th/8th gen i3/i5).

  • It was two builds from the beginning.

    Two builds yes, but most would presume from the same camp.

    Not really a place for the impatient to be chucking in their attempts. They belong in a different thread where it is made clear that it might be evolving differently than the @adamg & co builds =O

    That is, of course, presuming @boot2k3 isn't currently secretly developing in the @adamg stables, and we just didn't know ^^

    Raybuntu The Coolest afl1 and boot2k3 and myself are now all contributing to the Amlogic builds to make them better for everyone.


    Edited once, last by Poida ().

  • same thing happened to me. you have two options. i have tried both and it works.

    1. use the kodi remote from appstore/playstore to change the color space to 444,10bit then reboot

    2. ssh to the box, you can use nano

    - systemctl stop kodi

    - edit guisettings.xml from /storage/.kodi/userdata/ and change the setting to

    <setting id="videoscreen.colourspace">444,10bit</setting>

    - systemctl restart kodi

  • Strongly v5.90.7 !

    v5.90.7 what? /shrug

  • seems like a bunch of random numbers to me.

    'You're like a child who wanders into the middle of a movie and wants to know -..' ~ Walter Sobchak (The Big Lebowski)

  • Just a quick thanks GDPR-2 for the latest build w/colorspace options in settings.

    Kodi with full 3D & HD audio home theater enthusiast

  • Just noticed that my disp_cap file contained both 2160p50/60hz and 2160p50/60hz420.

    Made a copy to userdate and removed 2160p50/60hz. So auto switch to 2160p50/60hz works fine ;)


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray

  • I'm using an Odroid C2 and are having issues with an outdated inputstream plugin and Amazon VOD. Already tried a few solutions e.g. an updated sh script from Kodifans forum ... seemingly worked with your build.

    Can I switch from rb leila24 builds via upgrade or should I do a clean flash (I'm getting used to constantly reflashing it ... kinda funny that I wanted a stable box going away from my old Minix Neo 2 Mini Android Box).

  • To adamg. Will these builds be a departure from the standard Libreelec images?

    Beelink MiniMXIII II 2GB, 32GB always running latest Libreelec from SD card. No issues so far(except for the ones already known or posted by me).

    Mecool m8s Pro+ which with widevine level 1, Android runs a hacked version of android TV.

  • I just noticed that Netflix is no longer working on my Beelink (S905x).

    Last working version for me was 8.90.4

    Now it does not work with all newer devel-versions from adamg and also not with the

    S905-devel version from test.libreelec.tv.

    Netflix- and Inputstream-adaptive settings are exactly the same.


    The login to Netflix is ok, I can browse the movies.

    But when I start a movie (SD or HD), the 'working'-info appears

    in the lower right corner of the screen and then dissappears again without error message.

    No switching to the movie.

    I installed Netflix from GitHub - asciidisco/plugin.video.netflix: Inputstream based Netflix plugin for Kodi

    Are there any logfiles I can provide?

    Box: Beelink Mini MXIII II (S905X/2GB/32GB SD)

    running: LE (thanks @kszaq) and CE 8.90.0 (thanks @adamg + @afl1)

    Edited once, last by pepeq ().

  • there seems to be a problem on the netflix addon. check the issues on the github.

  • I can't speak for the LE build but it works fine on mine with the latest version from GitHub and the latest libwidevine.so, tested yesterday.

  • GDPR-2:

    you are right,Netflix runs on 8.90.4 and your devel-versions also.

    My problem was that I did an fresh install of 8.90.4 and updated with your latest devel-tarfile


    Then I installed the Netflix-addon (download hereGitHub - asciidisco/plugin.video.netflix: Inputstream based Netflix plugin for Kodi),

    configured the Netflix-login.: But I forgot to install the libwidevine then. On my daily-use 8.90.4 SD-card the libwidevine exists

    from a former version, so Netflix runs there without problems.

    So for all who want to run Netflix, read the following:

    [8.90.6] LibreELEC 9.0 Alpha for S905/S912 devices



    Box: Beelink Mini MXIII II (S905X/2GB/32GB SD)

    running: LE (thanks @kszaq) and CE 8.90.0 (thanks @adamg + @afl1)