[8.90.1] CoreELEC for S905/S912 devices

  • hi GDPR-2


    timeshift tvh wetek play2 with all build LE9 is not stable . but in LE8.2 is stable fine


    What is the problem ??

    Could it be that this is an unstable Alpha built?

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • Set colour space in video settings and reboot


    Latest version uses kszaq kernel from 8.90.4

    GDPR-2:

    can you please add "420,10bit" and "420,8bit" to available colour space options in video settings

    in your next devel build for testing?



    Box: Beelink Mini MXIII II (S905X/2GB/32GB SD)

    running: LE 8.2.3.1 (thanks @kszaq) and CE 8.90.0 (thanks @adamg + @afl1)

  • GDPR-2:

    can you please add "420,10bit" and "420,8bit" to available colour space options in video settings

    in your next devel build for testing?

    And maybe an auto change when playing UHD 420,10bit 59/60hz. ;)

    -2re


    8.90 ⇒ MeCool KI Pro ⇒ Onkyo TX-NR656 ⇒ SAMSUNG 65"LED/UHD/PQ1300/T2CS

    LG BP50NB40 USB Blu-ray


  • I´m testing this devel Version LibreELEC-S905.arm-9.0-devel-1522739536.img.gz


    installed on my Mecool K1pro


    first had to change color space (green screen) using rgb 8 bit now


    Amazon addon working sd Quality films and HD Quality series - had to reduce to 720p otherwise series stuttering


    live tv with dvbviewer client ok - takes some seconds until picture is seen but then lipsync ok with AC3 passtrough enabled

    no more slomo vogon lyric voices after zapping so far


    sometimes restart problems - hangs on Mecool logo until power plug is removed


    TVheadend : with standard drivers nothing to configure because no hardware adapter seen

    enabled crazycat drivers, after this the internal Availink avl6862 adapter is recognized

  • I have been testing the latest (*39536) dev build.

    System is m8s mini (s905).


    I am noticing black screen and/or freezes of the video while audio continues with LiveTV.


    I reproduced as follows:

    -Installed latest devel

    -Minimal settings (region,..)

    -Installed tvmozaic/dvblink addon

    - Turn on Debug Logging (comp: A/V/Timing)


    -Start Channel (HD). AV fine

    - Next Channel (HD) AV fine

    - Next Channel (HD) AVFine

    - Next Channel (SD) Image freezes, sound continues (about 8 secs before catching up)

    -Next Channel (SD) Fine

    -Next Channel (SD) Image freezes, sound continues

    - Next Channel (SD) Image freezes, sound continues

    - Next Channel (SD) Image freezes, sound continues

    - Stop


    Log attached.


    Regards,

    Atreyu

    Files

    • 01_KODI.zip

      (504.25 kB, downloaded 14 times, last: )

    'You're like a child who wanders into the middle of a movie and wants to know -..' ~ Walter Sobchak (The Big Lebowski)

  • Gaudi and Everyone, please read the rules in the opening posts of this thread before posting issues!

    Filling the thread with issues when there are several builds out there makes debugging very difficult for the devs, when trying to sift through this thread and understand whether an issue is relevant or not.

    I agree and am sorry. I thought the issue was already identified. Will report following instructions and avoid the "troll" behaviour.

    Am very sorry about it.

    Beelink MiniMX III 2GB/16GB gigabit LAN

    Edal T95Z Plus s912 2GB/16GB gigabit LAN

    LibreELEC running from SD card (will confirm version on post).

    Slowly being replaced by Intel NUCs (7th/8th gen i3/i5).

  • testing the latest devel version on s905x box. overall its ok. thumbs up!


    but it seems, it can't play high bitrate files like below. picture just freezes. the same file works on 8.90.3 coming from the same source. i will try and test more.


    jellyfish-120-mbps-4k-uhd-hevc-10bit.mkv

  • @adamg

    If an issue occurs, when do I grab the log file to provide (and are you just after kodi.log) ?

    In other words, is the log file more informative taken at the time of issue (if possible) or at reboot?

    Noticed a peculiarity but so far only once - not sure if it was a one-off glitch (after watching steaming content and pressing stop, kodi didn't seem to be able to recover the GUI)


    EDIT:

    I think it might've just been a bit of a glitch with the addon. Probably not worth looking at unless it happens again ;)

    Edited once, last by Poida ().

  • GDPR-2, wrxtasy fixed the gui tearing for S912 devices for subtitle stuttering here.


    Is it possible to add this to your next testbuild?


    Thanks!

    I could but wrxtasy does not publish his changes online so without knowing what changes he has made it makes it kind of difficult.

  • GDPR-2 I have to say the 4/3/18 devel build is solid. A lot of the IPTV and HLS stream stuttering and a/v syncing issues are gone. Even some of the 1080p streams with inputstream have improved. Same goes with passthrough issues as well. I've been testing on my Tronsmart S95 Meta for about six months and it finally seems happy. Great work and thanks!

  • I could but wrxtasy does not publish his changes online so without knowing what changes he has made it makes it kind of difficult.


    i don't think many code changes where done, just need to disable dirty regions is what i'm getting from wrxtasy's post

  • i don't think many code changes where done, just need to disable dirty regions is what i'm getting from wrxtasy's post

    He disabled dirty regions ( <algorithmdirtyregions>0</algorithmdirtyregions> ) and set GPU clock to 792MHz.

  • GDPR-2 I have to say the 4/3/18 devel build is solid. A lot of the IPTV and HLS stream stuttering and a/v syncing issues are gone. Even some of the 1080p streams with inputstream have improved. Same goes with passthrough issues as well. I've been testing on my Tronsmart S95 Meta for about six months and it finally seems happy. Great work and thanks!

    I've tried this on my Minix U1 connected to Onkyo receiver and 4K tv. All seems to work fine so far!

    2xMinix U1, Onkyo NR626 and Samsung 40" 4K TV